Blocks speak! Do you have an interest in getting more blocks - or even making your own? The Blocks Board is for you!


SimplePortal

SimplePortal's bugs.

Bug Issue: Portal is hidden when adding anything to the url

Pages: [1]   Go Down

Offline Doctor Deejay

  • Localizer
  • Language
  • *
  • Posts: 797
  • Gender: Male
« on: May 30, 2012, 03:24:39 AM »
Okay, I don't know if it's supposed behavior, but it happens on this site too, only a bit different. When you go to an url like this:

Code: [Select]
http://localhost/simpleportal/index.php?test
The portal blocks will be hidden. It just shows an empty SMF page, with only the header, footer and linktree. The weird thing is, on this site, it only hides the right panel and its collapse button. Thoughts?
Doctor Deejay
Simple Portal - Language Team
SMF - Localizer
Vienara - Lead Developer

Backup both your files and database before modifying anything!

Offline AngelinaBelle

  • Support
  • *
  • Posts: 4881
  • Gender: Female
« Reply #1 on: September 19, 2012, 06:06:07 AM »
Which blocks go missing seems to vary considerably.
For a plain-jane installation of SMF 2.0.2 and SimplePortal 2.3.5
* http://rockhallsailingclub.org/smf2prep/index.php -- normal
* http://rockhallsailingclub.org/smf2prep/index.php?blah -- all blocks missing

But see a couple of seemingly-identical, outdated installations of Simple Portal (both 2.0 RC4 with Simple Portal 2.3.3)
* http://www.rockhallsailingclub.org/smf2test/index.php -- normal
* http://www.rockhallsailingclub.org/smf2test/index.php?test -- left blocks are missing

* http://www.rockhallsailingclub.org/smf1test/index.php -- normal portal page
* http://www.rockhallsailingclub.org/smf1test/index.php?test -- left, right, and center all missing
* http://www.rockhallsailingclub.org/smf1test/index.php?action=portal -- right and center are missing
* http://www.rockhallsailingclub.org/smf1test/index.php?action=forum -- forum
* http://www.rockhallsailingclub.org/smf1test/index.php?action=test -- forum, with left blocks missing
« Last Edit: September 19, 2012, 06:24:16 AM by AngelinaBelle »
Please to keep this website running, if you like SimplePortal, make a
one-time subscription. Thank you for your support.

Have you tried the SimplePortal documentation?

Offline [SiNaN]

  • Mr. SimplePortal
  • Developer
  • *
  • Posts: 6387
  • The Amazing Coder!
« Reply #2 on: September 21, 2012, 03:05:34 PM »
This is intentional. If there is something in $_GET, the page will not be considered as the portal home page. It is designed like this so that URLs such as index.php?issue=123 or index.php?project=123 etc. aren't treated as portal home page. So if you have something which isn't an exception (ie. index.php?theme=123 is an exception) the page will be considered a non-portal page and only blocks which are set to display everywhere will be shown.
And slowly, you come to realize... It's all as it should be...

Offline AngelinaBelle

  • Support
  • *
  • Posts: 4881
  • Gender: Female
« Reply #3 on: October 02, 2012, 09:54:24 AM »
For index.php?action=portal, no "portal only" blocks show up.
Please to keep this website running, if you like SimplePortal, make a
one-time subscription. Thank you for your support.

Have you tried the SimplePortal documentation?

Offline velorooms

  • Jr. Member
  • **
  • Posts: 74
    • Velorooms
« Reply #4 on: January 07, 2013, 06:31:14 PM »
tested on my site, (front page mode) all you see are the articles.
Admin and Owner of Velorooms.com - Using SMF 2.0.3 and Simpleportal 2.3.5

Pages: [1]   Go Up

Issue Details

  • Reported
    May 30, 2012, 03:24:39 AM
  • Updated
    January 07, 2013, 06:31:14 PM
  • View Status
    Public
  • Type
    Bug
  • Status
    New
  • Priority
    Normal
  • Version
    2.3.x
  • Fixed in
    (none)
  • Assigned to
    (none)
  • Category
    Display

Tags



Powered by: SMF Project Tools 0.5.4 © Niko Pahajoki 2007-2011