Installation errors? Mod incompatibilities? Upgrade problems? Make your way over to the Install and Upgrade Support board for all your solutions!


SimplePortal

SimplePortal's bugs.

Bug Issue: Login on Custom pages redirects to BoardIndex

Pages: [1]   Go Down

Online ♦ Ninja ZX-10RR ♦

  • Spammer Hammer
  • Support
  • *
  • Posts: 1131
  • Gender: Male
  • Sniper Legends
    • Virtual Interactive Games Entertainment™
« on: October 27, 2015, 06:41:17 pm »
http://simpleportal.net/index.php?topic=14157.0

If you visit a custom page accessible to public and then try to login from there, they will redirect you to the board index no matter what you do.

Ref: http://simpleportal.net/index.php?topic=14156.msg70513#msg70513

The reason for this behavior is because custom pages do not have login_url set.

You can do change this behavior by opening /Sources/PortalPages.php

Find:
Code: [Select]
$page_id = !empty($_REQUEST['page']) ? $_REQUEST['page'] : 0;
Replace with:
Code: [Select]
$page_id = !empty($_REQUEST['page']) ? $_REQUEST['page'] : 0;

$_SESSION['login_url'] = $scripturl . '?page=' . $page_id;

That one fixes it. Adding to the bug tracker and marking it as solved as per the board rules.
« Last Edit: November 02, 2015, 11:20:57 pm by ? Ninja ZX-10RR ? »
Have you tried SimplePortal Documentation before asking? ;)
F.A.Q.  English Support  |  Blocks Support
Fancy Feature idea ?!  |  Blocks Requests
Themes & Graphics

▼ My job! ▼

No PMs for support unless it's a paid request. Thank you! :)
#OpIsis

Pages: [1]   Go Up

Issue Changes

Change Member Time
Version changed from 2.3.x to 2.3.x, 2.3.6 ♦ Ninja ZX-10RR ♦ January 18, 2016, 03:14:19 am
Issue renamed from "Login on Custom pages redirect to BoardIndex" to "Login on Custom pages redirects to BoardIndex" ♦ Ninja ZX-10RR ♦ November 02, 2015, 11:20:57 pm
Issue renamed from "Login on Custom pages redirect on BoardIndex" to "Login on Custom pages redirect to BoardIndex" ♦ Ninja ZX-10RR ♦ October 28, 2015, 02:56:09 am
Status changed from New to Confirmed ♦ Ninja ZX-10RR ♦ October 27, 2015, 06:44:10 pm
Category changed from (none) to Function ♦ Ninja ZX-10RR ♦ October 27, 2015, 06:44:10 pm

Issue Details

  • Reported
    October 27, 2015, 06:41:17 pm
  • Updated
    January 18, 2016, 03:14:19 am
  • View Status
    Public
  • Type
    Bug
  • Status
    Confirmed
  • Priority
    Normal
  • Version
    2.3.x, 2.3.6
  • Fixed in
    (none)
  • Assigned to
    (none)
  • Category
    Function

Tags



Powered by: SMF Project Tools 0.5.4 © Niko Pahajoki 2007-2011