collapse

* User Info

 
 
Welcome, Guest. Please login or register.
Did you miss your activation email?

* Who's Online

  • Dot Guests: 47
  • Dot Hidden: 0
  • Dot Users: 1
  • Dot Users Online:

* Shoutbox

Refresh History
  • Shoutbox is not for support!
  • Mstcool: :p *
    September 13, 2014, 07:55:49 PM
  • Mstcool: so when is a new version coming out? :o
    September 13, 2014, 07:55:45 PM
  • USFA: sorry thought was search no glasses
    September 06, 2014, 08:48:23 PM
  • USFA: rename forum
    September 06, 2014, 08:47:40 PM
  • Mstcool: Oh, ok, Sinan
    August 25, 2014, 10:19:15 PM
  • ArsenArsen: When i make them
    August 19, 2014, 12:20:20 AM
  • ArsenArsen: I had some mod ideas, i will put them.
    August 19, 2014, 12:19:45 AM
  • [SiNaN]: We could, but it's there as a reminder of some kind, that we should fill it in, somehow.
    August 18, 2014, 09:57:14 PM
  • Mstcool: Y don't u guys remove the customization section since it has no files?
    August 17, 2014, 10:27:28 PM
  • ArsenArsen: Ok, Great!
    August 15, 2014, 03:13:18 PM
  • [SiNaN]: We have the translators' names listed in the downloads area.
    August 15, 2014, 03:05:39 PM
  • ArsenArsen: Never Mind, i wont, noone did.
    August 15, 2014, 02:22:32 PM
  • ArsenArsen: Can i put mz name on translation
    August 15, 2014, 02:21:06 PM
  • [SiNaN]: You can only change your forum profile options once you have 5 posts. I have made an exception for Translator group though, so you should be able to do it now.
    August 13, 2014, 03:32:17 PM
  • ArsenArsen: Cant find where to change avatar
    August 13, 2014, 03:12:38 PM
  • ArsenArsen: Ok
    August 11, 2014, 05:17:55 AM
  • Underdog: there is a documentation link on your top-right
    August 10, 2014, 08:48:45 PM
  • ArsenArsen: What to use for docs? This is NoT SP support question.
    August 10, 2014, 02:55:55 PM
  • Ron-KK4HGY: Hello all!
    August 06, 2014, 03:22:50 PM
  • USFA: tada
    August 04, 2014, 09:49:45 PM

* Team Blog

* Recent Posts

NEED HELP? If you're looking for support with Simple Portal, look no further than the Support Board!

Author Topic: Multiple errors which appear to be shoutbox related  (Read 2523 times)

0 Members and 1 Guest are viewing this topic.

Offline Phåråoh

  • Semi Newbie
  • *
  • Posts: 11
  • SMF Version: 2.0.2
  • SP Version: 2.3.5
Multiple errors which appear to be shoutbox related
« on: September 18, 2012, 08:35:42 PM »
Hello,

I have SMF 2.0.2, SMF Media Gallery 2.0.5 and Simple Portal 2.3.5

After installing the SP shoutbox, I started getting huge number of undefined errors in my error log, most of which include the shoutbox.  These are errors in the gallery, the search, profile, PMs, search,... just about everything... hundreds a day.  I have no idea if this is all related to the shoutbox but every error includes it and all of the errors seem to generate from the Sources/Subs.php file.  Here are several examples:


http://www.classicwinnebagos.com/forum/index.php?action=portal;sa=shoutbox;shoutbox_id=4;time=1347951246;xml
8: Undefined index: logout
File: .../forum/Sources/Subs.php
Line: 4356

http://www.classicwinnebagos.com/forum/index.php?action=portal;sa=shoutbox;shoutbox_id=4;time=1347951246;xml
8: Undefined index: register
File: .../public_html/forum/Sources/Subs.php
Line: 4348

http://www.classicwinnebagos.com/forum/index.php?action=portal;sa=shoutbox;shoutbox_id=4;time=1347951246;xml
8: Undefined index: mlist_search
File: .../public_html/forum/Sources/Subs.php
Line: 4333

http://www.classicwinnebagos.com/forum/index.php?action=portal;sa=shoutbox;shoutbox_id=4;time=1347951246;xml
8: Undefined index: members_title
File: .../public_html/forum/Sources/Subs.php
Line: 4323

http://www.classicwinnebagos.com/forum/index.php?action=portal;sa=shoutbox;shoutbox_id=4;time=1347951246;xml
8: Un.../public_html/forum/Sources/Subs.php

 http://www.classicwinnebagos.com/forum/index.php?action=portal;sa=shoutbox;shoutbox_id=4;time=1347951246;xml
8: Undefined index: smfstore_menu
File: .../public_html/forum/Sources/Subs.php
Line: 4297

http://www.classicwinnebagos.com/forum/index.php?action=portal;sa=shoutbox;shoutbox_id=4;time=1347951246;xml
8: Undefined index: calendar_post_event
File: .../public_html/forum/Sources/Subs.php

http://www.classicwinnebagos.com/forum/index.php?action=portal;sa=shoutbox;shoutbox_id=4;time=1347951246;xml
8: Undefined index: bookmarks
File: .../public_html/forum/Sources/Subs.php
Line: 4270 

http://www.classicwinnebagos.com/forum/index.php?action=portal;sa=shoutbox;shoutbox_id=4;time=1347951246;xml
8: Undefined index: forumprofile
File: .../public_html/forum/Sources/Subs.php
Line: 4244

http://www.classicwinnebagos.com/forum/index.php?action=portal;sa=shoutbox;shoutbox_id=4;time=1347761490;xml
8: Undefined index: search_on
File: .../public_html/forum/Sources/Subs.php
Line: 1439

I think you get the idea.  696 errors in 3 days and these were light traffic days.  There have been over 1,200 on heavier traffic in the same amount of time.

I have a member who is on the site almost all the time and is generating tons of these errors.  Some of them are a little disturbing.  I'm seeing such things in the "8: Undefined index:" as "modlog_view" "moderate" "edit_permissions" "code" code_slect" "theme_language_error" "mc_reported_posts" "errlog" "package""mod_settings" and "admin" among others. 

Is this person hacking the site?

Any help would be greatly appreciated. 
« Last Edit: September 18, 2012, 08:55:55 PM by Phåråoh »

Offline AngelinaBelle

  • Support
  • *
  • Posts: 4885
  • Gender: Female
  • SMF Version: 2 RC3
  • SP Version: 2.3.2
Re: Multiple errors which appear to be shoutbox related
« Reply #1 on: September 18, 2012, 11:39:07 PM »
This sounds like a language file problem.

Line 1439 is probably within parse_bbc, and referring to $txt['search_on']
In fact, there is also a $txt['forumprofile']

So I am going to guess that these are all missing $txt strings.  It is as though you have an incomplete language file, or an old language file from a much earlier version of SMF.
Are you using a UTF8 forum, or not?
What is the appropriate index.english*.php file? What version is it?
Can you find $txt['forumprofile'] in your language file?

Do  you have the same problem no matter which theme you use? Each theme can have its own language files.
Please to keep this website running, if you like SimplePortal, make a
one-time subscription. Thank you for your support.

Have you tried the SimplePortal documentation?

Offline Phåråoh

  • Semi Newbie
  • *
  • Posts: 11
  • SMF Version: 2.0.2
  • SP Version: 2.3.5
Re: Multiple errors which appear to be shoutbox related
« Reply #2 on: September 19, 2012, 08:24:52 PM »
  • The forum is UTF8.
  • The forum is SMF 2.0.2, fresh build, imported database info from 2.0 RC1.
  • Default theme, but with CSS and some minor language (english) changes.  No text strings, just what appears in place of the default text.
  • I don't use any other theme, never have, never will.
  • The index.english*php file is version 2.0
  • Yes, $txt['forumprofile']is in this file.
Both the index.english and subs files are attached, if that'll help.
This is way beyond my rudimentary knowledge.  Thanks!

Offline AngelinaBelle

  • Support
  • *
  • Posts: 4885
  • Gender: Female
  • SMF Version: 2 RC3
  • SP Version: 2.3.2
Re: Multiple errors which appear to be shoutbox related
« Reply #3 on: September 20, 2012, 01:44:17 PM »
You need to have, and to use, the UTF8 version of your language files.  Please download the correct language files from SMF, and from Simple Portal, as well.

You might try repair_settings (ask for help on that at simplemachines.org.  They are very good with this)
And check that your SMF is loading the correct language files.

Please to keep this website running, if you like SimplePortal, make a
one-time subscription. Thank you for your support.

Have you tried the SimplePortal documentation?

Offline Phåråoh

  • Semi Newbie
  • *
  • Posts: 11
  • SMF Version: 2.0.2
  • SP Version: 2.3.5
Re: Multiple errors which appear to be shoutbox related
« Reply #4 on: December 15, 2012, 08:57:26 PM »
Update. 

I did try the repair settings and that had no effect.  However, today I got a massive amount of errors in addition to the types I mentioned originally.  But, one thing was significantly different:  All the errors were generated by one member and the errors were occurring in Admin areas!  This member has no admin privelages.  It then dawned on me that, a couple years ago, I read that ajax chats can pose a security issue.  I also noticed that one of the first errors in this massive barrage was "code inserted".  I've never seen that one before..  I began to wonder if I wasn't under a hacking attempt so I banned the member.  That was at 6:00 am this morning.  I've  had only the normal errors since:  incorrect password, registration still pending approval, ...

I'll know for sure over the next few days.

It would be nice not to have 700 to 1,200 errors to clear every day and no logical explanation for it.

Is it possible to shed some light on the potential for security issues with ajax chats?  Or, it's already here, a link to that info would be greatly appreciated!

Offline Phåråoh

  • Semi Newbie
  • *
  • Posts: 11
  • SMF Version: 2.0.2
  • SP Version: 2.3.5
Re: Multiple errors which appear to be shoutbox related
« Reply #5 on: December 15, 2012, 10:36:32 PM »
Update 2.

I spoke with the member and he ran a virus scan to see if there might be a program attaching with his logon - negative results.

However, it was discovered that the errors occurred while he was playing World of Tanks.  This could be a valid suspect for the issue.  I'm going to change the shoutbox program and see if it happens again.

Offline Phåråoh

  • Semi Newbie
  • *
  • Posts: 11
  • SMF Version: 2.0.2
  • SP Version: 2.3.5
Breach found with Simple Portal shoutbox.
« Reply #6 on: December 18, 2012, 12:21:57 PM »
Yup, it was definitely the World of Tanks somehow leaking in through the Simple Portal shoutbox and wreaking havoc in the error log.  Thoroughly tested the theory and there's no doubt about it.

The gamer keeps a persistent connection with the game and also with my website.  When the game is not actively being played, I got the daily, big bag of errors associated with any member.  When he actively played the game, the deluge of errors specifically connected with his username and IP came and affected all areas of website. 

I banned the member, all errors stopped.  I unbanned the member, the errors began again.  When the member played the game, errors increased to include admin areas and all under his username again.

I deactiveated the Simple Portal Shoutbox, the member could play or not play, no errors.  Activated the shoutbox... bang... errors like a Los Angeles traffic jam.

Well, the Simple Portal was a nice little shoutbox while it lasted but, with that kind of open door, I had to ditch it and went back to using the SMFPacks shoutbox.  No errors at all since.

Maybe the Simple Portal shoutbox back door needs to be checked?  There's definitely some kind of issue between it and The World of Tanks game.

Offline AngelinaBelle

  • Support
  • *
  • Posts: 4885
  • Gender: Female
  • SMF Version: 2 RC3
  • SP Version: 2.3.2
Re: Multiple errors which appear to be shoutbox related
« Reply #7 on: January 16, 2013, 12:55:11 PM »
It is surprising that world of tanks was apparantly trying to make a connection to your forum. It is as though it was picking something up from the browser and sending some kind of document (possibly including forms data) to the shoutbox URL.

I am not sure how or why the game was picking such stuff out of the browser and re-using it.

It would be an interesting experiment to add a little piece to capture samples of documents and posted data that this user sends during world of tanks sessions.
Please to keep this website running, if you like SimplePortal, make a
one-time subscription. Thank you for your support.

Have you tried the SimplePortal documentation?

Offline Phåråoh

  • Semi Newbie
  • *
  • Posts: 11
  • SMF Version: 2.0.2
  • SP Version: 2.3.5
Re: Multiple errors which appear to be shoutbox related
« Reply #8 on: January 16, 2013, 02:54:07 PM »
It certainly is an odd thing.  It's almost as if the gaming "wires" so to speak, were crossing with the shoutbox "wires" across the persistent connections and jingling error bells through many different areas of the forum code.

I've been using the other shoutbox since and the errors no longer occur. 

Offline AngelinaBelle

  • Support
  • *
  • Posts: 4885
  • Gender: Female
  • SMF Version: 2 RC3
  • SP Version: 2.3.2
Re: Multiple errors which appear to be shoutbox related
« Reply #9 on: January 23, 2013, 11:54:52 AM »
That probably makes the most sense. Without more information, I cannot hazard a guess as to what is going on.

I would assume that the game is erroneously picking up on a recent shoutbox xml request URL (make shout, receive shouts), and using it to try to do whatever it does.

I don't know what the contents of the request document sent to the shoutbox are, or why your game is persistantly using the shoutbox URL (and for what).

For now, I think it best to mark this solved, as you have simply decided the two products are incompatible and moved on.

Sound OK to you?
Please to keep this website running, if you like SimplePortal, make a
one-time subscription. Thank you for your support.

Have you tried the SimplePortal documentation?

Offline Phåråoh

  • Semi Newbie
  • *
  • Posts: 11
  • SMF Version: 2.0.2
  • SP Version: 2.3.5
Re: Multiple errors which appear to be shoutbox related
« Reply #10 on: January 24, 2013, 09:17:56 AM »
Solved. 

The issue is definitely beyond the normal scope of typical errors and corrections and, it could even be server related.  I've since migrated from HostMonster to a new, non-reselling server for several reasons and all errors aside from failed-logins, etc. have stopped.

Thank you for your attention and thought to this issue.

Offline AngelinaBelle

  • Support
  • *
  • Posts: 4885
  • Gender: Female
  • SMF Version: 2 RC3
  • SP Version: 2.3.2
Re: Multiple errors which appear to be shoutbox related
« Reply #11 on: January 25, 2013, 09:57:09 AM »
I'm glad to hear it!
Please to keep this website running, if you like SimplePortal, make a
one-time subscription. Thank you for your support.

Have you tried the SimplePortal documentation?