collapse

* User Info

 
 
Welcome, Guest. Please login or register.
Did you miss your activation email?

* Who's Online

  • Dot Guests: 52
  • Dot Hidden: 0
  • Dot Users: 0

There aren't any users online.

* Shoutbox

Refresh History
  • Shoutbox is not for support!
  • Underdog: there have been recent host changes and most likely issues due to configuration during that process. all should be resolved now please let us know of any further issue in this board: [link]  .. Thank you.
    Yesterday at 05:41:39 pm
  • BurkeKnight: Well, sometimes that error does show, like I said, when don't even get to the server. I have yet to figure out why...lol... However, there are times that you will see a msg about server stress here, but I have yet to get a 500 error, myself. And I'm here about 30 times a day, checking for new posts. :P
    Yesterday at 05:18:38 am
  • SeeingBlue: I was under the impressions that 500 Internal Server Error are only produced by the server(aka your site). Plus sanb below said he was having the same issue. Anyways just trying to help, not arguing.
    December 19, 2014, 06:59:40 pm
  • BurkeKnight: SeeingBlue, it may not be this end. There may be an issue in the connection from you to the SP site, that shows that. I know things like that can happen, due to the fact I had issues on my own site before, yet no one else did, nor were there any logs on it.
    December 19, 2014, 02:46:05 pm
  • ♦ Ninja ZX-10RR ♦: I'm not admin nor a staff member... I tried connecting with a different IP and via proxy. No errors...
    December 18, 2014, 01:15:06 pm
  • SeeingBlue: You've just been lucky, Ninja. There is a problem. Check your stats and see how many 500 error hits you've been getting.
    December 18, 2014, 08:08:56 am
  • ♦ Ninja ZX-10RR ♦: The server might be have a high load but it still works here...
    December 17, 2014, 03:13:51 pm
  • sanb: i cant post a reply(
    December 17, 2014, 01:36:59 pm
  • SeeingBlue: It's intermittent. I bet if the admin logs into the cpanel they'll find either CPU or Ram hitting it's limit.
    December 17, 2014, 09:11:07 am
  • ♦ Ninja ZX-10RR ♦: The site works fine here...
    December 16, 2014, 11:01:27 am
  • SeeingBlue: I was finally able to make 1 post, but I can't edit it or make another. I'm frustrated, I give up.
    December 16, 2014, 08:49:37 am
  • SeeingBlue: I even tried a different browser. I'm just getting a 500 Internal Server Error.
    December 16, 2014, 08:30:15 am
  • SeeingBlue: When I "hit" post, sorry.
    December 16, 2014, 08:26:04 am
  • SeeingBlue: I'm trying to reply to my thread "Loading custom JS files" and when I get post it just loads a blank page.
    December 16, 2014, 08:25:43 am
  • Eliana Tamerin: Let's kick this over to his support topic, folks.
    December 03, 2014, 10:16:21 pm
  • Underdog: what is the issue with it? the naviagtion links? look here: [link]
    December 03, 2014, 09:54:07 pm
  • [SiNaN]: Oh! I didn't even see that. The author seems to have posted some instructions at the theme support topic at sm.org: [link]
    December 03, 2014, 02:11:58 pm
  • WhiteEagle: No the menu on top... the one that comes down when you mouse over it. ;)
    December 03, 2014, 02:02:35 pm
  • [SiNaN]: I already posted it!
    December 03, 2014, 01:51:11 pm
  • WhiteEagle: Any idea what I can do with the menu on top in that theme [SiNaN]?
    December 03, 2014, 01:28:25 pm

* Recent Posts

Installation errors? Mod incompatibilities? Upgrade problems? Make your way over to the Install and Upgrade Support board for all your solutions!

Author Topic: SMF Package Manager Blank  (Read 4920 times)

0 Members and 1 Guest are viewing this topic.

Offline Zaxxon

  • Semi Newbie
  • *
  • Posts: 6
  • SMF Version: 2.0.2
  • SP Version: 2.3.5
SMF Package Manager Blank
« on: December 23, 2012, 11:15:14 am »
When Simple Portal is installed, when I click "Browse Packages" the page comes up blank. Checking my Error Log, I see that I am getting a 404 error.

I did a search on the forums and I saw that someone had a similar issue where it was a PHP memory error. This does not appear to be the same case with me. Any help would be appreciated.

SMF 2.0.3
Simple Portal 2.3.5

The only way I can bring it back is if Simple Portal is uninstalled.

Offline Zaxxon

  • Semi Newbie
  • *
  • Posts: 6
  • SMF Version: 2.0.2
  • SP Version: 2.3.5
Re: SMF Package Manager Blank
« Reply #1 on: January 31, 2013, 03:15:46 pm »
I'm the only one with this problem then?

Offline Doctor Deejay

  • Localizer
  • Language
  • *
  • Posts: 827
  • Gender: Male
  • SMF Version: 2.0.2
  • SP Version: 2.3.5
Re: SMF Package Manager Blank
« Reply #2 on: February 02, 2013, 10:53:00 am »
Welcome to Simple Portal! :) Not sure if I understand your problem. Do you mean you have installed Simple Portal, but when trying to view the browse packages page in the admin panel, the page goes blank?

Have you changed any settings after installing Simple Portal and does it happen every time you want to view the page?
Doctor Deejay
Simple Portal - Language Team
SMF - Localizer
Vienara - Lead Developer

Backup both your files and database before modifying anything!

Offline Zaxxon

  • Semi Newbie
  • *
  • Posts: 6
  • SMF Version: 2.0.2
  • SP Version: 2.3.5
Re: SMF Package Manager Blank
« Reply #3 on: February 03, 2013, 01:37:02 am »
Welcome to Simple Portal! :) Not sure if I understand your problem. Do you mean you have installed Simple Portal, but when trying to view the browse packages page in the admin panel, the page goes blank?

Have you changed any settings after installing Simple Portal and does it happen every time you want to view the page?
Yes that is what I mean, thanks! I have had it installed for a long time so I'm not sure what all I've changed in settings. To ever get the Browse Packages page to show up, I have to uninstall SimplePortal and then everything is OK again. Tonight, I actually uninstalled it, downloaded SimplePortal 2.3.5 again and installed it and the same thing happens :(

I have it in StandAlone mode. Setting it to anything else other than Disabled has the same effect (a blank page for Browse Packages in SMF).

If I set it to Disabled, the page is populated again.

Also, it doesn't matter if I'm using the Curve theme or a custom theme.

Offline Doctor Deejay

  • Localizer
  • Language
  • *
  • Posts: 827
  • Gender: Male
  • SMF Version: 2.0.2
  • SP Version: 2.3.5
Re: SMF Package Manager Blank
« Reply #4 on: February 03, 2013, 04:09:50 pm »
Hmm, strange. Since how long do you have this problem? Since some days/weeks/months or since you've installed it?
Doctor Deejay
Simple Portal - Language Team
SMF - Localizer
Vienara - Lead Developer

Backup both your files and database before modifying anything!

Offline Zaxxon

  • Semi Newbie
  • *
  • Posts: 6
  • SMF Version: 2.0.2
  • SP Version: 2.3.5
Re: SMF Package Manager Blank
« Reply #5 on: February 03, 2013, 04:58:32 pm »
Hmm, strange. Since how long do you have this problem? Since some days/weeks/months or since you've installed it?

I believe since I've installed it. I think the original install was version SimplePortal 2.3.0. It seems to be a problem on my side, maybe some sort of incompatibility because I have not been able to find another issue like this from someone else.

Attached is my PHP configuration, if you'd like to look at it.

Offline Doctor Deejay

  • Localizer
  • Language
  • *
  • Posts: 827
  • Gender: Male
  • SMF Version: 2.0.2
  • SP Version: 2.3.5
Re: SMF Package Manager Blank
« Reply #6 on: February 04, 2013, 12:45:47 am »
I took a look at your phpinfo file, but I didn't find anything wrong. :/ Do you know if you have any other mods installed? If so, which?
Doctor Deejay
Simple Portal - Language Team
SMF - Localizer
Vienara - Lead Developer

Backup both your files and database before modifying anything!

Offline Zaxxon

  • Semi Newbie
  • *
  • Posts: 6
  • SMF Version: 2.0.2
  • SP Version: 2.3.5
Re: SMF Package Manager Blank
« Reply #7 on: February 04, 2013, 02:34:37 am »
1.   SA Facebook   2.0.2   [ Uninstall ]
2.   SimplePortal   2.3.5   [ Uninstall ]
3.   Stop Spammer   2.3.9   [ Uninstall ]
4.   httpBL   2.5.1   [ Uninstall ]
5.   Tapatalk SMF 2.0 RC5/Final Plugin   3.4.0   [ Uninstall ]
6.   Piwik Analytics   1.0.2   [ Uninstall ]
7.   Battlefield Rank avatars   1.0   [ Uninstall ]
8.   Simple Audio Video Embedder   2.0.6   [ Uninstall ]
9.   Ultimate Avatar Pack   1.1   [ Uninstall ]
10.   Metal Gear Avatars   1.0   [ Uninstall ]
11.   star wars avatars   1.0   [ Uninstall ]
12.   FF Colection Avatars   1.0   [ Uninstall ]
13.   Gaming Avatars   1.0   [ Uninstall ]
14.   Futurama Avatars   1.0   [ Uninstall ]
15.   iDownload - SMFAvatars   1.0   [ Uninstall ]
16.   Color Emoticon Avatars   1.0   [ Uninstall ]

The Avatars are pretty old but they are just images loaded into the avatar folder.

Offline Doctor Deejay

  • Localizer
  • Language
  • *
  • Posts: 827
  • Gender: Male
  • SMF Version: 2.0.2
  • SP Version: 2.3.5
Re: SMF Package Manager Blank
« Reply #8 on: February 04, 2013, 03:10:06 pm »
Okay, do you have any custom blocks set?
Doctor Deejay
Simple Portal - Language Team
SMF - Localizer
Vienara - Lead Developer

Backup both your files and database before modifying anything!

Offline Zaxxon

  • Semi Newbie
  • *
  • Posts: 6
  • SMF Version: 2.0.2
  • SP Version: 2.3.5
Re: SMF Package Manager Blank
« Reply #9 on: February 06, 2013, 01:48:08 pm »
I only have one custom block, which is an HTML block for Ventrilo server status. Deactivating it made no change unfortunately. The only block shown on my SMF is the Shoutbox as well.

Offline Doctor Deejay

  • Localizer
  • Language
  • *
  • Posts: 827
  • Gender: Male
  • SMF Version: 2.0.2
  • SP Version: 2.3.5
Re: SMF Package Manager Blank
« Reply #10 on: February 06, 2013, 03:14:26 pm »
Weird, really weird.. Could you install a test forum (same version of both Simple Portal and SMF as you have know, with no mods or custom themes installed) on the same host and tell us what happens when you install + activate Simple Portal?
Doctor Deejay
Simple Portal - Language Team
SMF - Localizer
Vienara - Lead Developer

Backup both your files and database before modifying anything!

Offline imamzw

  • Semi Newbie
  • *
  • Posts: 5
  • SMF Version: 2.0.7
  • SP Version: 2.3.5
Re: SMF Package Manager Blank
« Reply #11 on: February 02, 2014, 04:43:02 pm »
When Simple Portal is installed, when I click "Browse Packages" the page comes up blank. Checking my Error Log, I see that I am getting a 404 error.

I did a search on the forums and I saw that someone had a similar issue where it was a PHP memory error. This does not appear to be the same case with me. Any help would be appreciated.

SMF 2.0.3
Simple Portal 2.3.5

The only way I can bring it back is if Simple Portal is uninstalled.

Hi Zaxxon, My Package manager was error too, yes, that annoying blank page !.  In My opinion, it's caused by new SMF version isn't compatible with Simple Portal 2.3.5.  But my problem was solved !

Simply ways, just use filezilla or any file manager,  replace Source/Class-Package.php with an old working one.  You can grab from previous SMF version.

And problem SOLVED ! ;)
« Last Edit: February 05, 2014, 06:54:10 am by imamzw »

Offline AngelinaBelle

  • Support
  • *
  • Posts: 4885
  • Gender: Female
  • SMF Version: 2 RC3
  • SP Version: 2.3.2
Re: SMF Package Manager Blank
« Reply #12 on: February 05, 2014, 04:46:02 am »
This is a confusing error, for sure.   And not every user is seeing this error.
It is interesting the imamzw  was able to work around the problem by replacing Source/Class-Package.php.
imamzw -- can you please test -- try a copy of Source/Class-Package.php from the same version of SMF that you have installed.  One without any of the changes that any of your mods has made.
Either it works, and we need to look into what mods have done to Class-Package, or it does not work, and we need to compare the old Class-Package to the new Class-Package to look for clues to the problem.

In the end, the issue might be an SMF issue or a SimplePortal issue, or just one of those "who would have thought that would have happened" sort of things.

A 404 error is usually "file not found".  The question is -- which file is not being found, and why?
What does the error log file say?
If you "view source" from the Browse Packages page, what does the source say (sometimes invisible things contain useful information)
Please to keep this website running, if you like SimplePortal, make a
one-time subscription. Thank you for your support.

Have you tried the SimplePortal documentation?

Offline imamzw

  • Semi Newbie
  • *
  • Posts: 5
  • SMF Version: 2.0.7
  • SP Version: 2.3.5
Re: SMF Package Manager Blank
« Reply #13 on: February 05, 2014, 06:45:14 am »
@AngelinaBelle:

I'm using SMF 2.0.7 (totally update from SMF 2.0.6).

I've search for the problem before.  It says that the problem was in hosting provider, then I checked, there wasn't a problem for the host nor the PHP upload limit, etc.

Yes it's weird, I installed Simple Portal 2.3.5 on my new SMF 2.0.7. Then i unistalled Simple Portal, installed again, just like for a few times, then I conclude that my new version of SMF was unsuitable with Simple Portal 2.3.5.  And i replace Source/Class-Package.php with Source/Class-Package.php from SMF 2.0.6.

I'm comparing that 2 files now, using NotePad++ and Compare Plugins, and here the differences (on line 576) :

Class-package.php from SMF 2.0.7 :

Code: [Select]
$data = strtr(preg_replace_callback('~&#(\d{1,4});~', create_function('$m', 'return chr("$m[1]");'), $data), $trans_tbl);
Class-package.php from SMF 2.0.6 (the working one, original - never "touched" by any plugins) :

Code: [Select]
$data = strtr(preg_replace('~&#(\d{1,4});~e', "chr('\$1')", $data), $trans_tbl);
I send the attachments of that files.
« Last Edit: February 05, 2014, 06:56:04 am by imamzw »

Offline AngelinaBelle

  • Support
  • *
  • Posts: 4885
  • Gender: Female
  • SMF Version: 2 RC3
  • SP Version: 2.3.2
Re: SMF Package Manager Blank
« Reply #14 on: February 06, 2014, 06:50:17 pm »
Very odd, to be sure.
Please try the solution from imamzw, to see if it helps.

Then, whatever happens, I will share this information with the devs at SimpleMachines.org.
It is possible that the problem is afflicting installs of other mods as well.
Perhaps the SMF team will want to make some change in the future.
Perhaps the SMF team will want to tell mod authors to do something differently in the future, because of the change in 2.0.7
I do not know the answer, but I think it will be good to share some useful information with devs all around.
Please to keep this website running, if you like SimplePortal, make a
one-time subscription. Thank you for your support.

Have you tried the SimplePortal documentation?

Offline Underdog

  • Support
  • *
  • Posts: 918
  • Gender: Male
  • On Hiatus
    • WebDev
  • SMF Version: 2.0.9
  • SP Version: 2.3.6
Re: SMF Package Manager Blank
« Reply #15 on: February 07, 2014, 05:21:22 pm »
This is an issue with SMF 2.0.7 itself and will most likely not be properly resolved until a SMF 2.0.8 release.
Due to the seriousness of the issue(s), hopefully this update will be released in a short time on the SMF download site.

  Since there were no security updates within SMF 2.0.7, I will advise you to revert to SMF 2.0.6 until the SMF development team resolves this issue.

Regards.
« Last Edit: February 07, 2014, 07:48:47 pm by Underdog »