collapse

* User Info

 
 
Welcome, Guest. Please login or register.
Did you miss your activation email?

* Who's Online

  • Dot Guests: 52
  • Dot Hidden: 0
  • Dot Users: 1
  • Dot Users Online:

* Shoutbox

Refresh History
  • Shoutbox is not for support!
  • Mulwa: if simpleportal team could make some of the blocks like articles to display photos just like how ebay does, it would be very great for shopping
    September 27, 2014, 08:24:14 AM
  • Mulwa: everybody is busy, no help for us this time
    September 26, 2014, 05:00:07 PM
  • [SiNaN]: That shows how simple but powerful SimplePortal is!
    September 26, 2014, 06:56:41 AM
  • oNLy1: thought the 'Blocks In Blocks' was going to be complicated - easy peasy - and was exactly what my site needed - ty
    September 20, 2014, 01:13:44 PM
  • P flex: Xup guys
    September 18, 2014, 08:29:06 AM
  • P flex: Xup
    September 18, 2014, 08:28:38 AM
  • Mstcool: :p *
    September 13, 2014, 07:55:49 PM
  • Mstcool: so when is a new version coming out? :o
    September 13, 2014, 07:55:45 PM
  • USFA: sorry thought was search no glasses
    September 06, 2014, 08:48:23 PM
  • USFA: rename forum
    September 06, 2014, 08:47:40 PM
  • Mstcool: Oh, ok, Sinan
    August 25, 2014, 10:19:15 PM
  • ArsenArsen: When i make them
    August 19, 2014, 12:20:20 AM
  • ArsenArsen: I had some mod ideas, i will put them.
    August 19, 2014, 12:19:45 AM
  • [SiNaN]: We could, but it's there as a reminder of some kind, that we should fill it in, somehow.
    August 18, 2014, 09:57:14 PM
  • Mstcool: Y don't u guys remove the customization section since it has no files?
    August 17, 2014, 10:27:28 PM
  • ArsenArsen: Ok, Great!
    August 15, 2014, 03:13:18 PM
  • [SiNaN]: We have the translators' names listed in the downloads area.
    August 15, 2014, 03:05:39 PM
  • ArsenArsen: Never Mind, i wont, noone did.
    August 15, 2014, 02:22:32 PM
  • ArsenArsen: Can i put mz name on translation
    August 15, 2014, 02:21:06 PM
  • [SiNaN]: You can only change your forum profile options once you have 5 posts. I have made an exception for Translator group though, so you should be able to do it now.
    August 13, 2014, 03:32:17 PM
Welcome to SimplePortal.net! You can download SimplePortal from the Download Page!

Author Topic: Forum button opening a new tab  (Read 915 times)

0 Members and 1 Guest are viewing this topic.

Offline Paley

  • Newbie
  • Posts: 2
  • SMF Version: 2.0.2
  • SP Version: 2.3.5
Forum button opening a new tab
« on: January 07, 2013, 04:34:39 PM »
For some reason my forum button is opening in a new window as opposed to simply redirecting to the forum page in the same window. How do I fix this?

Thanks.

Offline velorooms

  • Jr. Member
  • **
  • Posts: 74
    • Velorooms
  • SMF Version: 2.0.2
  • SP Version: 2.3.5
Re: Forum button opening a new tab
« Reply #1 on: January 07, 2013, 04:57:46 PM »
whats the site address.. will test here in a few browsers and have a quick look at the code..
Admin and Owner of Velorooms.com - Using SMF 2.0.3 and Simpleportal 2.3.5

Offline Paley

  • Newbie
  • Posts: 2
  • SMF Version: 2.0.2
  • SP Version: 2.3.5
Re: Forum button opening a new tab
« Reply #2 on: January 07, 2013, 05:25:16 PM »
It will not let me post the url on here for some reason. I feel like there is some code I simply need to remove somewhere but haven't the foggiest idea where to look for something like that.

Offline velorooms

  • Jr. Member
  • **
  • Posts: 74
    • Velorooms
  • SMF Version: 2.0.2
  • SP Version: 2.3.5
Re: Forum button opening a new tab
« Reply #3 on: January 07, 2013, 05:41:21 PM »
Right, couple of starters.

First you can post the name of the website without the www and the .com or .co.uk, google can do the rest.

Do you have portal set in the options as standalone, front page, or integration?

Second, you can have a look in the following file (assuming you have ftp access)..

Sources/subs.php

find where it says

Code: [Select]
// All the buttons we can possible want and then some, try pulling the final list of buttons from cache first.
and below you should see the array for the buttons on the menu bar, something like this.

Code: [Select]
$buttons = array(
'home' => array(
'title' => $txt['home'],
'href' => $scripturl,
'show' => true,
'sub_buttons' => array(
),
'is_last' => $context['right_to_left']

),

'forum' => array(
'title' => 'Forum',
'href' => $scripturl . '?action=forum',
'show' => true,
'sub_buttons' => array(
),
),

if it looks something like that , then theres no reason it should open in new window and its a forum settings somewhere.

my portal is set as FRONT PAGE.. I think standalone might cause it to see the forum as an external site and open in new window,
Admin and Owner of Velorooms.com - Using SMF 2.0.3 and Simpleportal 2.3.5

Offline AngelinaBelle

  • Support
  • *
  • Posts: 4885
  • Gender: Female
  • SMF Version: 2 RC3
  • SP Version: 2.3.2
Re: Forum button opening a new tab
« Reply #4 on: March 11, 2013, 01:26:51 PM »
Standalone vs Front page should not cause an issue like this.

Please check the following

* consider your "disable portal redirect" setting (see http://simpleportal.net/index.php?action=docs;area=general_settings)

* Also, check the following SMF and Simple Portal settings
  * Administration Center » Server Settings » Database and Paths -- forum URL
  * Administration Center » Server Settings » Cookies and Sessions  --  Use subdomain independent cookies
  * action=admin;area=portalconfig;sa=generalsettings -- Standalone URL
(though this is more related to login/logout oddities than to URL redirection)


Please to keep this website running, if you like SimplePortal, make a
one-time subscription. Thank you for your support.

Have you tried the SimplePortal documentation?