collapse

* User Info

 
 
Welcome, Guest. Please login or register.
Did you miss your activation email?

* Who's Online

  • Dot Guests: 85
  • Dot Hidden: 0
  • Dot Users: 0

There aren't any users online.

* Shoutbox

Refresh History
  • Shoutbox is not for support!
  • Jade Elizabeth: It's GREAT to see you too Sinan!! :D
    July 06, 2016, 02:33:26 am
  • [SiNaN]: Hey Jade! It's great to see you around! Jade!
    July 03, 2016, 06:51:31 am
  • Jade Elizabeth: Oops, sorry I mean HEY SINAN! ;)
    July 01, 2016, 11:07:13 am
  • Jade Elizabeth: Hey Sinan!! :D
    July 01, 2016, 11:06:59 am
  • [SiNaN]: But you shouldn't wait for a security issue and drop by more often. :D
    June 27, 2016, 04:32:18 pm
  • [SiNaN]: Hey ディン1031! It's great to see you around!
    June 27, 2016, 04:31:56 pm
  • ディン1031: Uh to long ago that i was last time here xD
    June 27, 2016, 02:03:08 pm
  • Schnuffeltier: :D
    June 24, 2016, 05:22:34 am
  • Jade Elizabeth: SHOUTBOX IS FOR SHOUTING AAAAAAHHHHHHHHHHH!!
    June 24, 2016, 12:57:05 am
  • [DFg]DJF-1975: Thank you, SP!
    June 21, 2016, 01:35:09 pm
  • Skhilled: phpBB is a good product but has a steeper learning curve.
    June 21, 2016, 08:19:04 am
  • ♦ Ninja ZX-10RR ♦: Hmm, not so sure about it, Eliana: [link]
    May 05, 2016, 02:03:02 am
  • Eliana Tamerin: That may have faded away now, or gotten better. I hope so. I see a lot of happy phpBB users, so I have to imagine someone is having success.
    April 25, 2016, 12:48:06 am
  • Eliana Tamerin: @andy, the phpBB folks had (at one point, not sure how it is now) a specific set of rules you had to follow to get support. Anyone not found doing so would have their topic ignored.
    April 25, 2016, 12:47:40 am
  • andy: SP team is a breath of fresh air...
    April 24, 2016, 11:24:32 pm
  • andy: Yes they are difficult to deal with at SMF. I never experienced anybody like that at phpbb several years ago.
    April 24, 2016, 11:24:03 pm
  • D.Va: Their team is very antagonistic and I prefer this forum and this staff far more. So kudos to SP for doing it right.
    April 24, 2016, 09:18:21 pm
  • andy: When SMF went gold there was a lot of optimism about progress and talk of 3.0.  Five years on and that soulds like SF.
    April 24, 2016, 08:37:31 pm
  • andy: Just my frustration at the slow pace of SMF. I suppose we have an alternative now.
    April 24, 2016, 08:34:38 pm
  • Burke Knight: Andy, as long as the SMF team keeps like they are doing, there's always going to be bugs, mainly due to SMF issues, because the team can't get their stuff straight.
    April 24, 2016, 08:25:41 pm

* Recent Posts

Re: Deleted block still showing!!! by Chen Zhen
[Today at 11:48:52 am]


Re: Deleted block still showing!!! by habeycole
[Yesterday at 06:43:15 am]


Re: Deleted block still showing!!! by Chen Zhen
[July 27, 2016, 07:21:42 pm]


Re: Deleted block still showing!!! by ♦ Ninja ZX-10RR ♦
[July 27, 2016, 08:33:03 am]


Re: Deleted block still showing!!! by habeycole
[July 26, 2016, 10:49:54 am]

NEED HELP? If you're looking for support with Simple Portal, look no further than the Support Board!

Author Topic: Forum button opening a new tab  (Read 1215 times)

0 Members and 1 Guest are viewing this topic.

Offline Paley

  • Newbie
  • Posts: 2
  • SMF Version: 2.0.2
  • SP Version: 2.3.5
Forum button opening a new tab
« on: January 07, 2013, 05:34:39 pm »
For some reason my forum button is opening in a new window as opposed to simply redirecting to the forum page in the same window. How do I fix this?

Thanks.

Offline velorooms

  • Jr. Member
  • **
  • Posts: 83
    • Velorooms
  • SMF Version: 2.0.2
  • SP Version: 2.3.5
Re: Forum button opening a new tab
« Reply #1 on: January 07, 2013, 05:57:46 pm »
whats the site address.. will test here in a few browsers and have a quick look at the code..
Admin and Owner of Velorooms.com - Using SMF 2.0.3 and Simpleportal 2.3.5

Offline Paley

  • Newbie
  • Posts: 2
  • SMF Version: 2.0.2
  • SP Version: 2.3.5
Re: Forum button opening a new tab
« Reply #2 on: January 07, 2013, 06:25:16 pm »
It will not let me post the url on here for some reason. I feel like there is some code I simply need to remove somewhere but haven't the foggiest idea where to look for something like that.

Offline velorooms

  • Jr. Member
  • **
  • Posts: 83
    • Velorooms
  • SMF Version: 2.0.2
  • SP Version: 2.3.5
Re: Forum button opening a new tab
« Reply #3 on: January 07, 2013, 06:41:21 pm »
Right, couple of starters.

First you can post the name of the website without the www and the .com or .co.uk, google can do the rest.

Do you have portal set in the options as standalone, front page, or integration?

Second, you can have a look in the following file (assuming you have ftp access)..

Sources/subs.php

find where it says

Code: [Select]
// All the buttons we can possible want and then some, try pulling the final list of buttons from cache first.
and below you should see the array for the buttons on the menu bar, something like this.

Code: [Select]
$buttons = array(
'home' => array(
'title' => $txt['home'],
'href' => $scripturl,
'show' => true,
'sub_buttons' => array(
),
'is_last' => $context['right_to_left']

),

'forum' => array(
'title' => 'Forum',
'href' => $scripturl . '?action=forum',
'show' => true,
'sub_buttons' => array(
),
),

if it looks something like that , then theres no reason it should open in new window and its a forum settings somewhere.

my portal is set as FRONT PAGE.. I think standalone might cause it to see the forum as an external site and open in new window,
Admin and Owner of Velorooms.com - Using SMF 2.0.3 and Simpleportal 2.3.5

Offline AngelinaBelle

  • Support
  • *
  • Posts: 4873
  • Gender: Female
  • SMF Version: 2 RC3
  • SP Version: 2.3.2
Re: Forum button opening a new tab
« Reply #4 on: March 11, 2013, 03:26:51 pm »
Standalone vs Front page should not cause an issue like this.

Please check the following

* consider your "disable portal redirect" setting (see http://simpleportal.net/index.php?action=docs;area=general_settings)

* Also, check the following SMF and Simple Portal settings
  * Administration Center » Server Settings » Database and Paths -- forum URL
  * Administration Center » Server Settings » Cookies and Sessions  --  Use subdomain independent cookies
  * action=admin;area=portalconfig;sa=generalsettings -- Standalone URL
(though this is more related to login/logout oddities than to URL redirection)


Please to keep this website running, if you like SimplePortal, make a
one-time subscription. Thank you for your support.

Have you tried the SimplePortal documentation?