collapse

* User Info

 
 
Welcome, Guest. Please login or register.
Did you miss your activation email?

* Who's Online

  • Dot Guests: 84
  • Dot Hidden: 0
  • Dot Users: 2
  • Dot Users Online:

* Shoutbox

Refresh History
  • Shoutbox is not for support!
  • Nucky: :D
    January 08, 2016, 10:53:07 am
  • ♦ Ninja ZX-10RR ♦: Merry Christmas to everyone :D
    December 25, 2015, 06:42:17 pm
  • Mark Parker: Yeah thanks for this awesome thing
    November 15, 2015, 03:10:44 am
  • Yahmez: Thanks for making simple portal... Many thanks.
    October 06, 2015, 09:16:18 pm
  • ♦ Ninja ZX-10RR ♦: Thank you for your kind words Phåråoh!
    September 26, 2015, 08:47:29 pm
  • Phåråoh: Good to see admin is still on top of things.  Some people don't take your VOLUNTEER work for granted.  We GREATLY appreciate it, whether it's a small thing or a major issue.
    September 26, 2015, 07:49:44 pm
  • ♦ Ninja ZX-10RR ♦: Kindly wait for replies in each topic, venting in the shoutbox is not going to help, I'm afraid. We are all volunteers and we might not be able to be online 24/7. Thank you for your understanding.
    September 13, 2015, 10:14:49 am
  • Cyberkid: >:( :| :'( :( no admin to fix this stuff
    September 13, 2015, 08:54:19 am
  • rentner: sorry be wrong
    August 19, 2015, 07:56:53 am
  • rentner: beta 2.1
    August 19, 2015, 07:56:32 am
  • ♦ Ninja ZX-10RR ♦: Lol thanks for considering me that much
    August 15, 2015, 01:22:47 pm
  • David: Eliana!! WADDUP, GURL!!!  SiNaN... glad y'all are still around!
    August 15, 2015, 11:27:21 am
  • ♦ Ninja ZX-10RR ♦: Welcome back :)
    August 15, 2015, 11:24:52 am
  • David: I missed y'all!!
    August 15, 2015, 11:23:22 am
  • Eliana Tamerin: People with colored usernames are staff, please abide by their requests.
    August 13, 2015, 04:43:00 pm
  • ♦ Ninja ZX-10RR ♦: Once again, this topic is *NOT* for support, anyway. Thank you for your understanding.
    August 13, 2015, 03:37:51 pm
  • ♦ Ninja ZX-10RR ♦: Please refrain from using such language in the shoutbox. Also, try to read the documentation, it should tell you that and more. [link]
    August 13, 2015, 03:36:48 pm
  • psewolf: Where are the settings on the admin panel?
    August 13, 2015, 02:00:32 pm
  • psewolf: I'm not making a whole damn topic to ask where the settings are on the admin panel.
    August 13, 2015, 02:00:15 pm
  • ♦ Ninja ZX-10RR ♦: Please don't spam the shoutbox, post a topic instead. Thank you.
    August 13, 2015, 01:30:02 am

* Recent Posts

Re: Visitors straight to forum by kast
[Today at 06:04:43 am]


Re: Visitors straight to forum by andy
[Today at 12:10:05 am]


Re: Visitors straight to forum by emanuele
[Yesterday at 09:25:59 am]


Re: Visitors straight to forum by andy
[Yesterday at 07:42:01 am]


Visitors straight to forum by kast
[Yesterday at 04:28:06 am]

Installation errors? Mod incompatibilities? Upgrade problems? Make your way over to the Install and Upgrade Support board for all your solutions!

Author Topic: "Warning: Cannot modify header information - headers already sent"  (Read 2932 times)

0 Members and 1 Guest are viewing this topic.

Offline neilbombd

  • Semi Newbie
  • *
  • Posts: 17
    • Cook'd and Bomb'd - Chris Morris, Four Lions and British Comedy Discussion
  • SMF Version: 2 RC3
  • SP Version: 2.3.1
I've just noticed that I've got this infuriating message on my homepage now.  Not sure how long it's been there, but not long - I am uptodate on the latest SMF patches and have the latest Simple Portal installed.  It seems like it's only on the front page, the other portal pages are fine, and this message isn't appearing on the forum pages either:

Quote
Warning: Cannot modify header information - headers already sent by (output started at /home/cookd/public_html/index.php:2) in /home/cookd/public_html/forums/Sources/Subs.php on line 3533

Warning: Cannot modify header information - headers already sent by (output started at /home/cookd/public_html/index.php:2) in /home/cookd/public_html/forums/Sources/Subs.php on line 3534

Warning: Cannot modify header information - headers already sent by (output started at /home/cookd/public_html/index.php:2) in /home/cookd/public_html/forums/Sources/Subs.php on line 3540

Warning: Cannot modify header information - headers already sent by (output started at /home/cookd/public_html/index.php:2) in /home/cookd/public_html/forums/Sources/Subs.php on line 3543

Any idea how to get rid of this?  I thought it might have started after the latest SMF patch, but can't see anyone else having this issue.

The site is at www.cookdandbombd.co.uk if you want to see it.
« Last Edit: February 27, 2013, 01:50:47 pm by neilbombd »

Offline phantomm

  • Support
  • *
  • Posts: 395
  • Gender: Male
  • Smile, tomorrow will be worse...
    • Polish ElkArte community
  • SMF Version: None
  • SP Version: 2.4 (Elkarte)
  • Elkarte Version: 1.0.5
Re: "Warning: Cannot modify header information - headers already sent"
« Reply #1 on: February 27, 2013, 02:02:54 pm »
did you add any SSI functions in blocks or SMF code?

Offline neilbombd

  • Semi Newbie
  • *
  • Posts: 17
    • Cook'd and Bomb'd - Chris Morris, Four Lions and British Comedy Discussion
  • SMF Version: 2 RC3
  • SP Version: 2.3.1
Re: "Warning: Cannot modify header information - headers already sent"
« Reply #2 on: February 27, 2013, 03:31:39 pm »
Nope, and there's been no changes to the front page for ages.

Offline Chen Zhen

  • The Underdog
  • Support
  • *
  • Posts: 1132
  • Gender: Male
  • ベジータ王
    • WebDev
  • SMF Version: 2.0.11
  • SP Version: 2.3.6
  • Elkarte Version: None
Re: "Warning: Cannot modify header information - headers already sent"
« Reply #3 on: February 27, 2013, 10:22:31 pm »

neilbombd,

 Ensure that the paths in your Settings.php file are correct.
 


Offline neilbombd

  • Semi Newbie
  • *
  • Posts: 17
    • Cook'd and Bomb'd - Chris Morris, Four Lions and British Comedy Discussion
  • SMF Version: 2 RC3
  • SP Version: 2.3.1
Re: "Warning: Cannot modify header information - headers already sent"
« Reply #4 on: March 04, 2013, 10:07:51 am »

neilbombd,

 Ensure that the paths in your Settings.php file are correct.

They're all fine.

Edit: Got it - rogue space inserted itself in the index :-/