collapse

* User Info

 
 
Welcome, Guest. Please login or register.
Did you miss your activation email?

* Who's Online

  • Dot Guests: 223
  • Dot Hidden: 0
  • Dot Users: 0

There aren't any users online.

* Shoutbox

Refresh History
  • Shoutbox is not for support!
  • Chara from Undertale: Since my topic is taking a while to post, can I show my site off here?
    March 30, 2017, 10:00:45 pm
  • ♦ Ninja ZX-10RR ♦: Excuse me but what does Simpleportal have to deal with that?
    February 05, 2017, 08:21:14 pm
  • WhiteEagle: of course IMHO that site appears to be dead :(
    February 04, 2017, 01:08:05 pm
  • WhiteEagle: If I can get that, then I'll use it for that site...
    February 04, 2017, 01:07:35 pm
  • WhiteEagle: decided to not use SMF for any projects, unless I can get a copy of the premium version of the fanfiction archive plugin
    February 04, 2017, 01:06:54 pm
  • expertdecisions: cloudflare
    January 28, 2017, 08:01:47 am
  • aegersz: SM release 2.0.13 !
    January 12, 2017, 06:00:13 am
  • raffo: Tks Emanuele, even if I didn't understand the fix :D
    November 07, 2016, 02:01:20 am
  • emanuele: [link]
    November 01, 2016, 12:43:50 pm
  • emanuele: raffo: the English support board is a good place. ;)
    November 01, 2016, 12:43:38 pm
  • raffo: Where can I find the fix for the shoutbox?
    November 01, 2016, 05:06:09 am
  • [DFg]DJF-1975: To the SP team, I make a point to come here and thank you as much as possible for your work.  so again, THANK YOU!
    October 28, 2016, 10:38:05 am
  • emanuele: That's indeed funny, the limit is present only in the patch and not the full install.
    October 22, 2016, 06:14:58 pm
  • phantomm: and from what I see only patch is broken, full install package is fine
    October 21, 2016, 03:44:44 pm
  • phantomm: they say it for over 3 weeks now..
    October 21, 2016, 03:43:52 pm
  • aegersz: SMF say that bug fix 2.0.13 is coming soon ...
    October 19, 2016, 06:46:12 pm
  • Chen Zhen: check that thread at a later date as that file is not a final fix
    October 10, 2016, 03:09:18 pm
  • [DFg]DJF-1975: Thanks for the shoutbox fix file!
    October 10, 2016, 09:17:19 am
  • * Burke Knight Lurks
    October 02, 2016, 09:17:45 pm
If you're interested in helping other members with support requests, consider joining the Community Support Helpers group.

Author Topic: Poll Block Permissions not working  (Read 9159 times)

0 Members and 1 Guest are viewing this topic.

Offline Ozisuzu

  • Semi Newbie
  • *
  • Posts: 5
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
Poll Block Permissions not working
« on: February 05, 2017, 09:53:29 pm »
Hi I asked this question of the SMF forum but I think it may be better to ask here.

I have added a Poll block to the right side and it works fine for me as the administrator but none of my members or even guests can see it.

They get 'you can not see the results of this poll at the moment' message.

I have permissions for that block set to 'everyone', I even tried custom permissions and I am getting the same results.

I use 'View only boards' if that has an impact on my permission not working??

Any help is appreciated.


Offline ♦ Ninja ZX-10RR ♦

  • Spammer Hammer
  • Support
  • *
  • Posts: 1129
  • Gender: Male
  • Sniper Legends
    • Virtual Interactive Games Entertainment™
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
  • Elkarte Version: 1.0.6
Re: Poll Block Permissions not working
« Reply #1 on: February 05, 2017, 10:56:42 pm »
Hi and welcome to SimplePortal.

I am not sure whether it could have an impact over that, but it's possible for sure.
Have you tried to uninstall it temporarily and see what happens? (If you can do it, that is)
Do said members have permission to view and enter that board?

Regards
Have you tried SimplePortal Documentation before asking? ;)
F.A.Q.  English Support  |  Blocks Support
Fancy Feature idea ?!  |  Blocks Requests
Themes & Graphics

▼ My job! ▼

No PMs for support unless it's a paid request. Thank you! :)
#OpIsis

Offline Ozisuzu

  • Semi Newbie
  • *
  • Posts: 5
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
Re: Poll Block Permissions not working
« Reply #2 on: February 06, 2017, 04:55:34 pm »
Hi and welcome to SimplePortal.

I am not sure whether it could have an impact over that, but it's possible for sure.
Have you tried to uninstall it temporarily and see what happens? (If you can do it, that is)
Do said members have permission to view and enter that board?

Regards

I cant really uninstall view only boards as it is a really significant mod on our board.

Yes I have set the blocks permissions to everyone and I even tried custom permissions but nothing is working. I can only see it when I am logged in as the administrator.

None of the mods can see it, nor the regular members and certainly no guests.


Offline andy

  • On Leave
  • *
  • Posts: 855
  • Gender: Male
    • Outdoor Club Japan (OCJ) アウトドア・クラブ・ジャパン
  • SMF Version: 2.0.11
  • SP Version: 2.3.6
  • Elkarte Version: None
Re: Poll Block Permissions not working
« Reply #3 on: February 07, 2017, 03:31:05 pm »
I use view only boards and it does affect permissions.

You can set to see the message board index page but not read the topics. As polls are attached to topics then I guess the permission to see them will be denied for people not given permission to enter the board.
I would check carefully the member group permissions for polls and the view only board permissions.

If guests/user groups are not allowed to enter a board (but allowed to see topic titles in it) then setting permission to everyone for polls will still not work.
Go through the permissions again to check carefully.
Everyone is a volunteer here so please try and make a small donation to keep the Simple Portal website running


Offline ♦ Ninja ZX-10RR ♦

  • Spammer Hammer
  • Support
  • *
  • Posts: 1129
  • Gender: Male
  • Sniper Legends
    • Virtual Interactive Games Entertainment™
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
  • Elkarte Version: 1.0.6
Re: Poll Block Permissions not working
« Reply #4 on: February 07, 2017, 03:43:08 pm »
Thanks andy! :)
Have you tried SimplePortal Documentation before asking? ;)
F.A.Q.  English Support  |  Blocks Support
Fancy Feature idea ?!  |  Blocks Requests
Themes & Graphics

▼ My job! ▼

No PMs for support unless it's a paid request. Thank you! :)
#OpIsis

Offline Ozisuzu

  • Semi Newbie
  • *
  • Posts: 5
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
Re: Poll Block Permissions not working
« Reply #5 on: February 07, 2017, 06:32:46 pm »
I use view only boards and it does affect permissions.

You can set to see the message board index page but not read the topics. As polls are attached to topics then I guess the permission to see them will be denied for people not given permission to enter the board.
I would check carefully the member group permissions for polls and the view only board permissions.

If guests/user groups are not allowed to enter a board (but allowed to see topic titles in it) then setting permission to everyone for polls will still not work.
Go through the permissions again to check carefully.

Thanks Andy. I have checked and double checked all permissions and everyone including guests are allowed to see the topic and poll. Everyone can see it in the forum thread just not on the portal block.

Everything is ticked in permissions, both columns for that area of the forum in view only boards mod.

Its got me stumped.

Offline andy

  • On Leave
  • *
  • Posts: 855
  • Gender: Male
    • Outdoor Club Japan (OCJ) アウトドア・クラブ・ジャパン
  • SMF Version: 2.0.11
  • SP Version: 2.3.6
  • Elkarte Version: None
Re: Poll Block Permissions not working
« Reply #6 on: February 08, 2017, 07:08:01 am »
Maybe an easy test would be to uninstall the view boards mod and see if it affects it. Actually, always best to uninstall mods and see if there is a difference. Add back one by one and check each time.
The only way to be sure.
Everyone is a volunteer here so please try and make a small donation to keep the Simple Portal website running


Offline Ozisuzu

  • Semi Newbie
  • *
  • Posts: 5
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
Re: Poll Block Permissions not working
« Reply #7 on: February 08, 2017, 10:05:19 am »
Thanks andy, I had a chap solve the issue for me in the smf community.  He said.......


Quote
Ok, I think I see what's happening. And confirm.  If you set up a poll, and set the poll options to "Show the poll's results to anyone." The poll content will show in the block.

If you set the poll options to either of the tow remaining settings,

"Only show the results after someone has voted."  Actual poll content is hidden, and you're presented with the 'you can not see the results of this poll at the moment' message.
 
"Only show the results after the poll has expired."  Actual poll content is hidden, and you're presented with the 'you can not see the results of this poll at the moment' message.

This solved the issue. I set the poll to show to anyone instead of only show after someone has voted and it fixed it.

Thanks again for trying to help.

Offline lurkalot

  • Semi Newbie
  • *
  • Posts: 10
  • SMF Version: 2.0.10
  • SP Version: None
Re: Poll Block Permissions not working
« Reply #8 on: February 08, 2017, 01:05:18 pm »
Thanks andy, I had a chap solve the issue for me in the smf community.  He said.......


Quote
Ok, I think I see what's happening. And confirm.  If you set up a poll, and set the poll options to "Show the poll's results to anyone." The poll content will show in the block.

If you set the poll options to either of the tow remaining settings,

"Only show the results after someone has voted."  Actual poll content is hidden, and you're presented with the 'you can not see the results of this poll at the moment' message.
 
"Only show the results after the poll has expired."  Actual poll content is hidden, and you're presented with the 'you can not see the results of this poll at the moment' message.

This solved the issue. I set the poll to show to anyone instead of only show after someone has voted and it fixed it.

Thanks again for trying to help.

Yeah, that was me. lol..  I will just say, the poll block shouldn't really work like that, in as much as it should still show the poll content using any of the three poll options. Not just one of them.  Unless it's by design, but that wold be a bit silly.. So I'm still thinking there's a bug in that poll block. ;)

Offline Ozisuzu

  • Semi Newbie
  • *
  • Posts: 5
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
Re: Poll Block Permissions not working
« Reply #9 on: February 08, 2017, 06:38:27 pm »
I was wondering if it was you, thanks again.

Offline ♦ Ninja ZX-10RR ♦

  • Spammer Hammer
  • Support
  • *
  • Posts: 1129
  • Gender: Male
  • Sniper Legends
    • Virtual Interactive Games Entertainment™
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
  • Elkarte Version: 1.0.6
Re: Poll Block Permissions not working
« Reply #10 on: February 08, 2017, 08:32:48 pm »
Marked as solved - you can do so yourself in the future by hitting the relative button at the bottom.
Please post again if you have issues.

Regards
Have you tried SimplePortal Documentation before asking? ;)
F.A.Q.  English Support  |  Blocks Support
Fancy Feature idea ?!  |  Blocks Requests
Themes & Graphics

▼ My job! ▼

No PMs for support unless it's a paid request. Thank you! :)
#OpIsis