collapse

* User Info

 
 
Welcome, Guest. Please login or register.
Did you miss your activation email?

* Who's Online

  • Dot Guests: 66
  • Dot Hidden: 1
  • Dot Users: 1

There aren't any users online.

* Shoutbox

Refresh History
  • Shoutbox is not for support!
  • BCNPalomino: lol, that search doe :O
    July 18, 2014, 09:26:27 AM
  • RohailPro23: hi all
    July 18, 2014, 08:09:00 AM
  • samborabora: sorry, thought this was search, lol
    June 29, 2014, 04:45:12 AM
  • samborabora: sp_embed_image
    June 29, 2014, 04:45:01 AM
  • stanyy: Was it merely correcting the mistake made in 2.0.7 or is 2.0.8 actually faster than 2.0.6?
    June 20, 2014, 07:51:21 AM
  • AngelinaBelle: Smf 2.0.8 has been released. -- uses less memory than 2.0.7 [link]
    June 19, 2014, 03:46:47 PM
  • iSamp: [link]
    June 14, 2014, 06:42:38 AM
  • iSamp: SiNaN Plz Help
    June 14, 2014, 06:42:12 AM
  • iSamp: I need Help Plz Help Me I posted a Thing In English Support Plz read it
    June 14, 2014, 06:21:15 AM
  • Cyberkid: hey!
    June 12, 2014, 02:29:42 AM
  • AngelinaBelle: Hello!
    June 03, 2014, 01:06:04 PM
  • kal: also, hello. :)
    June 03, 2014, 08:36:43 AM
  • kal: I haven't been here in a couple months I don't think.
    June 03, 2014, 08:36:35 AM
  • AngelinaBelle: Welcome back, David
    June 02, 2014, 06:18:46 AM
  • David: I've missed this place!
    June 02, 2014, 01:04:01 AM

* Team Blog

* Recent Posts

Re: Not Working! by Underdog
[Today at 10:19:06 PM]


Re: how to remove simpleportal 100% by Underdog
[Today at 10:02:57 PM]


Re: Home Theme not working by oNLy1
[Today at 09:57:38 PM]


Re: how to remove simpleportal 100% by crshep
[Today at 08:42:45 PM]


Re: Memberlist Box by Smasher
[Today at 04:27:42 PM]

Welcome to SimplePortal.net! You can download SimplePortal from the Download Page!

Author Topic: Javascript no funciona en Pagina  (Read 1892 times)

0 Members and 1 Guest are viewing this topic.

Offline angelverde

  • Semi Newbie
  • *
  • Posts: 6
  • SMF Version: 1.1.11
  • SP Version: 2.3.2
Javascript no funciona en Pagina
« on: August 03, 2010, 04:24:31 AM »
Esta en uso SMF 1.1.11 con Simple Portal 2.3.2, el link del sitio es este

Me tomo horas para que un JavaScript me funcionara, lo estuve probando en esta pagina para probar modificaciones, cuando todo estuvo correcto fui al panel de Simple Portal y cree una nueva página tipo HTML, el problema esta en que el JS no funciona en ella.

Probe meter el JS antes de </head> y tampoco funciona, el link de la pagina creada es este si prueban los botones no verán algún cambio, cuando deberian cambiar los iframes.

El código de la página es este:
Code: [Select]
<a href="http://www.forosbuap.mx/chat/index.php" target="popup" onclick="window.open(this.href, 'chat', 'toolbar=0,scrollbars=0,location=0,statusbar=0,menubar=0,resizable=0,width=760px,height=550px');this.blur();return false;"><b>Ver el Chat en Ventana nueva</b></a>
<br />
<p>
<b>Disfruta de nuestra Programación</b>
<div class="smalltext">Prueba las estaciones de Grupo Acir, de Radio BUAP o películas en Streaming.<br /> Solo diviertete, aunque también puedes cerrar todo, da clic en el botón que más te guste:</div>

<script language="JavaScript" type="text/javascript">
<!--
function crearFrame(val, anc, alt) {
    var testFrame = document.createElement("IFRAME");
    testFrame.id = "contenidos";
    testFrame.src = val;
    testFrame.width = anc;
    testFrame.height = alt;
    testFrame.frameborder = "0";
    testFrame.scrolling = "no";
    var control = document.getElementById(testFrame.id)
    document.body.removeChild(control);
    document.body.appendChild(testFrame);

//-->
</script>
<form>
<input type="button" value="Silencio" onclick="crearFrame('nada.html', '1', '1')"/>
<input type="button" value="Grupo Acir" onclick="crearFrame('http://www.grupoacir.com.mx/multimedia/audio/radio/flash/mixquer.php', '500', '400')"/>
<input type="button" value="Radio BUAP" onclick="crearFrame('http://www.enciendetv.buap.mx/paginas/2510.asp?canal=1', '550', '400')"/>
</form>
</p>
<br />
<iframe  id="contenidos"
   frameborder="0"
   width="500"
   scrolling="no"
   height="400"
   src="http://www.grupoacir.com.mx/multimedia/audio/radio/flash/mixquer.php">
</iframe>

Cualquier sugerencia es bienvenida.
« Last Edit: August 03, 2010, 01:08:25 PM by angelverde »

Offline angelverde

  • Semi Newbie
  • *
  • Posts: 6
  • SMF Version: 1.1.11
  • SP Version: 2.3.2
Re: Javascript no funciona en Pagina
« Reply #1 on: August 03, 2010, 04:48:21 AM »
 :( :'(
Creo que mi JavaScript no funciona dentro de un <div> y por ahora ya estoy agotado para investigar, ojala me pudieran orientar un poco  :|

Offline 130860

  • Super Handsome Language Coordinator
  • Board Moderators
  • *
  • Posts: 1777
  • Gender: Male
  • You and I are not the same class of pirate!
  • SMF Version: 2 RC3
  • SP Version: 2.3.2
Re: Javascript no funciona en Pagina
« Reply #2 on: August 03, 2010, 09:11:46 AM »
tu codigo está mal, revisalo, asegurate e que llame a el iframe correcto o en su caso que apunte a el frame correspondiente.

Offline angelverde

  • Semi Newbie
  • *
  • Posts: 6
  • SMF Version: 1.1.11
  • SP Version: 2.3.2
Re: Javascript no funciona en Pagina
« Reply #3 on: August 03, 2010, 01:04:12 PM »
Revise que llame al iframe correcto y lo hace, solo que soy nuevo en JS y no se porque no funciona cuando esta dentro de un div.

Me pondre a estudiar/investigar si sabes algo por favor no dudes en comentarlo.

Offline angelverde

  • Semi Newbie
  • *
  • Posts: 6
  • SMF Version: 1.1.11
  • SP Version: 2.3.2
Re: Javascript no funciona en Pagina
« Reply #4 on: August 03, 2010, 03:35:11 PM »
Lo solucione metiendo el iframe en un div y luego usando este JS

Code: [Select]
<script language="JavaScript" type="text/javascript">
<!--
function crearFrame(url, anch, alt) {

  document.getElementById ("miDiv").innerHTML = "<iframe frameborder=0 scrolling=no width=" + anch + " height=" + alt + " src=" + url + "></iframe>";
  }
//-->
</script>

Vaya solucion que encontre :P