SimplePortal

Support => International Support => French => Topic started by: nofear on September 14, 2009, 12:05:31 PM

Title: Shoutbox Refresh
Post by: nofear on September 14, 2009, 12:05:31 PM
Bonjour,

Voilà mon petit souci, la shoutbox ne se rafraichi pas après l'envoi de texte, ou via l'icône actualiser qu'elle contient.

Le seul moyen est donc de rafraîchir la page entière.

Si quelqu'un a une suggestion, merci.

PS : J'ai oublié de dire que j'étais en version smf 1.1.10 et sp 2.3.
Title: Re: Shoutbox Refresh
Post by: nofear on September 14, 2009, 05:33:30 PM
Bonsoir,

J'ai trouvé, cela viens en fait de la langue utilisé, puisqu'en anglais la shoutbox fonctionne bien.

Il manque donc la traduction pour l'utiliser en français sans défaut.

Bon courage et merci d'avance GravuTrad.
Title: Re: Shoutbox Refresh
Post by: nofear on September 14, 2009, 06:11:16 PM
Re,

Finalement la traduction ne suffira sans doute pas.

Je viens d'essayer avec la trad english_british pour SMF 1.1.10, ainsi que pour SP 2.3.

Le résultat est identique a la trad française de SMF.

Sachant que cela fonctionne avec le langage english par défaut, le problème viens d'ailleurs j'imagine.
Title: Re: Shoutbox Refresh
Post by: AngelinaBelle on April 26, 2010, 01:10:50 PM
Cette problème -- est-ce que c'est resolu?
 
Title: Re: Shoutbox Refresh
Post by: DeathSign on June 17, 2010, 05:48:14 PM
Cette problème -- est-ce que c'est resolu?
Ce problème est malheureusement toujours présent.

Bonjour ! Oui oui je suis là aussi, petit coucou à GravuTrad, maximus23 que j'ai vu pour la traduction :)

J'ai planifié d'utiliser SP pour mon site qui sera refait prochainement. J'ai donc un forum de test sur lequel je travaille sur le design et la découverte du portail. Il se trouve que j'ai rencontré le même problème.

En regardant les erreurs de firefox, il y a une erreur au niveau du XML.

Code: [Select]
Erreur : entité non définie
Fichier Source : http://www.XXXXXXX.tld/index.php?action=portal;sa=shoutbox;xml
Ligne : 12, Colonne : 26
Code Source :
  <timeclean>Aujourd'hui &agrave; 22:04:57</timeclean>

En effet &agrave; est une entité HTML et n'est pas correct en XML.

A mon avis pour le reproduire il faut un forum en ISO-8859-1 avec des accents dans le formatage de la date et l'heure (=> "Aujourd'hui &agrave; 22:04:57").

Alors petit quick & dirty fix : fichier Sources/Sub-Portal.php

Rechercher :

Quote
      $shouts[$shout['id']]['time'] = timeformat($shouts[$shout['id']]['time']);
Remplacer par :
Quote
      $shouts[$shout['id']]['time'] = str_replace('&agrave;', '&#224;', timeformat($shouts[$shout['id']]

['time'])); // DeathSign quick & dirty fix
EDIT: cf plus bas pour le fix

Je pense qu'il serait utile de transmettre le bug à la team.

Amicalement,
DeathSign
Title: Re: Shoutbox Refresh
Post by: AngelinaBelle on June 17, 2010, 07:35:04 PM
Après le petit fix -- le shoutbox marche bien?
Vous dites que les entités indefinés sont responsibles pour le problème avec le shoutbox?
 
&agrave;,  c'est en entité definé en XHTML http://www.w3schools.com/tags/ref_entities.asp (http://www.w3schools.com/tags/ref_entities.asp) 
Mais non recommandé en XML
 
Quelque chose d'aussi simple comme cela?
 
http://en.wikipedia.org/wiki/Character_encodings_in_HTML#XML_character_references (http://en.wikipedia.org/wiki/Character_encodings_in_HTML#XML_character_references)
http://webservices.itcs.umich.edu/mediawiki/oaibp/index.php/CharacterEncoding#Use_of_character_entities (http://webservices.itcs.umich.edu/mediawiki/oaibp/index.php/CharacterEncoding#Use_of_character_entities)
 
Oui?
 
 
Title: Re: Shoutbox Refresh
Post by: DeathSign on June 18, 2010, 06:04:47 AM
Exactly that's why I replaced &agrave; by &#224; but it is not clean: You should replace every HTML entities that may appears.

I hate online translator, sometimes your sentences don't make sense. You can speak english I understand.

EDIT: Ok j'ai trouvé une meilleure méthode, oubliez le code au dessus. Je vais faire comme pour les autres champs c'est-à-dire rajouter htmlspecialchars() pour le temps qui posait problème.
(OK I found better, forgot the fix I found another one. I can do like the others fields so just add htmlspecialchars() for "timeclean".)

Fichier (file) Themes/defaults/PortalShoutbox.template.php :

Rechercher (find) :
Code: [Select]
<timeclean>', strip_tags($shout['time']), '</timeclean>Remplacer par (replace by) :
Code: [Select]
<timeclean>', htmlspecialchars(strip_tags($shout['time'])), '</timeclean>
Et ça marche très bien :)
Title: Re: Shoutbox Refresh
Post by: AngelinaBelle on June 18, 2010, 07:15:40 AM
Thank you.  I have been using what French I remember from high school. Then I add vocabulary from Google translate.
 
I will tell the devs that you noticed that some HTML entities are being used in XML without being defined first, and share your fix.
 
I wish nofear could tell us if this solves his problem as well.
 
----------------------------------------
Edit: reported in bugtracker http://simpleportal.net/index.php?issue=390.0#com1057 (http://simpleportal.net/index.php?issue=390.0#com1057)
Title: Re: Shoutbox Refresh
Post by: DeathSign on June 18, 2010, 08:22:39 AM
I see ^^

You're welcome I was looking for the button to submit the issue :angel:

The topic was started last year, I'm not sure nofear will answer it. But he did not tell us he was using UTF-8 or not. I don't understand how english-british could suffer from the same problem because there are not accent. I tried to install english-british not UTF-8 and it works fine without my fix.
Title: Re: Shoutbox Refresh
Post by: AngelinaBelle on June 18, 2010, 10:02:09 AM
You can always report bugs at http://simpleportal.net/index.php?board=3.0 (http://simpleportal.net/index.php?board=3.0)
I got lazy and put it straight on the bugtracker.
 
I don't have very much time available to help out here any more, but I try to help a little bit when I can.
 
Title: Re: Shoutbox Refresh
Post by: shaitan on July 04, 2010, 03:21:13 AM
Bonjour à tous,

Je confirme que cela fonctionne, j'avais été confronté à ce problème et un membre m'avait aidé à trouvé cette solution.

http://passion-xbmc.org/xbmc-passion-le-site/mise-a-jour-du-site-maintenance/msg63365/#msg63365
Title: Re: Shoutbox Refresh
Post by: AngelinaBelle on August 05, 2010, 05:13:57 PM
Thanks for the report. It looks like the fix will be in the next version of SimplePortal.
SimplePortal 2.3.7 © 2008-2022, SimplePortal