SimplePortal

Support => International Support => French => Topic started by: c0by on August 20, 2011, 07:59:27 PM

Title: Menu Forum sur SMF 2
Post by: c0by on August 20, 2011, 07:59:27 PM
Bonjour,

Je viens d'installer SP en dehors d'une petite modification de la CSS pour coller au thème de notre forum aucun soucis d'installation. Cela a été fait via le module d'installation de SMF.

Comment fait-on pour avoir/afficher dans le menu après Accueil, Forum ?  J'ai du mal à comprendre les explication en Anglais.

Notre forum : http://forum.lahorde.org/
Il est avec la dernière version de SMF et de SP. Dans les mods liés au menu il y a Menu_Icons. Le thème que nous avons fait est dérivé du thème par défaut de SMF 2.
Title: Re: Menu Forum sur SMF 2
Post by: Sapinho® on August 21, 2011, 03:37:23 AM
Bonjour, ce n'est pas ma langue, mais vous pouvez essayer ceci:

Dans votre menu, allez à l'option administrador/simpleportal/configuration générale/mode portail

et il y sélectionner première "page"
Title: Re: Menu Forum sur SMF 2
Post by: c0by on August 21, 2011, 04:13:08 AM
Merci pour ce retour, c'est le cas de mes réglages.
Le bouton accueil du menu amène bien sur le portail. Je ne trouve pas comment avoir un bouton Forum qui aurait comme action "?action=forum"
Title: Re: Menu Forum sur SMF 2
Post by: Sapinho® on August 21, 2011, 04:28:13 AM
vous pouvez ajouter sur cette question, le fichier sources/subs.php??

mais dans ce fichier pour les éléments suivants:

Code: [Select]
),
'help' => array(
'title' => '<img align="absMiddle" src="'. $settings['images_url']. '/menu_icons/help.png" alt="'.$txt['help']. '"/>&nbsp; ' . $txt['help'],
'href' => $scripturl . '?action=help',
'show' => true,
'sub_buttons' => array(
),

et a ajouté, avant

Code: [Select]
'forum' => array(
'title' => '<img align="absMiddle" src="'. $settings['images_url']. '/menu_icons/forum.png" alt="'.$txt['sp-forum']. '"/>&nbsp; ' . $txt['sp-forum'],
'href' => $scripturl . ($modSettings['sp_portal_mode'] == 1 && empty($context['disable_sp']) ? '?action=forum' : ''),
'show' => in_array($modSettings['sp_portal_mode'], array(1, 3)) && empty($context['disable_sp']),
'sub_buttons' => array(
),

regards i hope this works for u
Title: Re: Menu Forum sur SMF 2
Post by: c0by on August 21, 2011, 05:06:00 AM
Super  :thumbsup:

Il manquait  une "),"

Code: [Select]
'forum' => array(
'title' => '<img align="absMiddle" src="'. $settings['images_url']. '/menu_icons/forum.png" alt="'.$txt['sp-forum']. '"/>&nbsp; ' . $txt['sp-forum'],
'href' => $scripturl . ($modSettings['sp_portal_mode'] == 1 && empty($context['disable_sp']) ? '?action=forum' : ''),
'show' => in_array($modSettings['sp_portal_mode'], array(1, 3)) && empty($context['disable_sp']),
'sub_buttons' => array(
),
            ),

Encore merci, je vais chercher  une image qui aille bien avec^^
SimplePortal 2.3.7 © 2008-2021, SimplePortal