collapse collapse

* Simple Portal Archived Forum

This is an Archive Forum.

The content in this forum may be out-of-date or have been superseded by newer information, and links in forum pages to other sites may not work.
This forum contains archives for future reference.

Visit our thread at Simple Machines Forum for current support.

SMF 2.1 users: EhPortal is a ported version of Simple Portal specifically designed for the SMF 2.1 branch.
Please visit web-develop.ca to download EhPortal and for its support.

* User Info

 
 
Welcome, Guest. Please login or register.

* Who's Online

  • Dot Guests: 187
  • Dot Hidden: 0
  • Dot Users: 0

There aren't any users online.

* Shoutbox

Refresh History
  • Shoutbox is not for support!
  • {OCS}MasterSeal: Yup, Still adore SP
    April 21, 2019, 07:08:06 PM
  • {OCS}MasterSeal: STILL love SP :)
    November 24, 2018, 05:05:50 AM
  • ♦ Ninja ZX-10RR ♦: <3 aegersz
    September 13, 2018, 03:36:09 PM
  • aegersz: I STILL <3 LOVE SimplePortal
    September 13, 2018, 07:11:39 AM
  • aegersz: o LOVE you guys - Simple Portal rocks !
    May 09, 2018, 05:18:59 AM
  • Chen Zhen: our apologies for the site being down.. please read server issues topic
    March 22, 2018, 05:32:38 AM
  • {OCS}MasterSeal: LOL PLEASE forget I just posted that. I found the answer in my own dang post back in 2015. lol sorry!
    July 04, 2017, 10:47:55 PM
  • {OCS}MasterSeal: I know this SB isnt' for support, but I just have a general question. Who would I contact to find out where SP stores its block info? Is it DB driven or files? I searched the site but came up with nothing. probably my fault any insight is appreciated.
    July 04, 2017, 10:43:36 PM
  • ♦ Ninja ZX-10RR ♦: Excuse me but what does Simpleportal have to deal with that?
    February 05, 2017, 08:21:14 PM
  • WhiteEagle: of course IMHO that site appears to be dead :(
    February 04, 2017, 01:08:05 PM
  • WhiteEagle: If I can get that, then I'll use it for that site...
    February 04, 2017, 01:07:35 PM
  • WhiteEagle: decided to not use SMF for any projects, unless I can get a copy of the premium version of the fanfiction archive plugin
    February 04, 2017, 01:06:54 PM
  • expertdecisions: cloudflare
    January 28, 2017, 08:01:47 AM
  • aegersz: SM release 2.0.13 !
    January 12, 2017, 06:00:13 AM
  • raffo: Tks Emanuele, even if I didn't understand the fix :D
    November 07, 2016, 02:01:20 AM
  • emanuele: [link]
    November 01, 2016, 12:43:50 PM
  • emanuele: raffo: the English support board is a good place. ;)
    November 01, 2016, 12:43:38 PM
  • raffo: Where can I find the fix for the shoutbox?
    November 01, 2016, 05:06:09 AM
  • {OCS}MasterSeal: To the SP team, I make a point to come here and thank you as much as possible for your work.  so again, THANK YOU!
    October 28, 2016, 10:38:05 AM
  • emanuele: That's indeed funny, the limit is present only in the patch and not the full install.
    October 22, 2016, 06:14:58 PM

* Recent Posts

Adding Forums Button to Nav bar by jirapon
[August 01, 2019, 09:07:12 AM]


Re: Board Icons by ♦ Ninja ZX-10RR ♦
[July 30, 2019, 04:03:41 PM]


MOVED: Czech translation???? by ♦ Ninja ZX-10RR ♦
[July 30, 2019, 03:04:51 PM]


Board Icons by jirapon
[July 30, 2019, 07:28:44 AM]


Re: Thankyou Simpleportal, by ♦ Ninja ZX-10RR ♦
[July 29, 2019, 09:41:29 AM]

Thanks for having an interest with our portal. If you have any requests for features, have a look at the Feature Requests board.

Author Topic: Problem in the portal using theme "music"  (Read 3593 times)

0 Members and 1 Guest are viewing this topic.

Offline distante

  • Semi Newbie
  • *
  • Posts: 24
  • SMF Version: 2.0.1
  • SP Version: 2.3.4
Problem in the portal using theme "music"
« on: March 08, 2012, 01:13:23 PM »
Well I think, the words won't be enough, see :

http://www.musicaysonido.com/foro/index.php


For some reason, the portal isn't load the sprites images...


I'm using this theme : http://custom.simplemachines.org/themes/index.php?lemma=2437

Any Ideas? :(

Pd: just in case, I copied the portal.css and portal_rtl.css files into my theme css dir.

Offline andy

  • On Leave
  • *
  • Posts: 861
  • Gender: Male
    • Outdoor Club Japan (OCJ) アウトドア・クラブ・ジャパン
  • SMF Version: 2.0.15
  • SP Version: 2.3.7
  • Elkarte Version: None
Re: Problem in the portal using theme "music"
« Reply #1 on: March 09, 2012, 02:05:46 AM »
Not sure what you mean ....'For some reason, the portal isn't load the sprites images...'.
The problem with the corner images is a well known one and lots of information if you look. It looks like your theme blocks are set to display a light background for the title bar on the blocks, unless the black background isnt showing because of something you have already changed.
http://www.musicaysonido.com/foro/Themes/Music_2_0/images/theme/catbg.png
You want the black bar to display?

Variations for the block display can be changed in the block settings.

Some topics to fix the corner image problem.
http://simpleportal.net/index.php?topic=10241

http://simpleportal.net/index.php?topic=10529

Also search for topics with 'main_block' or 'main_block.png' for details.

Take your time and read through ... If it is difficult to understand the 'correct' way ... code fixes, then with a custom theme that does not use the main_block image you could try deleting it like I did... might work. If not, then put it back and try the other solutions they recommend on those pages.
I deleted this and my custom theme corners were displayed correctly. I wouldnt recommend if users can switch themes or use curve etc later.

Andy
http://www.musicaysonido.com/foro/Themes/Music_2_0/images/theme/main_block.png
« Last Edit: March 09, 2012, 02:21:35 AM by igirisjin »
Everyone is a volunteer here so please try and make a small donation to keep the Simple Portal website running


Offline Old Fossil

  • Beta Tester
  • *
  • Posts: 796
  • Gender: Male
  • SMF Version: 2.0.4
  • SP Version: 2.3.5
Re: Problem in the portal using theme "music"
« Reply #2 on: March 09, 2012, 10:22:26 AM »
It won't be something distante has changed due to my new forum having the exact same problem with the er exact same theme.

 :-[

www.broadstarradio.com

Daily backups mean less headaches

Block Set Up

I may be no coding expert but I am willing to help where I can.

I eat Spammers for breakfast

Offline distante

  • Semi Newbie
  • *
  • Posts: 24
  • SMF Version: 2.0.1
  • SP Version: 2.3.4
Re: Problem in the portal using theme "music"
« Reply #3 on: March 09, 2012, 11:57:02 AM »
Yeap, I didn't change anything, just install simple portal and see how it looks.

In other forums and themes I don't have that problem

Offline AngelinaBelle

  • Comrade
  • *
  • Posts: 4870
  • Gender: Female
  • SMF Version: 2 RC3
  • SP Version: 2.3.2
Re: Problem in the portal using theme "music"
« Reply #4 on: March 09, 2012, 02:01:38 PM »
distante,

This theme is special.  It uses a separate png file for the catbg.
SimplePortal uses main_block.png for the block title bar.

This kind of change should be done in the CSS file, but this will be a little difficult because of special code Sinan has put in for compatability with two different versions of the CURVE theme.

This means that this bit of CSS is actually in a php file, to be emitted as part of the HTML doc. (I hope I got that right).
What it means is that your theme is not exactly compatable with the most recent version of SimplePortal.

The simplest change to this problem might involve a change to main_block.png for this theme -- to put the little left-side-of-bar thing in main_block.png where SimplePortal expects to find it.
Please to keep this website running, if you like SimplePortal, make a
one-time subscription. Thank you for your support.

Have you tried the SimplePortal documentation?

Offline distante

  • Semi Newbie
  • *
  • Posts: 24
  • SMF Version: 2.0.1
  • SP Version: 2.3.4
Re: Problem in the portal using theme "music"
« Reply #5 on: March 09, 2012, 03:59:14 PM »
So...

If I change in the index.css file all the references to main_block.png for lets say formely_block.png, and upload a regular main_block, it should fix the portal problem,. Don't?

*Edit

Well not, I added other main_block.png and changed the other one in the css. But still doesn't show.

Quote
The simplest change to this problem might involve a change to main_block.png for this theme -- to put the little left-side-of-bar thing in main_block.png where SimplePortal expects to find it.

I'm not quite sure of how to do this.

*Edit 2

So, I added
Code: [Select]
background: black url(../images/theme/catbg.png) center repeat-x; to the h3.catbg and h3.catbg2 styles.

But now I'm not sure of how to fix the corner problem. Do I have to edit the Portal Css file?

*Edit3 looks like, as you said, the css style for the catbg in blocks are being rendered as code in the index.php

I will need some help to know what to change in order to fix the corner.
« Last Edit: March 09, 2012, 04:41:56 PM by distante »

Offline AngelinaBelle

  • Comrade
  • *
  • Posts: 4870
  • Gender: Female
  • SMF Version: 2 RC3
  • SP Version: 2.3.2
Re: Problem in the portal using theme "music"
« Reply #6 on: March 09, 2012, 04:47:41 PM »
The problem is that SimplePortal is getting those corners from main_block.png. But your theme does not use main_block.png.
This is happening because some of the CSS is coded into the php files, which was done to help SimplePortal be more compatable with the 2 versions of CURVE (CURVE final and CURVE pre-RC4).

I don't think editing the CSS files will change the behavior.
If creating a "matching" main_block.php is not doable, it may reuire some editing of the php file.
Please to keep this website running, if you like SimplePortal, make a
one-time subscription. Thank you for your support.

Have you tried the SimplePortal documentation?

 

SimplePortal 2.3.7 © 2008-2021, SimplePortal