collapse collapse

* Simple Portal Archived Forum

This is an Archive Forum.

The content in this forum may be out-of-date or have been superseded by newer information, and links in forum pages to other sites may not work.
This forum contains archives for future reference.

Visit our thread at Simple Machines Forum for current support.

* User Info

 
 
Welcome, Guest. Please login or register.

* Who's Online

  • Dot Guests: 340
  • Dot Hidden: 0
  • Dot Users: 0

There aren't any users online.

* Shoutbox

Refresh History
  • Shoutbox is not for support!
  • {OCS}MasterSeal: Yup, Still adore SP
    April 21, 2019, 07:08:06 PM
  • {OCS}MasterSeal: STILL love SP :)
    November 24, 2018, 05:05:50 AM
  • ♦ Ninja ZX-10RR ♦: <3 aegersz
    September 13, 2018, 03:36:09 PM
  • aegersz: I STILL <3 LOVE SimplePortal
    September 13, 2018, 07:11:39 AM
  • aegersz: o LOVE you guys - Simple Portal rocks !
    May 09, 2018, 05:18:59 AM
  • Chen Zhen: our apologies for the site being down.. please read server issues topic
    March 22, 2018, 05:32:38 AM
  • {OCS}MasterSeal: LOL PLEASE forget I just posted that. I found the answer in my own dang post back in 2015. lol sorry!
    July 04, 2017, 10:47:55 PM
  • {OCS}MasterSeal: I know this SB isnt' for support, but I just have a general question. Who would I contact to find out where SP stores its block info? Is it DB driven or files? I searched the site but came up with nothing. probably my fault any insight is appreciated.
    July 04, 2017, 10:43:36 PM
  • ♦ Ninja ZX-10RR ♦: Excuse me but what does Simpleportal have to deal with that?
    February 05, 2017, 08:21:14 PM
  • WhiteEagle: of course IMHO that site appears to be dead :(
    February 04, 2017, 01:08:05 PM
  • WhiteEagle: If I can get that, then I'll use it for that site...
    February 04, 2017, 01:07:35 PM
  • WhiteEagle: decided to not use SMF for any projects, unless I can get a copy of the premium version of the fanfiction archive plugin
    February 04, 2017, 01:06:54 PM
  • expertdecisions: cloudflare
    January 28, 2017, 08:01:47 AM
  • aegersz: SM release 2.0.13 !
    January 12, 2017, 06:00:13 AM
  • raffo: Tks Emanuele, even if I didn't understand the fix :D
    November 07, 2016, 02:01:20 AM
  • emanuele: [link]
    November 01, 2016, 12:43:50 PM
  • emanuele: raffo: the English support board is a good place. ;)
    November 01, 2016, 12:43:38 PM
  • raffo: Where can I find the fix for the shoutbox?
    November 01, 2016, 05:06:09 AM
  • {OCS}MasterSeal: To the SP team, I make a point to come here and thank you as much as possible for your work.  so again, THANK YOU!
    October 28, 2016, 10:38:05 AM
  • emanuele: That's indeed funny, the limit is present only in the patch and not the full install.
    October 22, 2016, 06:14:58 PM

* Recent Posts

Adding Forums Button to Nav bar by jirapon
[August 01, 2019, 09:07:12 AM]


Re: Board Icons by ♦ Ninja ZX-10RR ♦
[July 30, 2019, 04:03:41 PM]


MOVED: Czech translation???? by ♦ Ninja ZX-10RR ♦
[July 30, 2019, 03:04:51 PM]


Board Icons by jirapon
[July 30, 2019, 07:28:44 AM]


Re: Thankyou Simpleportal, by ♦ Ninja ZX-10RR ♦
[July 29, 2019, 09:41:29 AM]

Blocks speak! Do you have an interest in getting more blocks - or even making your own? The Blocks Board is for you!

Author Topic: Tiny Menu Bug  (Read 3803 times)

0 Members and 1 Guest are viewing this topic.

Offline FrizzleFried

  • Full Member
  • ***
  • Posts: 114
  • SMF Version: 2.0.5
  • SP Version: 2.3.5
Tiny Menu Bug
« on: April 03, 2012, 04:08:46 PM »
Default theme (modified).

The top menu... when you click HOME or when you drop in to the site the HOME button is "lit up" orange.  When you click FORUM the FORUM button lights up (orange)... but when I click in to a category the "HOME" button re-lights up rather than staying on the "FORUM" button.

How can I rectify that behavior?

Thanks!


Offline FrizzleFried

  • Full Member
  • ***
  • Posts: 114
  • SMF Version: 2.0.5
  • SP Version: 2.3.5
Re: Tiny Menu Bug
« Reply #1 on: April 05, 2012, 03:04:01 PM »
...and suggestions on where to look? Thanks!

Offline andy

  • On Leave
  • *
  • Posts: 861
  • Gender: Male
    • Outdoor Club Japan (OCJ) アウトドア・クラブ・ジャパン
  • SMF Version: 2.0.15
  • SP Version: 2.3.7
  • Elkarte Version: None
Re: Tiny Menu Bug
« Reply #2 on: April 07, 2012, 02:46:20 PM »
Seeing it might help .... it is probably your theme but could be related to changes made to the home link. I dont know much about this though.
Everyone is a volunteer here so please try and make a small donation to keep the Simple Portal website running


Offline FrizzleFried

  • Full Member
  • ***
  • Posts: 114
  • SMF Version: 2.0.5
  • SP Version: 2.3.5
Re: Tiny Menu Bug
« Reply #3 on: April 07, 2012, 06:44:22 PM »
Default theme.   I don't think I've done anything RE: the home button specifically but I did remove the HELP button from the main menu and I also have added a number of items (arcade, quiz, etc)...

Basically the way it behaves is:

HOME it remains orange...

Click forum and FORUM turns orange and HOME turns to unlit.

Click any of the forum categories and it drops back to HOME as lit when it is supposed to stay at FORUM (as it is above on this forum... FORUM is lit right now... on mine,  it would have HOME lit).

The site is a private site,  but if you think it would help I could set you up an account.

Thanks!

Friz

Offline ccbtimewiz

  • Hero Member
  • *****
  • Posts: 2185
  • Gender: Male
  • $("div.content:dd").hide();
  • SMF Version: None
  • SP Version: None
  • Elkarte Version: None
  • EhPortal Version: None
Re: Tiny Menu Bug
« Reply #4 on: April 07, 2012, 11:02:20 PM »
Confirmed, the collapse action has "home" highlighted as opposed to "forum". It's a bug, here's the fix:

Open ./Sources/Subs.php

Find:
Code: [Select]
in_array($context['current_action'], array('unread', 'unreadreplies', 'recent', 'stats', 'who'))
Replace with:
Code: [Select]
in_array($context['current_action'], array('collapse', 'unread', 'unreadreplies', 'recent', 'stats', 'who'))

Offline FrizzleFried

  • Full Member
  • ***
  • Posts: 114
  • SMF Version: 2.0.5
  • SP Version: 2.3.5
Re: Tiny Menu Bug
« Reply #5 on: April 08, 2012, 12:02:54 PM »
I'd like to report that while I evidently discovered this bug on accident... it wasn't the solution to my problem... My problem had nothing to do with collapsing.  HOWEVER... pulling a search on the string above failed... which caused me to look in to the issue... and compare a fresh SMF/Simple Portal installation with my modified one in that area and I discovered the entire line that this change is to be made on was missing from my subs.php file!   After installing the line (and making the correction above) the button is now working as intended!

THANK YOU!

Offline [SiNaN]

  • Mr. SimplePortal
  • Developer
  • *
  • Posts: 6782
  • SMF Version: 2.0.15
  • SP Version: 2.3.7
Re: Tiny Menu Bug
« Reply #6 on: August 14, 2014, 04:13:14 PM »
Fixed for the upcoming release.
And slowly, you come to realize... It's all as it should be...