collapse collapse

* Simple Portal Archived Forum

This is an Archive Forum.

The content in this forum may be out-of-date or have been superseded by newer information, and links in forum pages to other sites may not work.
This forum contains archives for future reference.

Visit our thread at Simple Machines Forum for current support.

* User Info

 
 
Welcome, Guest. Please login or register.

* Who's Online

  • Dot Guests: 208
  • Dot Hidden: 0
  • Dot Users: 0

There aren't any users online.

* Shoutbox

Refresh History
  • Shoutbox is not for support!
  • {OCS}MasterSeal: Yup, Still adore SP
    April 21, 2019, 07:08:06 PM
  • {OCS}MasterSeal: STILL love SP :)
    November 24, 2018, 05:05:50 AM
  • ♦ Ninja ZX-10RR ♦: <3 aegersz
    September 13, 2018, 03:36:09 PM
  • aegersz: I STILL <3 LOVE SimplePortal
    September 13, 2018, 07:11:39 AM
  • aegersz: o LOVE you guys - Simple Portal rocks !
    May 09, 2018, 05:18:59 AM
  • Chen Zhen: our apologies for the site being down.. please read server issues topic
    March 22, 2018, 05:32:38 AM
  • {OCS}MasterSeal: LOL PLEASE forget I just posted that. I found the answer in my own dang post back in 2015. lol sorry!
    July 04, 2017, 10:47:55 PM
  • {OCS}MasterSeal: I know this SB isnt' for support, but I just have a general question. Who would I contact to find out where SP stores its block info? Is it DB driven or files? I searched the site but came up with nothing. probably my fault any insight is appreciated.
    July 04, 2017, 10:43:36 PM
  • ♦ Ninja ZX-10RR ♦: Excuse me but what does Simpleportal have to deal with that?
    February 05, 2017, 08:21:14 PM
  • WhiteEagle: of course IMHO that site appears to be dead :(
    February 04, 2017, 01:08:05 PM
  • WhiteEagle: If I can get that, then I'll use it for that site...
    February 04, 2017, 01:07:35 PM
  • WhiteEagle: decided to not use SMF for any projects, unless I can get a copy of the premium version of the fanfiction archive plugin
    February 04, 2017, 01:06:54 PM
  • expertdecisions: cloudflare
    January 28, 2017, 08:01:47 AM
  • aegersz: SM release 2.0.13 !
    January 12, 2017, 06:00:13 AM
  • raffo: Tks Emanuele, even if I didn't understand the fix :D
    November 07, 2016, 02:01:20 AM
  • emanuele: [link]
    November 01, 2016, 12:43:50 PM
  • emanuele: raffo: the English support board is a good place. ;)
    November 01, 2016, 12:43:38 PM
  • raffo: Where can I find the fix for the shoutbox?
    November 01, 2016, 05:06:09 AM
  • {OCS}MasterSeal: To the SP team, I make a point to come here and thank you as much as possible for your work.  so again, THANK YOU!
    October 28, 2016, 10:38:05 AM
  • emanuele: That's indeed funny, the limit is present only in the patch and not the full install.
    October 22, 2016, 06:14:58 PM

* Recent Posts

Adding Forums Button to Nav bar by jirapon
[August 01, 2019, 09:07:12 AM]


Re: Board Icons by ♦ Ninja ZX-10RR ♦
[July 30, 2019, 04:03:41 PM]


MOVED: Czech translation???? by ♦ Ninja ZX-10RR ♦
[July 30, 2019, 03:04:51 PM]


Board Icons by jirapon
[July 30, 2019, 07:28:44 AM]


Re: Thankyou Simpleportal, by ♦ Ninja ZX-10RR ♦
[July 29, 2019, 09:41:29 AM]

Blocks speak! Do you have an interest in getting more blocks - or even making your own? The Blocks Board is for you!

Author Topic: [Bug] Recent Posts  (Read 9177 times)

0 Members and 1 Guest are viewing this topic.

Offline [SiNaN]

  • Mr. SimplePortal
  • Developer
  • *
  • Posts: 6782
  • SMF Version: 2.0.15
  • SP Version: 2.3.7
[Bug] Recent Posts
« on: July 28, 2008, 03:10:52 AM »
Seems like this recent topics guy doesn't show me up. Any ideas?
And slowly, you come to realize... It's all as it should be...

Offline Nathaniel

  • Comrade
  • *
  • Posts: 5203
  • Gender: Male
    • Verbtest.com
  • SMF Version: 2 RC4
  • SP Version: 2.3.3
Re: [Bug] Recent Posts
« Reply #1 on: July 28, 2008, 03:19:59 AM »
Its happening to me too, it was working this morning so...

It was being caused by the "Member Color Link" mod that was installed, I uninstalled it and now its working perfectly.
SMF Friend (Former Support Specialist) | SimplePortal Developer
My SMF Mods | SimplePortal

"Quis custodiet ipsos custodes?" - Who will Guard the Guards?

Please don't send me ANY support related PMs. I will just delete them.

Offline Nathaniel

  • Comrade
  • *
  • Posts: 5203
  • Gender: Male
    • Verbtest.com
  • SMF Version: 2 RC4
  • SP Version: 2.3.3
Re: [Bug] Recent Posts
« Reply #2 on: July 28, 2008, 03:21:49 AM »
We might want to have a look at the compatibility issue, although it doesn't seem too important...
SMF Friend (Former Support Specialist) | SimplePortal Developer
My SMF Mods | SimplePortal

"Quis custodiet ipsos custodes?" - Who will Guard the Guards?

Please don't send me ANY support related PMs. I will just delete them.

Offline [SiNaN]

  • Mr. SimplePortal
  • Developer
  • *
  • Posts: 6782
  • SMF Version: 2.0.15
  • SP Version: 2.3.7
Re: [Bug] Recent Posts
« Reply #3 on: July 28, 2008, 03:33:30 AM »
Strange. I can see it right now.
And slowly, you come to realize... It's all as it should be...

Offline Nathaniel

  • Comrade
  • *
  • Posts: 5203
  • Gender: Male
    • Verbtest.com
  • SMF Version: 2 RC4
  • SP Version: 2.3.3
Re: [Bug] Recent Posts
« Reply #4 on: July 28, 2008, 03:34:51 AM »
Yep, its was definetly the "Member Color Link" Mod, it was installed on this forum for some reason. ;)
SMF Friend (Former Support Specialist) | SimplePortal Developer
My SMF Mods | SimplePortal

"Quis custodiet ipsos custodes?" - Who will Guard the Guards?

Please don't send me ANY support related PMs. I will just delete them.

Offline [SiNaN]

  • Mr. SimplePortal
  • Developer
  • *
  • Posts: 6782
  • SMF Version: 2.0.15
  • SP Version: 2.3.7
Re: [Bug] Recent Posts
« Reply #5 on: July 28, 2008, 03:45:25 AM »
What was the error?
And slowly, you come to realize... It's all as it should be...

Offline Nathaniel

  • Comrade
  • *
  • Posts: 5203
  • Gender: Male
    • Verbtest.com
  • SMF Version: 2 RC4
  • SP Version: 2.3.3
Re: [Bug] Recent Posts
« Reply #6 on: July 28, 2008, 03:58:57 AM »
http://jeunosky.net/simpleportal/index.php?action=viewErrorLog;desc

8: Undefined index: link
File: /home/em1lycat/public_html/simpleportal/Sources/SPortal.php
Line: 958
SMF Friend (Former Support Specialist) | SimplePortal Developer
My SMF Mods | SimplePortal

"Quis custodiet ipsos custodes?" - Who will Guard the Guards?

Please don't send me ANY support related PMs. I will just delete them.

Offline ccbtimewiz

  • Hero Member
  • *****
  • Posts: 2185
  • Gender: Male
  • $("div.content:dd").hide();
  • SMF Version: None
  • SP Version: None
  • Elkarte Version: None
  • EhPortal Version: None
Re: [Bug] Recent Posts
« Reply #7 on: August 01, 2008, 02:32:57 PM »
I fixed it.

I did this:

Code: (SPortal.php) [Select]
//Add Colors to the Output link :)
if( !empty( $colorids ) ) {
global $color_profile;

sp_loadColors( $colorids );
foreach( $posts as $k => $p ) {
if( !empty( $color_profile[$p['poster']['id']] ) )
$profile = $color_profile[$p['poster']['id']];
if( !empty( $profile ) ) {
$posts[$k]['poster']['link'] = $profile['link']; }
else {
$post[$k]['poster']['link'] = ''; }
}
}

Offline Nathaniel

  • Comrade
  • *
  • Posts: 5203
  • Gender: Male
    • Verbtest.com
  • SMF Version: 2 RC4
  • SP Version: 2.3.3
Re: [Bug] Recent Posts
« Reply #8 on: August 01, 2008, 08:19:28 PM »
Have you done it for this website? Because at the moment its not working. ;)

Notice the error on this page:
http://jeunosky.net/simpleportal/index.php

I know its difficult to find, but there are errors. :P
« Last Edit: August 01, 2008, 11:34:12 PM by LHVWB »
SMF Friend (Former Support Specialist) | SimplePortal Developer
My SMF Mods | SimplePortal

"Quis custodiet ipsos custodes?" - Who will Guard the Guards?

Please don't send me ANY support related PMs. I will just delete them.

Offline [SiNaN]

  • Mr. SimplePortal
  • Developer
  • *
  • Posts: 6782
  • SMF Version: 2.0.15
  • SP Version: 2.3.7
Re: [Bug] Recent Posts
« Reply #9 on: August 02, 2008, 09:26:59 AM »
Okay let's try this:

SPortal.php

Find:

Code: [Select]
//This is  a small Skript to load colors for ssi
function sp_loadColors($users = array()) {
global $color_profile, $db_prefix, $scripturl;

// Can't just look for no users :P.
if (empty($users))
return false;

// Make sure it's an array.
$users = !is_array($users) ? array($users) : array_unique($users);

//First check is it already loaded?
if(empty($color_profile))
$color_profile = array();
else {
foreach($users as $k => $u)
if(isset($color_profile[$u]))
unset($users[$k]);
}

if (empty($users))
return false;

// Load the data.
$request = db_query("
SELECT
mem.ID_MEMBER, mem.memberName, mem.realName, mem.ID_GROUP,
mg.onlineColor AS member_group_color, pg.onlineColor AS post_group_color
FROM {$db_prefix}members AS mem
LEFT JOIN {$db_prefix}membergroups AS pg ON (pg.ID_GROUP = mem.ID_POST_GROUP)
LEFT JOIN {$db_prefix}membergroups AS mg ON (mg.ID_GROUP = mem.ID_GROUP)
WHERE mem.ID_MEMBER ".(count($users) == 1 ? " = '" . current($users) . "'" : " IN ('" . implode("', '", $users) . "')"), __FILE__, __LINE__);

$loaded_ids = array();
while ($row = mysql_fetch_assoc($request))
{
$loaded_ids[] = $row['ID_MEMBER'];
$color_profile[$row['ID_MEMBER']] = $row;
$color_profile[$row['ID_MEMBER']]['link'] = '<a href="' . $scripturl . '?action=profile;u=' . $row['ID_MEMBER'] . '">' . (!empty($row['member_group_color']) || !empty($row['post_group_color']) ? '<span style="color:'. (!empty($row['member_group_color']) ? $row['member_group_color'] : $row['post_group_color'] ) .';">' : '' ) . $row['realName'] . (!empty($row['member_group_color']) || !empty($row['post_group_color']) ? '</span>' : '' ).'</a>';
}
mysql_free_result($request);

return empty($loaded_ids) ? false : $loaded_ids;
}

Replace:

Code: [Select]
function sp_loadColors($users = array()) {
global $db_prefix, $scripturl;

if (empty($users))
return false;

$users = !is_array($users) ? array($users) : array_unique($users);

if(empty($color_profile))
$color_profile = array();
else {
foreach($users as $u)
if(isset($color_profile[$u]))
unset($users[$u]);
}

if (empty($users))
return false;

$request = db_query("
SELECT
mem.ID_MEMBER, mem.memberName, mem.realName, mem.ID_GROUP,
mg.onlineColor AS member_group_color, pg.onlineColor AS post_group_color
FROM {$db_prefix}members AS mem
LEFT JOIN {$db_prefix}membergroups AS pg ON (pg.ID_GROUP = mem.ID_POST_GROUP)
LEFT JOIN {$db_prefix}membergroups AS mg ON (mg.ID_GROUP = mem.ID_GROUP)
WHERE mem.ID_MEMBER ".(count($users) == 1 ? " = '" . current($users) . "'" : " IN ('" . implode("', '", $users) . "')"), __FILE__, __LINE__);

$loaded_ids = array();
while ($row = mysql_fetch_assoc($request))
{
$loaded_ids[] = $row['ID_MEMBER'];
$color_profile[$row['ID_MEMBER']] = $row;
$color_profile[$row['ID_MEMBER']]['link'] = '<a href="' . $scripturl . '?action=profile;u=' . $row['ID_MEMBER'] . '">' . (!empty($row['member_group_color']) || !empty($row['post_group_color']) ? '<span style="color:'. (!empty($row['member_group_color']) ? $row['member_group_color'] : $row['post_group_color'] ) .';">' : '' ) . $row['realName'] . (!empty($row['member_group_color']) || !empty($row['post_group_color']) ? '</span>' : '' ).'</a>';
}
mysql_free_result($request);

return empty($color_profile) ? false : $color_profile;
}

Find:

Code: [Select]
//Add Colors to the Output link :)
if(!empty($colorids)) {
global $color_profile;
sp_loadColors($colorids);
foreach($posts as $k => $p) {
if(!empty($color_profile[$p['poster']['id']]))
$profile = $color_profile[$p['poster']['id']];
if(!empty($profile)) {
$posts[$k]['poster']['link'] = $profile['link'];
}
}
}

Replace:

Code: [Select]
if(!empty($colorids)) {
$color_profile = sp_loadColors($colorids);
foreach($posts as $k => $p) {
if(!empty($color_profile[$p['poster']['id']])) {
$profile = $color_profile[$p['poster']['id']];
if(!empty($profile)) {
$posts[$k]['poster']['link'] = $profile['link'];
}
}
}
}

Just works for recent posts now. Can you check too?
And slowly, you come to realize... It's all as it should be...

Offline Nathaniel

  • Comrade
  • *
  • Posts: 5203
  • Gender: Male
    • Verbtest.com
  • SMF Version: 2 RC4
  • SP Version: 2.3.3
Re: [Bug] Recent Posts
« Reply #10 on: August 02, 2008, 09:32:36 AM »
Hmm, those edits just seem to completely remove the colors for me.
SMF Friend (Former Support Specialist) | SimplePortal Developer
My SMF Mods | SimplePortal

"Quis custodiet ipsos custodes?" - Who will Guard the Guards?

Please don't send me ANY support related PMs. I will just delete them.

Offline [SiNaN]

  • Mr. SimplePortal
  • Developer
  • *
  • Posts: 6782
  • SMF Version: 2.0.15
  • SP Version: 2.3.7
Re: [Bug] Recent Posts
« Reply #11 on: August 02, 2008, 09:37:13 AM »
Okay, checking that again.
And slowly, you come to realize... It's all as it should be...

Offline [SiNaN]

  • Mr. SimplePortal
  • Developer
  • *
  • Posts: 6782
  • SMF Version: 2.0.15
  • SP Version: 2.3.7
Re: [Bug] Recent Posts
« Reply #12 on: August 02, 2008, 09:41:01 AM »
Actually the second edit can appear more than once. Go to line 953 and change that one.
And slowly, you come to realize... It's all as it should be...

Offline Nathaniel

  • Comrade
  • *
  • Posts: 5203
  • Gender: Male
    • Verbtest.com
  • SMF Version: 2 RC4
  • SP Version: 2.3.3
Re: [Bug] Recent Posts
« Reply #13 on: August 02, 2008, 09:49:42 AM »
Hmm, it still isn't working for some reason, although it may be that particular smf install.

Attached is my dodgy Sportal.php file, its probably pretty hacky, because its almost midnight and I did the edits quickly. ;)
« Last Edit: August 02, 2008, 09:52:16 AM by LHVWB »
SMF Friend (Former Support Specialist) | SimplePortal Developer
My SMF Mods | SimplePortal

"Quis custodiet ipsos custodes?" - Who will Guard the Guards?

Please don't send me ANY support related PMs. I will just delete them.

Offline Nathaniel

  • Comrade
  • *
  • Posts: 5203
  • Gender: Male
    • Verbtest.com
  • SMF Version: 2 RC4
  • SP Version: 2.3.3
Re: [Bug] Recent Posts
« Reply #14 on: August 02, 2008, 09:58:24 AM »
Well, it works, I am only getting errors for lines 721 and 1276. Which are different block types.

I am now *officially* sleeping.
SMF Friend (Former Support Specialist) | SimplePortal Developer
My SMF Mods | SimplePortal

"Quis custodiet ipsos custodes?" - Who will Guard the Guards?

Please don't send me ANY support related PMs. I will just delete them.

Offline [SiNaN]

  • Mr. SimplePortal
  • Developer
  • *
  • Posts: 6782
  • SMF Version: 2.0.15
  • SP Version: 2.3.7
Re: [Bug] Recent Posts
« Reply #15 on: August 02, 2008, 09:59:17 AM »
Okay Nath, have a good sleep. Thanks.

Bug knocked down. 8)
And slowly, you come to realize... It's all as it should be...

Offline Nathaniel

  • Comrade
  • *
  • Posts: 5203
  • Gender: Male
    • Verbtest.com
  • SMF Version: 2 RC4
  • SP Version: 2.3.3
Re: [Bug] Recent Posts
« Reply #16 on: August 07, 2008, 03:39:27 AM »
Bug knocked down. 8)

Hmm, not so sure about that. We are still getting errors on this website. Are we running the lastest version of Simple Portal? With all the updates and fixes? Preferably a clean version?
SMF Friend (Former Support Specialist) | SimplePortal Developer
My SMF Mods | SimplePortal

"Quis custodiet ipsos custodes?" - Who will Guard the Guards?

Please don't send me ANY support related PMs. I will just delete them.

Offline Eliana Tamerin

  • Comrade
  • *
  • Posts: 2889
  • Gender: Female
  • SMF Version: 2 RC2
  • SP Version: 2.3.2
Re: [Bug] Recent Posts
« Reply #17 on: August 07, 2008, 12:38:28 PM »
We're running SiNaN's beta package. If you've got edits to commit to it, feel free to log into the FTP and do so.
Ms. Eliana Tamerin

It should be painfully obvious by now that I don't respond to support PMs. Don't send me PMs for support. They will be ignored and deleted, post on the Support Boards to get support.

Offline [SiNaN]

  • Mr. SimplePortal
  • Developer
  • *
  • Posts: 6782
  • SMF Version: 2.0.15
  • SP Version: 2.3.7
Re: [Bug] Recent Posts
« Reply #18 on: August 09, 2008, 10:12:50 AM »
This bug wasn't included in that package, I'll include in the release.
And slowly, you come to realize... It's all as it should be...