collapse collapse

* Simple Portal Archived Forum

This is an Archive Forum.

The content in this forum may be out-of-date or have been superseded by newer information, and links in forum pages to other sites may not work.
This forum contains archives for future reference.

Visit our thread at Simple Machines Forum for current support.

* User Info

 
 
Welcome, Guest. Please login or register.

* Who's Online

  • Dot Guests: 617
  • Dot Hidden: 0
  • Dot Users: 0

There aren't any users online.

* Shoutbox

Refresh History
  • Shoutbox is not for support!
  • {OCS}MasterSeal: Yup, Still adore SP
    April 21, 2019, 07:08:06 PM
  • {OCS}MasterSeal: STILL love SP :)
    November 24, 2018, 05:05:50 AM
  • ♦ Ninja ZX-10RR ♦: <3 aegersz
    September 13, 2018, 03:36:09 PM
  • aegersz: I STILL <3 LOVE SimplePortal
    September 13, 2018, 07:11:39 AM
  • aegersz: o LOVE you guys - Simple Portal rocks !
    May 09, 2018, 05:18:59 AM
  • Chen Zhen: our apologies for the site being down.. please read server issues topic
    March 22, 2018, 05:32:38 AM
  • {OCS}MasterSeal: LOL PLEASE forget I just posted that. I found the answer in my own dang post back in 2015. lol sorry!
    July 04, 2017, 10:47:55 PM
  • {OCS}MasterSeal: I know this SB isnt' for support, but I just have a general question. Who would I contact to find out where SP stores its block info? Is it DB driven or files? I searched the site but came up with nothing. probably my fault any insight is appreciated.
    July 04, 2017, 10:43:36 PM
  • ♦ Ninja ZX-10RR ♦: Excuse me but what does Simpleportal have to deal with that?
    February 05, 2017, 08:21:14 PM
  • WhiteEagle: of course IMHO that site appears to be dead :(
    February 04, 2017, 01:08:05 PM
  • WhiteEagle: If I can get that, then I'll use it for that site...
    February 04, 2017, 01:07:35 PM
  • WhiteEagle: decided to not use SMF for any projects, unless I can get a copy of the premium version of the fanfiction archive plugin
    February 04, 2017, 01:06:54 PM
  • expertdecisions: cloudflare
    January 28, 2017, 08:01:47 AM
  • aegersz: SM release 2.0.13 !
    January 12, 2017, 06:00:13 AM
  • raffo: Tks Emanuele, even if I didn't understand the fix :D
    November 07, 2016, 02:01:20 AM
  • emanuele: [link]
    November 01, 2016, 12:43:50 PM
  • emanuele: raffo: the English support board is a good place. ;)
    November 01, 2016, 12:43:38 PM
  • raffo: Where can I find the fix for the shoutbox?
    November 01, 2016, 05:06:09 AM
  • {OCS}MasterSeal: To the SP team, I make a point to come here and thank you as much as possible for your work.  so again, THANK YOU!
    October 28, 2016, 10:38:05 AM
  • emanuele: That's indeed funny, the limit is present only in the patch and not the full install.
    October 22, 2016, 06:14:58 PM

* Recent Posts

Adding Forums Button to Nav bar by jirapon
[August 01, 2019, 09:07:12 AM]


Re: Board Icons by ♦ Ninja ZX-10RR ♦
[July 30, 2019, 04:03:41 PM]


MOVED: Czech translation???? by ♦ Ninja ZX-10RR ♦
[July 30, 2019, 03:04:51 PM]


Board Icons by jirapon
[July 30, 2019, 07:28:44 AM]


Re: Thankyou Simpleportal, by ♦ Ninja ZX-10RR ♦
[July 29, 2019, 09:41:29 AM]

Welcome to SimplePortal.net! You can download SimplePortal from the Downloads Area!

Author Topic: Top Alignment problem.  (Read 10275 times)

0 Members and 1 Guest are viewing this topic.

Offline Black Tiger

  • Jr. Member
  • **
  • Posts: 60
  • Gender: Male
  • SMF Version: 2.0.11
  • SP Version: 2.3.6
Re: Top Alignment problem.
« Reply #20 on: March 13, 2014, 08:15:46 PM »
An edit to index.php?
Oeps... then I might have misunderstood something. I did not make any changes to the index.php. Would that be the main index.php in the /forum directory or the index.php in public_html (which was named PortalStandalone.php initially)?


Greetings, Black Tiger

Offline Chen Zhen

  • The Underdog
  • Operations Manager
  • *
  • Posts: 1350
  • Gender: Male
  • Kinesis
    • WebDev
  • SMF Version: 2.1
  • EhPortal Version: 1.22
Re: Top Alignment problem.
« Reply #21 on: March 13, 2014, 08:31:21 PM »
Black Tiger,

  The previous edit was for the main index.php file (../forum/index.php). It just fixes it when someone types in a bogus action into the url.



  The file in the last post should work just fine for you. However I am going to post another replacement file that should be set up simple enough for you to understand how to add your own future custom actions and sub-actions without my assistance.  This is in case you add mods or custom pages that require further corrections.

Put the attached file into this path (overwrite old file):
../Themes/ProRedV1-u

Here is an array that is contained within the file that imo you can figure out how to add to if necessary in the future:
Code: [Select]
$customActionArray = array(
'forum' => 17,
'search' => 21,
'download' => 17,
'contact' => 17,
'pm' => 16,
'pm;sa=send;' => 15,
);

  So when you add something (mod, page, etc.) in the future that requires a fix for the top right block, you just add it to that array contained within the file (approx. line 92). It is set up as: [ACTION] or  ACTION;sa=[SUB-ACTION]

  Make sure the entries are lower case as my explanation is just to stress what to do.  Also ensure all sub-actions are at the end of the array.
« Last Edit: March 13, 2014, 08:39:09 PM by Underdog »

Offline Black Tiger

  • Jr. Member
  • **
  • Posts: 60
  • Gender: Male
  • SMF Version: 2.0.11
  • SP Version: 2.3.6
Re: Top Alignment problem.
« Reply #22 on: March 13, 2014, 09:03:37 PM »
Oh wow, you're the best, I can adjust it myself now. Just found out that contact was a bit too high, easy to adjust put 2 px less and it works. Great!
I can edit this myself indeed, you made my life easy now.  :applause:

Just a last question. Is it just as easy to have the vertical white space kind of the same? Or is this a lot of work? It's not problem if it can't be done the same way, I'm already very happy with all the work you did for me and the horizontal alignment.

I added a screenshot to let you see what I mean, this space differs on some actions:
1 = vertical white space difference
2 = white space difference between main forum and right side column

Again, this has no hurry at all and if it can't be done, I'm already very thankfull for all your work done now.
Greetings, Black Tiger

Offline Chen Zhen

  • The Underdog
  • Operations Manager
  • *
  • Posts: 1350
  • Gender: Male
  • Kinesis
    • WebDev
  • SMF Version: 2.1
  • EhPortal Version: 1.22
Re: Top Alignment problem.
« Reply #23 on: March 13, 2014, 09:48:58 PM »

  The space at the top under the link tree is actually theme related specifically & not to do with Simple Portal. However, I will show you a simple edit to lessen the space under the link tree.

File: ../Themes/ProRedV1-u/index.template.php

find:
Code: [Select]
echo '
<div class="navigate_section">
<ul>';

replace with:
Code: [Select]
echo '
<div class="navigate_section" style="position:relative;height:0.1em;">
<ul>';



Put the attached file into this path (overwrite old file):
../Themes/ProRedV1-u

  There is now some adjustment that lessens the space between the side blocks and the center. However the exact width is not uniform for the home page compared to all other pages although it is imo close enough.

Offline Black Tiger

  • Jr. Member
  • **
  • Posts: 60
  • Gender: Male
  • SMF Version: 2.0.11
  • SP Version: 2.3.6
Re: Top Alignment problem.
« Reply #24 on: March 13, 2014, 10:43:01 PM »
Thanks! With your tip I can adjust that vertical whitespace myself.

For the portal template, I don't see any visual difference between the previous and the last one after implementation.

There is probably 1 px difference between forum and downloads. Only the search has 2-3px more white space.

On the Portal.template.php I changed the following myself:
1.) download -> downloads (cause the action is called downloads and the aligment works too)
2.) Contact 17px->15px

No other changes made.
Greetings, Black Tiger

Offline Chen Zhen

  • The Underdog
  • Operations Manager
  • *
  • Posts: 1350
  • Gender: Male
  • Kinesis
    • WebDev
  • SMF Version: 2.1
  • EhPortal Version: 1.22
Re: Top Alignment problem.
« Reply #25 on: March 13, 2014, 11:21:59 PM »
Black Tiger,

Put the attached file into this path (overwrite old file):
../Themes/ProRedV1-u

The array has now been changed to include a left positioning adjustment.

Code: [Select]
$customActionArray = array(
'forum' => array(17, -5),
'search' => array(21, -9),
'downloads' => array(17, -3),
'contact' => array(15, -3),
'pm' => array(16, -3),
'pm;sa=send;' => array(15, -3),
);

The format is:
'[ACTION]' => array([TOP PADDING], [LEFT PROPERTY]),

or

'[ACTION];sa=[SUB-ACTION]' => array([TOP PADDING], [LEFT PROPERTY]),



The default left property integer should be -3 and you can adjust it if you see something not lining up with any custom edits you add.
« Last Edit: March 13, 2014, 11:34:34 PM by Underdog »

Offline Black Tiger

  • Jr. Member
  • **
  • Posts: 60
  • Gender: Male
  • SMF Version: 2.0.11
  • SP Version: 2.3.6
Re: Top Alignment problem.
« Reply #26 on: March 14, 2014, 10:00:54 AM »
Thank you, but something still isn't working......
I changed:
Code: [Select]
'search' => array(21, -9),to
Code: [Select]
'search' => array(21, -3),and nothing changed.

However, I think we can't solve this little problem. Because when I have a look with Internet Explorer, the alignment looks very good.
It doesn't change in IE either when I change -9 to -3, but the whitespace is much more equal there between then actions then with Firefox.
In spite of the fact that I don't use cache in Firefox, refreshed the page, deleted the cache, it just looks better with IE.
And I presume these kind of browser specific differences can't be fixed, correct?
Greetings, Black Tiger

Offline Chen Zhen

  • The Underdog
  • Operations Manager
  • *
  • Posts: 1350
  • Gender: Male
  • Kinesis
    • WebDev
  • SMF Version: 2.1
  • EhPortal Version: 1.22
Re: Top Alignment problem.
« Reply #27 on: March 14, 2014, 02:41:01 PM »
  I found the portal css for the space between cells which will probably work better than the extra edit I added for that display.

  The behavior is different for most browsers. I found that custom theme has many css padding entries not to mention that some of the default template files it uses contain line breaks in some areas which is why the center drops down so much in specific areas.  Imo the only way to get something working as you want is to write a routine that detects the browser and adjusts according to that (ie. using javascript). Also to copy some of the theme files from the default to that theme's directory and edit them to remove various line breaks and/or add custom styling attributes.

  All of this is just something custom for your preference whereas the current appearance/display will be similar for any portal you opt to use. That being said, this is something that is mostly not Simple Portal support specific but rather a custom project to adjust that theme.
 

Offline Black Tiger

  • Jr. Member
  • **
  • Posts: 60
  • Gender: Male
  • SMF Version: 2.0.11
  • SP Version: 2.3.6
Re: Top Alignment problem.
« Reply #28 on: March 14, 2014, 02:46:33 PM »
I already thought something like that. Thank you for explaining.

But even thank you more for all the effort you put in this with all the work. I'm very satisfied with support and very happy my top alignment is adjustable now!

Thanks!!
 :applause: :D
Greetings, Black Tiger

Offline Chen Zhen

  • The Underdog
  • Operations Manager
  • *
  • Posts: 1350
  • Gender: Male
  • Kinesis
    • WebDev
  • SMF Version: 2.1
  • EhPortal Version: 1.22
Re: Top Alignment problem.
« Reply #29 on: March 14, 2014, 03:03:27 PM »
  Due to the horizontal spacing between blocks in the last template file that was provided, it may be better to use the template file from this post:
http://simpleportal.net/index.php?topic=13243.msg65537#msg65537



For the space between blocks, you can edit the following file:
../Themes/default/css/portal.css

.. you can also copy that file to: ../Themes/ProRedV1-u/css and edit it within that folder if you do not want to affect other themes.

Find this:
Code: [Select]
#sp_main
{
width: 100%;
border-spacing: 5px;
table-layout: fixed;
}

.. edit the border-spacing attribute to something smaller. To have finer measurement control you can use em instead of px whereas decimals can be used. The int number will have be smaller though ie. 0.5em

Regards.
« Last Edit: March 14, 2014, 03:20:45 PM by Underdog »

Offline Black Tiger

  • Jr. Member
  • **
  • Posts: 60
  • Gender: Male
  • SMF Version: 2.0.11
  • SP Version: 2.3.6
Re: Top Alignment problem.
« Reply #30 on: March 14, 2014, 06:34:01 PM »
I used the template from the post you pointed to, and changed the px from 5 to 3px in portal.css.
Looks nice! And I can play with it furter if needed, but I think it's good this way.
I don't mind those 2 that differ a bit.

Tonight or tomorrow I will fix the white space in height with the tips you gave me.

Great work, thank you!
Greetings, Black Tiger

Offline Chen Zhen

  • The Underdog
  • Operations Manager
  • *
  • Posts: 1350
  • Gender: Male
  • Kinesis
    • WebDev
  • SMF Version: 2.1
  • EhPortal Version: 1.22
Re: Top Alignment problem.
« Reply #31 on: March 14, 2014, 11:28:15 PM »

  Sometimes the easiest solution does not come to me, other times right away.
I am going to quote what I just wrote to someone which applies to your situation.

Quote from: Underdog
If you installed the theme after Simple Portal, then perhaps try uninstalling Simple Portal & then installing it again. This process will add image files and edit that theme's display template.

Please let me know if that solves the issue.

Offline Black Tiger

  • Jr. Member
  • **
  • Posts: 60
  • Gender: Male
  • SMF Version: 2.0.11
  • SP Version: 2.3.6
Re: Top Alignment problem.
« Reply #32 on: March 15, 2014, 09:01:59 AM »
I don't think so, because I already had my Pro Red theme installed before I installed Simpleportal.
And when I had the problem this week when I changed to stand alone portal, I also uninstalled and reinstalled again.
So in this case it did not work for me.
Greetings, Black Tiger