collapse collapse

* Archive Notice

This is an Archive Forum.

The content in this forum may be out-of-date or have been superseded by newer information, and links in forum pages to other sites may not work. This forum contains archives for future reference.

Visit our thread at Simple Machines Forum for current support.

* User Info

 
 
Welcome, Guest. Please login or register.

* Who's Online

  • Dot Guests: 282
  • Dot Hidden: 0
  • Dot Users: 0

There aren't any users online.

* Shoutbox

Refresh History
  • Shoutbox is not for support!
  • {OCS}MasterSeal: Yup, Still adore SP
    April 21, 2019, 07:08:06 PM
  • {OCS}MasterSeal: STILL love SP :)
    November 24, 2018, 05:05:50 AM
  • ♦ Ninja ZX-10RR ♦: <3 aegersz
    September 13, 2018, 03:36:09 PM
  • aegersz: I STILL <3 LOVE SimplePortal
    September 13, 2018, 07:11:39 AM
  • aegersz: o LOVE you guys - Simple Portal rocks !
    May 09, 2018, 05:18:59 AM
  • Chen Zhen: our apologies for the site being down.. please read server issues topic
    March 22, 2018, 05:32:38 AM
  • {OCS}MasterSeal: LOL PLEASE forget I just posted that. I found the answer in my own dang post back in 2015. lol sorry!
    July 04, 2017, 10:47:55 PM
  • {OCS}MasterSeal: I know this SB isnt' for support, but I just have a general question. Who would I contact to find out where SP stores its block info? Is it DB driven or files? I searched the site but came up with nothing. probably my fault any insight is appreciated.
    July 04, 2017, 10:43:36 PM
  • ♦ Ninja ZX-10RR ♦: Excuse me but what does Simpleportal have to deal with that?
    February 05, 2017, 08:21:14 PM
  • WhiteEagle: of course IMHO that site appears to be dead :(
    February 04, 2017, 01:08:05 PM
  • WhiteEagle: If I can get that, then I'll use it for that site...
    February 04, 2017, 01:07:35 PM
  • WhiteEagle: decided to not use SMF for any projects, unless I can get a copy of the premium version of the fanfiction archive plugin
    February 04, 2017, 01:06:54 PM
  • expertdecisions: cloudflare
    January 28, 2017, 08:01:47 AM
  • aegersz: SM release 2.0.13 !
    January 12, 2017, 06:00:13 AM
  • raffo: Tks Emanuele, even if I didn't understand the fix :D
    November 07, 2016, 02:01:20 AM
  • emanuele: [link]
    November 01, 2016, 12:43:50 PM
  • emanuele: raffo: the English support board is a good place. ;)
    November 01, 2016, 12:43:38 PM
  • raffo: Where can I find the fix for the shoutbox?
    November 01, 2016, 05:06:09 AM
  • {OCS}MasterSeal: To the SP team, I make a point to come here and thank you as much as possible for your work.  so again, THANK YOU!
    October 28, 2016, 10:38:05 AM
  • emanuele: That's indeed funny, the limit is present only in the patch and not the full install.
    October 22, 2016, 06:14:58 PM

* Recent Posts

Adding Forums Button to Nav bar by jirapon
[August 01, 2019, 09:07:12 AM]


Re: Board Icons by ♦ Ninja ZX-10RR ♦
[July 30, 2019, 04:03:41 PM]


MOVED: Czech translation???? by ♦ Ninja ZX-10RR ♦
[July 30, 2019, 03:04:51 PM]


Board Icons by jirapon
[July 30, 2019, 07:28:44 AM]


Re: Thankyou Simpleportal, by ♦ Ninja ZX-10RR ♦
[July 29, 2019, 09:41:29 AM]

Blocks speak! Do you have an interest in getting more blocks - or even making your own? The Blocks Board is for you!

Author Topic: logoff/logon fails with Unable to verify referring url. Please go back ... msg  (Read 5392 times)

0 Members and 1 Guest are viewing this topic.

Offline Ron-KK4HGY

  • Semi Newbie
  • *
  • Posts: 22
  • SMF Version: 2.0.8
  • SP Version: 2.3.5
When I am on the front page and try to log off I get this message:  Unable to verify referring url. Please go back and try again.  Some times it takes 2 or three tries before I can log off and sometimes I give up and go to FORUM where I can log off with no problem.

I also have this problem when I hit ADMIN and it asks for the password. Usually it takes two tries before I can get past the error message.

I have SMF 2.08 and SP 2.3.6 alpha.  It did it with 2.3.5 as well.  Lately I have just been going to FORUM to log off.  2.3.6 has fixed my shoutbox problem and I am very happy about that.  Thanks.

Offline [SiNaN]

  • Mr. SimplePortal
  • Developer
  • *
  • Posts: 6782
  • SMF Version: 2.0.15
  • SP Version: 2.3.7
Try removing the "www." part from your site URL in the redirect page you have in your website root. That should fix this issue.
And slowly, you come to realize... It's all as it should be...

Offline Ron-KK4HGY

  • Semi Newbie
  • *
  • Posts: 22
  • SMF Version: 2.0.8
  • SP Version: 2.3.5
Well that was easy.  It seems to be working, but I have no idea why.  Should I take all the wwws's off links to pages on my site?

Offline [SiNaN]

  • Mr. SimplePortal
  • Developer
  • *
  • Posts: 6782
  • SMF Version: 2.0.15
  • SP Version: 2.3.7
From my understanding, there should be consistency in the URLs of your forum.

In order to verify that it is you who wants to log out intentionally, there is some code that checks the URL of the page on which you have clicked the log out button/link. The code expects an exact match. So although http://somesite.com/ and http://www.somesite.com/ doesn't look different to you, they are not exactly the same as far as that code goes. It also causes problems with HTTP access control, which I recently fixed for shoutbox - that wasn't as easy as this one though.

Basically, you should see if your forum base URL (the URL that you set while installing SMF) has the "www." part or not. (in your case, it doesn't) Then make sure all your custom scripts and linking are consistent with that to prevent such issues.
And slowly, you come to realize... It's all as it should be...

Offline Ron-KK4HGY

  • Semi Newbie
  • *
  • Posts: 22
  • SMF Version: 2.0.8
  • SP Version: 2.3.5
Well that is good to know.  I will make adjustments as necessary.  Thank you for your quick reply and help.

Offline [SiNaN]

  • Mr. SimplePortal
  • Developer
  • *
  • Posts: 6782
  • SMF Version: 2.0.15
  • SP Version: 2.3.7
You're welcome. ;)
And slowly, you come to realize... It's all as it should be...