collapse collapse

* Simple Portal Archived Forum

This is an Archive Forum.

The content in this forum may be out-of-date or have been superseded by newer information, and links in forum pages to other sites may not work.
This forum contains archives for future reference.

Visit our thread at Simple Machines Forum for current support.

* User Info

 
 
Welcome, Guest. Please login or register.

* Who's Online

  • Dot Guests: 528
  • Dot Hidden: 0
  • Dot Users: 0

There aren't any users online.

* Shoutbox

Refresh History
  • Shoutbox is not for support!
  • {OCS}MasterSeal: Yup, Still adore SP
    April 21, 2019, 07:08:06 PM
  • {OCS}MasterSeal: STILL love SP :)
    November 24, 2018, 05:05:50 AM
  • ♦ Ninja ZX-10RR ♦: <3 aegersz
    September 13, 2018, 03:36:09 PM
  • aegersz: I STILL <3 LOVE SimplePortal
    September 13, 2018, 07:11:39 AM
  • aegersz: o LOVE you guys - Simple Portal rocks !
    May 09, 2018, 05:18:59 AM
  • Chen Zhen: our apologies for the site being down.. please read server issues topic
    March 22, 2018, 05:32:38 AM
  • {OCS}MasterSeal: LOL PLEASE forget I just posted that. I found the answer in my own dang post back in 2015. lol sorry!
    July 04, 2017, 10:47:55 PM
  • {OCS}MasterSeal: I know this SB isnt' for support, but I just have a general question. Who would I contact to find out where SP stores its block info? Is it DB driven or files? I searched the site but came up with nothing. probably my fault any insight is appreciated.
    July 04, 2017, 10:43:36 PM
  • ♦ Ninja ZX-10RR ♦: Excuse me but what does Simpleportal have to deal with that?
    February 05, 2017, 08:21:14 PM
  • WhiteEagle: of course IMHO that site appears to be dead :(
    February 04, 2017, 01:08:05 PM
  • WhiteEagle: If I can get that, then I'll use it for that site...
    February 04, 2017, 01:07:35 PM
  • WhiteEagle: decided to not use SMF for any projects, unless I can get a copy of the premium version of the fanfiction archive plugin
    February 04, 2017, 01:06:54 PM
  • expertdecisions: cloudflare
    January 28, 2017, 08:01:47 AM
  • aegersz: SM release 2.0.13 !
    January 12, 2017, 06:00:13 AM
  • raffo: Tks Emanuele, even if I didn't understand the fix :D
    November 07, 2016, 02:01:20 AM
  • emanuele: [link]
    November 01, 2016, 12:43:50 PM
  • emanuele: raffo: the English support board is a good place. ;)
    November 01, 2016, 12:43:38 PM
  • raffo: Where can I find the fix for the shoutbox?
    November 01, 2016, 05:06:09 AM
  • {OCS}MasterSeal: To the SP team, I make a point to come here and thank you as much as possible for your work.  so again, THANK YOU!
    October 28, 2016, 10:38:05 AM
  • emanuele: That's indeed funny, the limit is present only in the patch and not the full install.
    October 22, 2016, 06:14:58 PM

* Recent Posts

Adding Forums Button to Nav bar by jirapon
[August 01, 2019, 09:07:12 AM]


Re: Board Icons by ♦ Ninja ZX-10RR ♦
[July 30, 2019, 04:03:41 PM]


MOVED: Czech translation???? by ♦ Ninja ZX-10RR ♦
[July 30, 2019, 03:04:51 PM]


Board Icons by jirapon
[July 30, 2019, 07:28:44 AM]


Re: Thankyou Simpleportal, by ♦ Ninja ZX-10RR ♦
[July 29, 2019, 09:41:29 AM]

Welcome to SimplePortal.net! You can download SimplePortal from the Downloads Area!

Author Topic: "Custom Title Class" Not Working  (Read 5354 times)

0 Members and 1 Guest are viewing this topic.

Offline dopeitspaul

  • Semi Newbie
  • *
  • Posts: 24
  • SMF Version: 2.0.8
  • SP Version: 2.3.5
"Custom Title Class" Not Working
« on: August 23, 2014, 07:09:24 PM »
Hey everyone, I have side blocks on the right and the title bar is matching with my category bar. I was trying to add my own custom title class from my index.css but nothing happens, it's still using the default title class.

Anyone know how to get custom title class to work? Thanks

Offline phantomm

  • Translator
  • *
  • Posts: 406
  • Gender: Male
  • Smile, tomorrow will be worse...
    • Polish ElkArte community
  • SMF Version: None
  • Elkarte Version: 1.0.5
Re: "Custom Title Class" Not Working
« Reply #1 on: August 24, 2014, 06:18:42 AM »
What block are you using?

Offline dopeitspaul

  • Semi Newbie
  • *
  • Posts: 24
  • SMF Version: 2.0.8
  • SP Version: 2.3.5
Re: "Custom Title Class" Not Working
« Reply #2 on: August 24, 2014, 03:27:09 PM »
What block are you using?

Profile and a Recent Post (Custom PHP)


Offline oNLy1

  • Jr. Member
  • **
  • Posts: 53
  • SMF Version: 2.0.2
  • SP Version: 2.3.5
Re: "Custom Title Class" Not Working
« Reply #3 on: August 24, 2014, 09:22:07 PM »
make sure the class is actually in the CSS of the theme being used
then double check that you have called the class (or style) properly via the block settings

remember it should be 'mytitle' and not '.mytitle' or any other variants
just the name (no apostrophe)

Offline dopeitspaul

  • Semi Newbie
  • *
  • Posts: 24
  • SMF Version: 2.0.8
  • SP Version: 2.3.5
Re: "Custom Title Class" Not Working
« Reply #4 on: August 25, 2014, 12:37:25 AM »
make sure the class is actually in the CSS of the theme being used
then double check that you have called the class (or style) properly via the block settings

remember it should be 'mytitle' and not '.mytitle' or any other variants
just the name (no apostrophe)

Yeah I made sure of that but it still not working. Still matches the category bar which is what I'm not trying to do. Thanks though!

Offline dopeitspaul

  • Semi Newbie
  • *
  • Posts: 24
  • SMF Version: 2.0.8
  • SP Version: 2.3.5
Re: "Custom Title Class" Not Working
« Reply #5 on: August 25, 2014, 01:30:27 AM »
Maybe this could be another way of solving it. In the drop down menu of when you click the "default title class" is there a way I can add my own custom css in that menu?

Here's a pic of the menu I'm talking about

Offline oNLy1

  • Jr. Member
  • **
  • Posts: 53
  • SMF Version: 2.0.2
  • SP Version: 2.3.5
Re: "Custom Title Class" Not Working
« Reply #6 on: August 26, 2014, 01:52:52 PM »
Quote
In the drop down menu of when you click the "default title class" is there a way I can add my own custom css in that menu?

Yes - I am not sure if the code is the same now as this is an old post ..but will lead you to what you want
http://simpleportal.net/index.php?topic=4403.msg27057#msg27057

You'll just need to add a single line to Themes/default/PortalAdminBlocks.template.php file.

Code: (Find) [Select]
                           <option value="windowbg3"', $context['SPortal']['block']['style']['body_default_class'] == 'windowbg3' ? ' selected="selected"' : '', '>windowbg3</option>
Code: (Replace) [Select]
                           <option value="windowbg3"', $context['SPortal']['block']['style']['body_default_class'] == 'windowbg3' ? ' selected="selected"' : '', '>windowbg3</option>
                           <option value="classname"', $context['SPortal']['block']['style']['body_default_class'] == 'classname' ? ' selected="selected"' : '', '>classname</option>

Change the classname as the name of class you want to add to that list.

Offline [SiNaN]

  • Mr. SimplePortal
  • Developer
  • *
  • Posts: 6782
  • SMF Version: 2.0.15
  • SP Version: 2.3.7
Re: "Custom Title Class" Not Working
« Reply #7 on: October 11, 2014, 06:57:18 AM »
Unfortunately, we can't do much about this due to the SMF header bars markup. The best you can do would be either to add your own class manually or choose 'catbg' and style it using custom title class and style options.
And slowly, you come to realize... It's all as it should be...