collapse

* Simple Portal Archived Forum

This is an Archive Forum.

The content in this forum may be out-of-date or have been superseded by newer information, and links in forum pages to other sites may not work.
This forum contains archives for future reference.

Visit our thread at Simple Machines Forum for current support.

SMF 2.1 users: EhPortal is a ported version of Simple Portal specifically designed for the SMF 2.1 branch.
Please visit web-develop.ca to download EhPortal and for its support.

* User Info

 
 
Welcome, Guest. Please login or register.

* Who's Online

  • Dot Guests: 250
  • Dot Hidden: 0
  • Dot Users: 0

There aren't any users online.

* Shoutbox

Refresh History
  • Shoutbox is not for support!
  • {OCS}MasterSeal: Yup, Still adore SP
    April 21, 2019, 07:08:06 PM
  • {OCS}MasterSeal: STILL love SP :)
    November 24, 2018, 05:05:50 AM
  • ♦ Ninja ZX-10RR ♦: <3 aegersz
    September 13, 2018, 03:36:09 PM
  • aegersz: I STILL <3 LOVE SimplePortal
    September 13, 2018, 07:11:39 AM
  • aegersz: o LOVE you guys - Simple Portal rocks !
    May 09, 2018, 05:18:59 AM
  • Chen Zhen: our apologies for the site being down.. please read server issues topic
    March 22, 2018, 05:32:38 AM
  • {OCS}MasterSeal: LOL PLEASE forget I just posted that. I found the answer in my own dang post back in 2015. lol sorry!
    July 04, 2017, 10:47:55 PM
  • {OCS}MasterSeal: I know this SB isnt' for support, but I just have a general question. Who would I contact to find out where SP stores its block info? Is it DB driven or files? I searched the site but came up with nothing. probably my fault any insight is appreciated.
    July 04, 2017, 10:43:36 PM
  • ♦ Ninja ZX-10RR ♦: Excuse me but what does Simpleportal have to deal with that?
    February 05, 2017, 08:21:14 PM
  • WhiteEagle: of course IMHO that site appears to be dead :(
    February 04, 2017, 01:08:05 PM
  • WhiteEagle: If I can get that, then I'll use it for that site...
    February 04, 2017, 01:07:35 PM
  • WhiteEagle: decided to not use SMF for any projects, unless I can get a copy of the premium version of the fanfiction archive plugin
    February 04, 2017, 01:06:54 PM
  • expertdecisions: cloudflare
    January 28, 2017, 08:01:47 AM
  • aegersz: SM release 2.0.13 !
    January 12, 2017, 06:00:13 AM
  • raffo: Tks Emanuele, even if I didn't understand the fix :D
    November 07, 2016, 02:01:20 AM
  • emanuele: [link]
    November 01, 2016, 12:43:50 PM
  • emanuele: raffo: the English support board is a good place. ;)
    November 01, 2016, 12:43:38 PM
  • raffo: Where can I find the fix for the shoutbox?
    November 01, 2016, 05:06:09 AM
  • {OCS}MasterSeal: To the SP team, I make a point to come here and thank you as much as possible for your work.  so again, THANK YOU!
    October 28, 2016, 10:38:05 AM
  • emanuele: That's indeed funny, the limit is present only in the patch and not the full install.
    October 22, 2016, 06:14:58 PM

* Recent Posts

Adding Forums Button to Nav bar by jirapon
[August 01, 2019, 09:07:12 AM]


Re: Board Icons by ♦ Ninja ZX-10RR ♦
[July 30, 2019, 04:03:41 PM]


MOVED: Czech translation???? by ♦ Ninja ZX-10RR ♦
[July 30, 2019, 03:04:51 PM]


Board Icons by jirapon
[July 30, 2019, 07:28:44 AM]


Re: Thankyou Simpleportal, by ♦ Ninja ZX-10RR ♦
[July 29, 2019, 09:41:29 AM]

Blocks speak! Do you have an interest in getting more blocks - or even making your own? The Blocks Board is for you!

Author Topic: Shoutbox update error  (Read 9669 times)

0 Members and 1 Guest are viewing this topic.

Offline ♦ Ninja ZX-10RR ♦

  • Spammer Hammer
  • Support
  • *
  • Posts: 1193
  • Gender: Male
  • Sniper Legends
    • Virtual Interactive Games Entertainment™
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
  • Elkarte Version: 1.0.6
Shoutbox update error
« on: December 01, 2014, 03:01:55 PM »
This is the error I am getting if I inspect the browser
Quote
Uncaught TypeError: Object #<error> has no method 'getElementsByTagName' portal.js?236:104

And the Shoutbox doesn't update anymore unless I manually refresh the page... It's probably some kind of conflict with the Project Snow mod... Are there any fixes? Please I would really love to have both mods up and running... :(
Thanks in advance... :(

Edited by Sinan: updated the topic title.
« Last Edit: December 07, 2014, 09:29:27 AM by [SiNaN] »
Have you tried SimplePortal Documentation before asking? ;)
F.A.Q.  English Support  |  Blocks Support
Fancy Feature idea ?!  |  Blocks Requests
Themes & Graphics

? My job! ?No PMs for support unless it's a paid request. Thank you! :)#OpIsis

Offline ♦ Ninja ZX-10RR ♦

  • Spammer Hammer
  • Support
  • *
  • Posts: 1193
  • Gender: Male
  • Sniper Legends
    • Virtual Interactive Games Entertainment™
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
  • Elkarte Version: 1.0.6
Little update... I tried to uninstall the Project Snow mod but the problem is still there, no refresh unless doing a page refresh :| Also tried to uninstall the other FancyBox 4SMF that has a javascript but the issue is still there.
Have you tried SimplePortal Documentation before asking? ;)
F.A.Q.  English Support  |  Blocks Support
Fancy Feature idea ?!  |  Blocks Requests
Themes & Graphics

? My job! ?No PMs for support unless it's a paid request. Thank you! :)#OpIsis

Offline Burke Knight

  • Sr. Member
  • ****
  • Posts: 394
  • Gender: Male
  • I tell it how I see it. Don't like it? Hit Alt+F4
    • BurkeKnight Enterprises
  • SMF Version: None
  • SP Version: None
  • Elkarte Version: None
Are you setting the shoutbox up to auto-refresh?
I'm not certain what the server resources are on the auto-refresh, but I'd keep an eye on it, to be sure it's not overusing the server resources.

However, the first part needs more info, like what is the actual error that happens. Not what you posted, but what led you to finding that, if know what I mean.

Offline ♦ Ninja ZX-10RR ♦

  • Spammer Hammer
  • Support
  • *
  • Posts: 1193
  • Gender: Male
  • Sniper Legends
    • Virtual Interactive Games Entertainment™
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
  • Elkarte Version: 1.0.6
Thanks for the reply matey :)
Just inspecting the shoutbox itself my browser showed me that error with a red cross (which stands for a somehow critical error) and yeah I have set the shoutbox to auto-refresh but every 8 seconds or something so not continuously. I will tweak that accordingly to the traffic.
I don't have more details than those, it's just that...
Have you tried SimplePortal Documentation before asking? ;)
F.A.Q.  English Support  |  Blocks Support
Fancy Feature idea ?!  |  Blocks Requests
Themes & Graphics

? My job! ?No PMs for support unless it's a paid request. Thank you! :)#OpIsis

Offline [SiNaN]

  • Mr. SimplePortal
  • Developer
  • *
  • Posts: 6782
  • SMF Version: 2.0.15
  • SP Version: 2.3.7
I'll have to debug this myself to find out what might be going wrong. Any chance you can provide me with temporary access to your portal, shoutbox? You can send the information to me via pm.
And slowly, you come to realize... It's all as it should be...

Offline ♦ Ninja ZX-10RR ♦

  • Spammer Hammer
  • Support
  • *
  • Posts: 1193
  • Gender: Male
  • Sniper Legends
    • Virtual Interactive Games Entertainment™
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
  • Elkarte Version: 1.0.6
As it was conflicting with that other mod I tried to uninstall it and it went away... But the shoutbox doesn't work properly, it doesn't update unless the page is being manually refreshed and I can't understand why since I uninstalled all new mods with the slightest trace of a javascript file... The main problem now became that one >_< plus, the shoutbox sound is not working anymore too, I have no idea wtf happened to my shoutbox :/ I might try to reinstall the whole SimplePortal I am truly lost.
If you need access well my test account is semi-public, delete these after you read so I don't even need to bother you via pm ;) username: *** pw: *** http://vige.altervista.org/forum/index.php?action=forum (since the shoutbox is being displayed only on the board index)
« Last Edit: December 03, 2014, 02:52:53 PM by [SiNaN] »
Have you tried SimplePortal Documentation before asking? ;)
F.A.Q.  English Support  |  Blocks Support
Fancy Feature idea ?!  |  Blocks Requests
Themes & Graphics

? My job! ?No PMs for support unless it's a paid request. Thank you! :)#OpIsis

Offline [SiNaN]

  • Mr. SimplePortal
  • Developer
  • *
  • Posts: 6782
  • SMF Version: 2.0.15
  • SP Version: 2.3.7
I don't see any shoutboxes using the test account you provided. Can you please make sure that I can see it?
And slowly, you come to realize... It's all as it should be...

Offline ♦ Ninja ZX-10RR ♦

  • Spammer Hammer
  • Support
  • *
  • Posts: 1193
  • Gender: Male
  • Sniper Legends
    • Virtual Interactive Games Entertainment™
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
  • Elkarte Version: 1.0.6
Re: Shoutbox update error
« Reply #7 on: December 07, 2014, 09:44:45 AM »
Done, sorry, I had removed it coz I re-installed the Portal but at no avail. It's now available again :)
Have you tried SimplePortal Documentation before asking? ;)
F.A.Q.  English Support  |  Blocks Support
Fancy Feature idea ?!  |  Blocks Requests
Themes & Graphics

? My job! ?No PMs for support unless it's a paid request. Thank you! :)#OpIsis

Offline [SiNaN]

  • Mr. SimplePortal
  • Developer
  • *
  • Posts: 6782
  • SMF Version: 2.0.15
  • SP Version: 2.3.7
Re: Shoutbox update error
« Reply #8 on: December 07, 2014, 09:46:55 AM »
I still can't see it. It seems to me that the portal is on maintenance mode. If it is, can you make sure that I can see the portal even when it's on maintenance mode?
And slowly, you come to realize... It's all as it should be...

Offline ♦ Ninja ZX-10RR ♦

  • Spammer Hammer
  • Support
  • *
  • Posts: 1193
  • Gender: Male
  • Sniper Legends
    • Virtual Interactive Games Entertainment™
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
  • Elkarte Version: 1.0.6
Re: Shoutbox update error
« Reply #9 on: December 07, 2014, 09:50:36 AM »
Forgot it toggle it back, sorry. Try again #_# I posted also a shout in which I say that the shoutbox was meant to show up in the Foruml view only but instead when I tried to save the settings it was switching back automatically to "Portal" O.o I just used the "Everywhere" thing and it worked, despite it's not what I wanted... I just want to let you see that though.
Plus, just granted you full admin permissions with SimplePortal so that you can see its settings.
Have you tried SimplePortal Documentation before asking? ;)
F.A.Q.  English Support  |  Blocks Support
Fancy Feature idea ?!  |  Blocks Requests
Themes & Graphics

? My job! ?No PMs for support unless it's a paid request. Thank you! :)#OpIsis

Offline [SiNaN]

  • Mr. SimplePortal
  • Developer
  • *
  • Posts: 6782
  • SMF Version: 2.0.15
  • SP Version: 2.3.7
Re: Shoutbox update error
« Reply #10 on: December 07, 2014, 10:05:29 AM »
There shouldn't be any problems setting the display options, but that's another case.

The problem with the shoutbox is caused by a coding mistake. View the source for the following page:

vige.altervista.org/forum/index.php?action=portal;sa=shoutbox;shoutbox_id=3;xml

You'll notice that there is a single blank space at the beginning, right before the <?xml tag. There shouldn't be. Check the one on our site:

simpleportal.net/index.php?action=portal;sa=shoutbox;shoutbox_id=1;xml

It's either a mod that adds that extraneous space erroneously or you made a mistake while you were editing the files manually. There is no way for me guess where that space might be coming from. You have to go over all the changes you have made to find out what's causing it.

I should also note that this evil extra space not only affects SimplePortal shoutbox but all other SMF functions that use AJAX like the detailed stats for each month on more stats page or quick modify posts. It may not affect some other custom mods that use AJAX because not every mod is coded in a way that makes it a real part of SMF.
And slowly, you come to realize... It's all as it should be...

Offline ♦ Ninja ZX-10RR ♦

  • Spammer Hammer
  • Support
  • *
  • Posts: 1193
  • Gender: Male
  • Sniper Legends
    • Virtual Interactive Games Entertainment™
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
  • Elkarte Version: 1.0.6
Re: Shoutbox update error
« Reply #11 on: December 07, 2014, 10:30:58 AM »
It might be an update... I had a problem a while ago with the quick reply... Also there there was my previous mods list and it comes in a handy because there was also SimplePortal from the first time I installed it (and it was working). http://www.italiansmf.net/forum/index.php?topic=1196.msg7033#msg7033 I was suggested to remove a single line in a query that was bugged by the anti-spam links and everything went back to normal.
Anyway I guess that any mod I installed after the 22th of november could be the issue, right? I will try and report you back so I'll also tell the mod author to fix it and warn people about it.
Thanks for everything, if you have any other ideas or anything just tell me and I will be replying asap since I have notifications enabled for this one :)
« Last Edit: December 07, 2014, 10:55:52 AM by ♦ Ninja ZX-10RR ♦ »
Have you tried SimplePortal Documentation before asking? ;)
F.A.Q.  English Support  |  Blocks Support
Fancy Feature idea ?!  |  Blocks Requests
Themes & Graphics

? My job! ?No PMs for support unless it's a paid request. Thank you! :)#OpIsis

Offline [SiNaN]

  • Mr. SimplePortal
  • Developer
  • *
  • Posts: 6782
  • SMF Version: 2.0.15
  • SP Version: 2.3.7
Re: Shoutbox update error
« Reply #12 on: December 07, 2014, 10:49:23 AM »
It's not something I can make guesses about by looking at a list - it can be any mod, really! You just have to uninstall them one by one and check.
And slowly, you come to realize... It's all as it should be...

Offline ♦ Ninja ZX-10RR ♦

  • Spammer Hammer
  • Support
  • *
  • Posts: 1193
  • Gender: Male
  • Sniper Legends
    • Virtual Interactive Games Entertainment™
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
  • Elkarte Version: 1.0.6
Re: Shoutbox update error
« Reply #13 on: December 07, 2014, 11:11:52 AM »
I found it dude! You have been really vital for this. It was the number 147 "Guest registration notification", due to what you said I am filing a security report about it because it breaks AJAX functionalities (so it does really destroy something). Thanks for all the help you have been extremely vital! I'm forwarding these informations to the mod author and the sm.org customization team.
Thanks again, marking as solved.
Have you tried SimplePortal Documentation before asking? ;)
F.A.Q.  English Support  |  Blocks Support
Fancy Feature idea ?!  |  Blocks Requests
Themes & Graphics

? My job! ?No PMs for support unless it's a paid request. Thank you! :)#OpIsis

Offline [SiNaN]

  • Mr. SimplePortal
  • Developer
  • *
  • Posts: 6782
  • SMF Version: 2.0.15
  • SP Version: 2.3.7
Re: Shoutbox update error
« Reply #14 on: December 07, 2014, 11:16:26 AM »
Yeah, that seems to be the one. See the file Sources/GuestRegistrationNotification.php. At the beginning, there is an extra space right before the <?php tag.

You're welcome. Glad that you could solve it!
And slowly, you come to realize... It's all as it should be...