collapse collapse

* User Info

 
 
Welcome, Guest. Please login or register.
Did you miss your activation email?

* Who's Online

  • Dot Guests: 171
  • Dot Hidden: 0
  • Dot Users: 0

There aren't any users online.

* Shoutbox

Refresh History
  • Shoutbox is not for support!
  • {OCS}MasterSeal: STILL love SP :)
    November 24, 2018, 05:05:50 AM
  • ♦ Ninja ZX-10RR ♦: <3 aegersz
    September 13, 2018, 03:36:09 PM
  • aegersz: I STILL <3 LOVE SimplePortal
    September 13, 2018, 07:11:39 AM
  • aegersz: o LOVE you guys - Simple Portal rocks !
    May 09, 2018, 05:18:59 AM
  • Chen Zhen: our apologies for the site being down.. please read server issues topic
    March 22, 2018, 05:32:38 AM
  • {OCS}MasterSeal: LOL PLEASE forget I just posted that. I found the answer in my own dang post back in 2015. lol sorry!
    July 04, 2017, 10:47:55 PM
  • {OCS}MasterSeal: I know this SB isnt' for support, but I just have a general question. Who would I contact to find out where SP stores its block info? Is it DB driven or files? I searched the site but came up with nothing. probably my fault any insight is appreciated.
    July 04, 2017, 10:43:36 PM
  • ♦ Ninja ZX-10RR ♦: Excuse me but what does Simpleportal have to deal with that?
    February 05, 2017, 08:21:14 PM
  • WhiteEagle: of course IMHO that site appears to be dead :(
    February 04, 2017, 01:08:05 PM
  • WhiteEagle: If I can get that, then I'll use it for that site...
    February 04, 2017, 01:07:35 PM
  • WhiteEagle: decided to not use SMF for any projects, unless I can get a copy of the premium version of the fanfiction archive plugin
    February 04, 2017, 01:06:54 PM
  • expertdecisions: cloudflare
    January 28, 2017, 08:01:47 AM
  • aegersz: SM release 2.0.13 !
    January 12, 2017, 06:00:13 AM
  • raffo: Tks Emanuele, even if I didn't understand the fix :D
    November 07, 2016, 02:01:20 AM
  • emanuele: [link]
    November 01, 2016, 12:43:50 PM
  • emanuele: raffo: the English support board is a good place. ;)
    November 01, 2016, 12:43:38 PM
  • raffo: Where can I find the fix for the shoutbox?
    November 01, 2016, 05:06:09 AM
  • {OCS}MasterSeal: To the SP team, I make a point to come here and thank you as much as possible for your work.  so again, THANK YOU!
    October 28, 2016, 10:38:05 AM
  • emanuele: That's indeed funny, the limit is present only in the patch and not the full install.
    October 22, 2016, 06:14:58 PM
  • phantomm: and from what I see only patch is broken, full install package is fine
    October 21, 2016, 03:44:44 PM

* Recent Posts

Welcome to SimplePortal.net! You can download SimplePortal from the Downloads Area!

Author Topic: ?action=forum and persistent login not working  (Read 3305 times)

0 Members and 1 Guest are viewing this topic.

Offline johan7804

  • Just Registered
  • Posts: 1
  • SMF Version: 2.0.9
  • SP Version: 2.3.6
?action=forum and persistent login not working
« on: December 05, 2014, 03:26:46 AM »
Hi!

We have a community set up with SMF 2.0.9 and SimplePortal 2.3.6.

SimplePortal is great! It gives just the right layout and functionality to our community site! There are two problems though...

First the persistent login function does not work. Does not matter if you you choose to be kept logged  in for X minutes or forever, you get logged out after say 45-60 minutes. Hard to say without further testing. Nevertheless, the function does not work.

Second, after you get logged out and get back to the login page and log in, the path is show as hxxp://www.example.com/?action=forum. There is a index.php missing in there... I threw up a thread on the SMF forums since I thought the problems was there, and someone told me it should read hxxp://www.example.com/index.php?action=forum. Well, indeed it should :)

I have performed a fresh test installation on a different domain and started out with a clean SMF 2.0.9 installation. No problems at all. The exact same problem appear right after SimplePortal is installed... :( So I gather the login and redirect issue is with SimplePortal :(

I love SimplePortal, it's great, it's just what we want and need, so how do I make it work? :D

\\Edit -> Live links for new members is disallowed
« Last Edit: February 05, 2015, 10:22:09 PM by Chen Zhen »

Offline ccbtimewiz

  • Hero Member
  • *****
  • Posts: 2181
  • Gender: Male
  • $("div.content:dd").hide();
  • SMF Version: None
  • SP Version: None
  • Elkarte Version: None
  • EhPortal Version: None
Re: ?action=forum and persistent login not working
« Reply #1 on: February 05, 2015, 07:45:12 PM »
For the login function, I believe SP just borrows SMF's login, meaning it is not a problem with SP.

Considering your second issue, I would believe something is wrong with your paths. That could very well also be the source of the problem for your persistent login. Perhaps try running repair_settings.php from SMF and see if it can fix any broken paths.

Offline [SiNaN]

  • Mr. SimplePortal
  • Developer
  • *
  • Posts: 6782
  • SMF Version: 2.0.15
  • SP Version: 2.3.7
Re: ?action=forum and persistent login not working
« Reply #2 on: August 01, 2015, 07:30:02 AM »
johan7804, in case you were using the standalone mode, some settings may need to be set to certain values for sessions to work properly. If you need require further assistance, please let us know.
And slowly, you come to realize... It's all as it should be...