collapse collapse

* User Info

 
 
Welcome, Guest. Please login or register.
Did you miss your activation email?

* Who's Online

  • Dot Guests: 82
  • Dot Hidden: 0
  • Dot Users: 2
  • Dot Users Online:

* Shoutbox

Refresh History
  • Shoutbox is not for support!
  • {OCS}MasterSeal: Yup, Still adore SP
    April 21, 2019, 07:08:06 PM
  • {OCS}MasterSeal: STILL love SP :)
    November 24, 2018, 05:05:50 AM
  • ♦ Ninja ZX-10RR ♦: <3 aegersz
    September 13, 2018, 03:36:09 PM
  • aegersz: I STILL <3 LOVE SimplePortal
    September 13, 2018, 07:11:39 AM
  • aegersz: o LOVE you guys - Simple Portal rocks !
    May 09, 2018, 05:18:59 AM
  • Chen Zhen: our apologies for the site being down.. please read server issues topic
    March 22, 2018, 05:32:38 AM
  • {OCS}MasterSeal: LOL PLEASE forget I just posted that. I found the answer in my own dang post back in 2015. lol sorry!
    July 04, 2017, 10:47:55 PM
  • {OCS}MasterSeal: I know this SB isnt' for support, but I just have a general question. Who would I contact to find out where SP stores its block info? Is it DB driven or files? I searched the site but came up with nothing. probably my fault any insight is appreciated.
    July 04, 2017, 10:43:36 PM
  • ♦ Ninja ZX-10RR ♦: Excuse me but what does Simpleportal have to deal with that?
    February 05, 2017, 08:21:14 PM
  • WhiteEagle: of course IMHO that site appears to be dead :(
    February 04, 2017, 01:08:05 PM
  • WhiteEagle: If I can get that, then I'll use it for that site...
    February 04, 2017, 01:07:35 PM
  • WhiteEagle: decided to not use SMF for any projects, unless I can get a copy of the premium version of the fanfiction archive plugin
    February 04, 2017, 01:06:54 PM
  • expertdecisions: cloudflare
    January 28, 2017, 08:01:47 AM
  • aegersz: SM release 2.0.13 !
    January 12, 2017, 06:00:13 AM
  • raffo: Tks Emanuele, even if I didn't understand the fix :D
    November 07, 2016, 02:01:20 AM
  • emanuele: [link]
    November 01, 2016, 12:43:50 PM
  • emanuele: raffo: the English support board is a good place. ;)
    November 01, 2016, 12:43:38 PM
  • raffo: Where can I find the fix for the shoutbox?
    November 01, 2016, 05:06:09 AM
  • {OCS}MasterSeal: To the SP team, I make a point to come here and thank you as much as possible for your work.  so again, THANK YOU!
    October 28, 2016, 10:38:05 AM
  • emanuele: That's indeed funny, the limit is present only in the patch and not the full install.
    October 22, 2016, 06:14:58 PM

* Recent Posts

Re: How to Add signature in Simple Portal? by elissaamsmart
[May 14, 2019, 07:19:57 AM]


Re: Broke my forum upgrading by russguaj
[May 03, 2019, 08:15:45 AM]


Re: How to display more post on Simple Portal by ♦ Ninja ZX-10RR ♦
[May 01, 2019, 07:48:06 AM]


How to display more post on Simple Portal by hipp0
[May 01, 2019, 05:43:25 AM]


Re: Broke my forum upgrading by Chen Zhen
[April 25, 2019, 10:32:44 PM]

NEED HELP? If you're looking for support with Simple Portal, look no further than the Support Board!

Author Topic: install xml parse error  (Read 15663 times)

0 Members and 1 Guest are viewing this topic.

Offline korelabs

  • Semi Newbie
  • *
  • Posts: 14
  • Gender: Male
  • 'Lo thar.
    • Kore Gaming, no... not that one, the real one.
  • SMF Version: 2.0.9
  • SP Version: 2.3.6
install xml parse error
« on: December 16, 2014, 04:37:11 PM »
(edited to add permissions info)

1.   Execute Modification   smf2/install.xml   Modification parse error
2.   Execute Modification   smf2/install.xml   Modification parse error

This is what I'm getting when installing SP 2.3.6 on SMF 2.0.9

I have tried all I can think of.
chowned files to root:root
chowned files to the owner of /var/www
chmodded everything applicable to 755 and/or 777
uploaded the zip from 4 systems.
installed the zip direct from http from SP site.
created the temp folder, and chmod/chowned it as everything else.
cleared the contents of temp between install attempts, and during.

No matter what I do, it gives the same error *every* time.

Permissions seem in order.
 /var/www/main   Writable  (chmod: 0777)               
      agreement.txt   Writable  (chmod: 0777)               
      Settings.php   Writable  (chmod: 0777)               
      Settings_bak.php   Writable  (chmod: 0777)               
       * attachments   Writable  (chmod: 0777)               
       * avatars   Writable  (chmod: 0777)               
       * cache   Writable  (chmod: 0777)               
       * Smileys   Writable  (chmod: 0777)               
       * Sources   Writable  (chmod: 0777)               
       * Themes   Writable  (chmod: 0777)               
       * Packages   Writable  (chmod: 0777)

hardware: (not sure if it matters though.)
xeon E3-1246
32GB ECC

software: (probably a little more important.)
debian 7.7 64 (with multilib)
Apache 2.2.22
PHP  5.4.35-0+deb7u2
Registered PHP Streams   https, ftps, compress.zlib, compress.bzip2, php, file, glob, data, http, ftp, phar, zip
Registered Stream Socket Transports   tcp, udp, unix, udg, ssl, sslv3, tls
Registered Stream Filters   zlib.*, bzip2.*, convert.iconv.*, string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, dechunk

« Last Edit: December 16, 2014, 04:40:51 PM by korelabs »
There are two major products of Berkeley, CA -- LSD and UNIX. We don't believe this to be strictly by coincidence.

Online ♦ Ninja ZX-10RR ♦

  • Spammer Hammer
  • Support
  • *
  • Posts: 1184
  • Gender: Male
  • Sniper Legends
    • Virtual Interactive Games Entertainment™
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
  • Elkarte Version: 1.0.6
Re: install xml parse error
« Reply #1 on: December 16, 2014, 04:56:26 PM »
Welcome :)

A question that might sound stupid but in fact it isn't... Are you trying to install SP 2.3.6 over a previous installation? For example updating 2.3.5 without uninstalling?
I ask because it's not how it works, you should uninstall 2.3.5 and then install 2.3.6, you won't lose your data if you don't choose the "Delete the additional data" checkbox while uninstalling it.

After telling me the above... Try to unzip the package, rename "install.xml" to "Install.xml" (do note the uppercase), re-zip it, re-upload it and retry. This is due to the fact that some weird things can happen in some OS at a times... It happened to me as well before, with another mod.
The things you have done might sound useful but not all of them... In fact having 777 as chmod might cause more troubles than benefits. I'd ask you to bring it back to 775 at maximum.

By the way congrats for providing a boatload of informations, that's uncommon and much appreciated :)
« Last Edit: December 16, 2014, 05:00:57 PM by ♦ Ninja ZX-10RR ♦ »
Have you tried SimplePortal Documentation before asking? ;)
F.A.Q.  English Support  |  Blocks Support
Fancy Feature idea ?!  |  Blocks Requests
Themes & Graphics

▼ My job! ▼

No PMs for support unless it's a paid request. Thank you! :)
#OpIsis

Offline korelabs

  • Semi Newbie
  • *
  • Posts: 14
  • Gender: Male
  • 'Lo thar.
    • Kore Gaming, no... not that one, the real one.
  • SMF Version: 2.0.9
  • SP Version: 2.3.6
Re: install xml parse error
« Reply #2 on: December 16, 2014, 05:08:37 PM »
I apologize for missing that detail, this is a 100% clean install, and I have full root access to the server (of which I also forgot to mention)

Will try the suggestions and report back asap.
There are two major products of Berkeley, CA -- LSD and UNIX. We don't believe this to be strictly by coincidence.

Offline Burke Knight

  • Sr. Member
  • ****
  • Posts: 394
  • Gender: Male
  • I tell it how I see it. Don't like it? Hit Alt+F4
    • BurkeKnight Enterprises
  • SMF Version: None
  • SP Version: None
  • Elkarte Version: None
Re: install xml parse error
« Reply #3 on: December 16, 2014, 05:14:14 PM »
Hmmm... Where did you download SP from, SMF site or here?
If the SMF site, try downloading from here and trying that copy.
Just in case something corrupted the copy you had gotten.

Offline korelabs

  • Semi Newbie
  • *
  • Posts: 14
  • Gender: Male
  • 'Lo thar.
    • Kore Gaming, no... not that one, the real one.
  • SMF Version: 2.0.9
  • SP Version: 2.3.6
Re: install xml parse error
« Reply #4 on: December 16, 2014, 05:20:17 PM »
@ burkeknight, I got it from here.

@ ninja, same thing, I also took the caution of clearing the old cached copies off of the server-side directories, and making 110% sure it uploaded fresh and clean with the edits, it's showing the error as install.xml in SMF's package manager, but it shows quite clearly Install.xml when browsing the zip server side in */Packages/filename.zip, would appear there may be an auto renaming schema in place once things hit the installation script external of the zip file.
There are two major products of Berkeley, CA -- LSD and UNIX. We don't believe this to be strictly by coincidence.

Offline Burke Knight

  • Sr. Member
  • ****
  • Posts: 394
  • Gender: Male
  • I tell it how I see it. Don't like it? Hit Alt+F4
    • BurkeKnight Enterprises
  • SMF Version: None
  • SP Version: None
  • Elkarte Version: None
Re: install xml parse error
« Reply #5 on: December 16, 2014, 05:25:25 PM »
Have you tried to just upload the SP package to the Packages folder via FTP, then go and try to install from the list in package manager?

Offline korelabs

  • Semi Newbie
  • *
  • Posts: 14
  • Gender: Male
  • 'Lo thar.
    • Kore Gaming, no... not that one, the real one.
  • SMF Version: 2.0.9
  • SP Version: 2.3.6
Re: install xml parse error
« Reply #6 on: December 16, 2014, 05:32:59 PM »
Oddly enough, I just tried dreamportal as well, and i get the exact same issue...
There are two major products of Berkeley, CA -- LSD and UNIX. We don't believe this to be strictly by coincidence.

Offline Burke Knight

  • Sr. Member
  • ****
  • Posts: 394
  • Gender: Male
  • I tell it how I see it. Don't like it? Hit Alt+F4
    • BurkeKnight Enterprises
  • SMF Version: None
  • SP Version: None
  • Elkarte Version: None
Re: install xml parse error
« Reply #7 on: December 16, 2014, 05:35:16 PM »
Then it would appear that there is a server issue that needs to be looked at.

Offline korelabs

  • Semi Newbie
  • *
  • Posts: 14
  • Gender: Male
  • 'Lo thar.
    • Kore Gaming, no... not that one, the real one.
  • SMF Version: 2.0.9
  • SP Version: 2.3.6
Re: install xml parse error
« Reply #8 on: December 16, 2014, 05:39:42 PM »
Yeah, I'm thinking so as well.

Off to chase squirrels around /var for a while!

I'll report back anyway, because I see a few posts on this where users just up and claim fixed, then vanish into the ether with NO information at all... If i find it, i'll post it.
There are two major products of Berkeley, CA -- LSD and UNIX. We don't believe this to be strictly by coincidence.

Online ♦ Ninja ZX-10RR ♦

  • Spammer Hammer
  • Support
  • *
  • Posts: 1184
  • Gender: Male
  • Sniper Legends
    • Virtual Interactive Games Entertainment™
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
  • Elkarte Version: 1.0.6
Re: install xml parse error
« Reply #9 on: December 16, 2014, 05:40:17 PM »
it's showing the error as install.xml in SMF's package manager, but it shows quite clearly Install.xml when browsing the zip server side in */Packages/filename.zip, would appear there may be an auto renaming schema in place once things hit the installation script external of the zip file.
Rename it back AFTER you uploaded it to install.xml then (damn I hate this uppercase BS it makes me go crazy, really, see below)...

Then it would appear that there is a server issue that needs to be looked at.
Yeah... I just hope that this is actually fixable. Despite I have more than 130 mods installed I can't install ForumFirewall because it gives me the same exact error no matter what I do.
Have you tried SimplePortal Documentation before asking? ;)
F.A.Q.  English Support  |  Blocks Support
Fancy Feature idea ?!  |  Blocks Requests
Themes & Graphics

▼ My job! ▼

No PMs for support unless it's a paid request. Thank you! :)
#OpIsis

Offline korelabs

  • Semi Newbie
  • *
  • Posts: 14
  • Gender: Male
  • 'Lo thar.
    • Kore Gaming, no... not that one, the real one.
  • SMF Version: 2.0.9
  • SP Version: 2.3.6
Re: install xml parse error
« Reply #10 on: December 16, 2014, 06:00:23 PM »
Just installed libxml++ on a whim, and it also installed nearly 600 other packages, rebooting the server for good measure, hopefully something in that heap fixes it.

[edit] Nope, this is getting terribly irritating.

Any suggestions as to packages I may be missing that would cause this?
There are two major products of Berkeley, CA -- LSD and UNIX. We don't believe this to be strictly by coincidence.

Online ♦ Ninja ZX-10RR ♦

  • Spammer Hammer
  • Support
  • *
  • Posts: 1184
  • Gender: Male
  • Sniper Legends
    • Virtual Interactive Games Entertainment™
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
  • Elkarte Version: 1.0.6
Re: install xml parse error
« Reply #11 on: December 16, 2014, 06:01:36 PM »
Hell you did quite a lot of things... Let us know huh? :)
Have you tried SimplePortal Documentation before asking? ;)
F.A.Q.  English Support  |  Blocks Support
Fancy Feature idea ?!  |  Blocks Requests
Themes & Graphics

▼ My job! ▼

No PMs for support unless it's a paid request. Thank you! :)
#OpIsis

Offline Chen Zhen

  • The Underdog
  • Operations Manager
  • *
  • Posts: 1350
  • Gender: Male
  • Kinesis
    • WebDev
  • SMF Version: 2.1
  • EhPortal Version: 1.22
Re: install xml parse error
« Reply #12 on: December 16, 2014, 06:13:48 PM »
korelabs,

Imo you somehow have a misconfigured path setting within SMF itself.
To ensure all paths are correct perhaps use the repair_settings.php tool to correct them and try the installation again.
Make sure to remove the tool/file when the process is complete.

ref.
http://wiki.simplemachines.org/smf/Repair_settings.php

Regards.

Offline korelabs

  • Semi Newbie
  • *
  • Posts: 14
  • Gender: Male
  • 'Lo thar.
    • Kore Gaming, no... not that one, the real one.
  • SMF Version: 2.0.9
  • SP Version: 2.3.6
Re: install xml parse error
« Reply #13 on: December 16, 2014, 06:24:21 PM »
Ran it, hit the remove hooks, restore settings, save settings, then deleted it, same error.

[edited for missed step, corrected.]
There are two major products of Berkeley, CA -- LSD and UNIX. We don't believe this to be strictly by coincidence.

Online ♦ Ninja ZX-10RR ♦

  • Spammer Hammer
  • Support
  • *
  • Posts: 1184
  • Gender: Male
  • Sniper Legends
    • Virtual Interactive Games Entertainment™
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
  • Elkarte Version: 1.0.6
Re: install xml parse error
« Reply #14 on: December 16, 2014, 06:40:44 PM »
I would think some server stuff. Why? Because of the same problem I have with ForumFirewall mod... Looks like it doesn't work on my host. Perhaps it's the same thing here. As regards the reason... I'd love to discover it.
Have you tried SimplePortal Documentation before asking? ;)
F.A.Q.  English Support  |  Blocks Support
Fancy Feature idea ?!  |  Blocks Requests
Themes & Graphics

▼ My job! ▼

No PMs for support unless it's a paid request. Thank you! :)
#OpIsis

Offline Chen Zhen

  • The Underdog
  • Operations Manager
  • *
  • Posts: 1350
  • Gender: Male
  • Kinesis
    • WebDev
  • SMF Version: 2.1
  • EhPortal Version: 1.22
Re: install xml parse error
« Reply #15 on: December 16, 2014, 07:20:23 PM »
Ran it, hit the remove hooks, restore settings, save settings, then deleted it, same error.

[edited for missed step, corrected.]

I did not instruct you to remove any hooks. If you have existing mods installed that use them it will render some of those installed mods useless or possibly cause errors. I was suggesting that you fix the directory and path settings. The tool gives you suggested changes as links whereas most of the time you can just select all those links and then save the changed settings.

Offline Chen Zhen

  • The Underdog
  • Operations Manager
  • *
  • Posts: 1350
  • Gender: Male
  • Kinesis
    • WebDev
  • SMF Version: 2.1
  • EhPortal Version: 1.22
Re: install xml parse error
« Reply #16 on: December 16, 2014, 07:23:03 PM »
♦ Ninja ZX-10RR ♦,

  That sounds like an .htaccess issue you are experiencing, I will suggest that you post in that mods support thread if you have not already done so.

Regards.


Offline korelabs

  • Semi Newbie
  • *
  • Posts: 14
  • Gender: Male
  • 'Lo thar.
    • Kore Gaming, no... not that one, the real one.
  • SMF Version: 2.0.9
  • SP Version: 2.3.6
Re: install xml parse error
« Reply #17 on: December 16, 2014, 07:24:16 PM »
Just tried it with a clean install, database and everything, without the hooks thing, and same result.
Are there logs kept anywhere I could look at?
There are two major products of Berkeley, CA -- LSD and UNIX. We don't believe this to be strictly by coincidence.

Offline Chen Zhen

  • The Underdog
  • Operations Manager
  • *
  • Posts: 1350
  • Gender: Male
  • Kinesis
    • WebDev
  • SMF Version: 2.1
  • EhPortal Version: 1.22
Re: install xml parse error
« Reply #18 on: December 16, 2014, 07:35:35 PM »
The php error log path/location is configured within your php.ini file although it is usually viewable from your host panel (if you have one .. ie. Cpanel).

Do you have shell access? Is this CentOS, Ubuntu, etc ?
If you do have shell access, what is your actual forum path to this forum (public_html) folder?
Is this a newer OS installation?

Offline korelabs

  • Semi Newbie
  • *
  • Posts: 14
  • Gender: Male
  • 'Lo thar.
    • Kore Gaming, no... not that one, the real one.
  • SMF Version: 2.0.9
  • SP Version: 2.3.6
Re: install xml parse error
« Reply #19 on: December 16, 2014, 07:37:15 PM »
It's debian 7.7 AMD64 (with multilib).
I have 100% full access. (hosted rootserver)
Path is /var/www/main
yes, it's a fresh install of debian_minimal, I've added php, mysql, apache myself.
« Last Edit: December 16, 2014, 07:52:37 PM by korelabs »
There are two major products of Berkeley, CA -- LSD and UNIX. We don't believe this to be strictly by coincidence.