collapse collapse

* User Info

 
 
Welcome, Guest. Please login or register.
Did you miss your activation email?

* Who's Online

  • Dot Guests: 164
  • Dot Hidden: 0
  • Dot Users: 0

There aren't any users online.

* Shoutbox

Refresh History
  • Shoutbox is not for support!
  • {OCS}MasterSeal: STILL love SP :)
    November 24, 2018, 05:05:50 AM
  • ♦ Ninja ZX-10RR ♦: <3 aegersz
    September 13, 2018, 03:36:09 PM
  • aegersz: I STILL <3 LOVE SimplePortal
    September 13, 2018, 07:11:39 AM
  • aegersz: o LOVE you guys - Simple Portal rocks !
    May 09, 2018, 05:18:59 AM
  • Chen Zhen: our apologies for the site being down.. please read server issues topic
    March 22, 2018, 05:32:38 AM
  • {OCS}MasterSeal: LOL PLEASE forget I just posted that. I found the answer in my own dang post back in 2015. lol sorry!
    July 04, 2017, 10:47:55 PM
  • {OCS}MasterSeal: I know this SB isnt' for support, but I just have a general question. Who would I contact to find out where SP stores its block info? Is it DB driven or files? I searched the site but came up with nothing. probably my fault any insight is appreciated.
    July 04, 2017, 10:43:36 PM
  • ♦ Ninja ZX-10RR ♦: Excuse me but what does Simpleportal have to deal with that?
    February 05, 2017, 08:21:14 PM
  • WhiteEagle: of course IMHO that site appears to be dead :(
    February 04, 2017, 01:08:05 PM
  • WhiteEagle: If I can get that, then I'll use it for that site...
    February 04, 2017, 01:07:35 PM
  • WhiteEagle: decided to not use SMF for any projects, unless I can get a copy of the premium version of the fanfiction archive plugin
    February 04, 2017, 01:06:54 PM
  • expertdecisions: cloudflare
    January 28, 2017, 08:01:47 AM
  • aegersz: SM release 2.0.13 !
    January 12, 2017, 06:00:13 AM
  • raffo: Tks Emanuele, even if I didn't understand the fix :D
    November 07, 2016, 02:01:20 AM
  • emanuele: [link]
    November 01, 2016, 12:43:50 PM
  • emanuele: raffo: the English support board is a good place. ;)
    November 01, 2016, 12:43:38 PM
  • raffo: Where can I find the fix for the shoutbox?
    November 01, 2016, 05:06:09 AM
  • {OCS}MasterSeal: To the SP team, I make a point to come here and thank you as much as possible for your work.  so again, THANK YOU!
    October 28, 2016, 10:38:05 AM
  • emanuele: That's indeed funny, the limit is present only in the patch and not the full install.
    October 22, 2016, 06:14:58 PM
  • phantomm: and from what I see only patch is broken, full install package is fine
    October 21, 2016, 03:44:44 PM

* Recent Posts

Re: Occasional Chat/Shout box Issue by OpoWolfie
[January 06, 2019, 04:54:46 AM]


Re: Where is the code for these elements, where are they stored? by Chen Zhen
[January 04, 2019, 10:50:07 AM]


Re: Have a block only show on threads? by danmsmith018f
[January 03, 2019, 05:46:35 AM]


Re: Occasional Chat/Shout box Issue by OpoWolfie
[January 03, 2019, 05:33:09 AM]


Re: Occasional Chat/Shout box Issue by Chen Zhen
[January 03, 2019, 12:54:27 AM]

Blocks speak! Do you have an interest in getting more blocks - or even making your own? The Blocks Board is for you!

Author Topic: Need Help - Upgrading from 2.3.5 to 2.3.6  (Read 5393 times)

0 Members and 1 Guest are viewing this topic.

Offline Anastasie

  • Semi Newbie
  • *
  • Posts: 7
  • SMF Version: 2.0.10
  • SP Version: 2.3.5
Need Help - Upgrading from 2.3.5 to 2.3.6
« on: May 01, 2015, 01:13:30 PM »
Ok - so I was following the instructions to uninstall 2.3.5 prior to installing 2.3.6 on the test version of my forum.  I did see error messages before uninstalling like previous posters.

Somehow when I went to upload and install 2.3.6, I inadvertently installed it on my live forum instead of the test forum. 

Now my live forum is completely dead and I can't do anything.  I hadn't uninstalled 2.3.5 from the live forum yet since I wasn't intending to upgrade it until I verified it was working on my test forum. 

I went into mySQL database and uploaded my forum back-up and my site is still down.

I'm not sure what to do at this point to fix this.  Please help.

I can't get my test forum or live forum to load at this point.  :'(

Quote
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.
« Last Edit: May 01, 2015, 01:17:10 PM by Anastasie »

Offline ♦ Ninja ZX-10RR ♦

  • Spammer Hammer
  • Support
  • *
  • Posts: 1179
  • Gender: Male
  • Sniper Legends
    • Virtual Interactive Games Entertainment™
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
  • Elkarte Version: 1.0.6
Re: Need Help - Upgrading from 2.3.5 to 2.3.6
« Reply #1 on: May 01, 2015, 03:19:07 PM »
Now my live forum is completely dead and I can't do anything.  I hadn't uninstalled 2.3.5 from the live forum yet since I wasn't intending to upgrade it until I verified it was working on my test forum.
So you installed 2.3.6 onto 2.3.5, is it correct? Out of curiosity... How could you possibly do that? The package manager should have warned you about tons of things failing...

I went into mySQL database and uploaded my forum back-up and my site is still down.
Please distinguish between FORUM and DATABASE, they are 2 different things. The database backup is not that important, it's the forum that is damaged as of now. You need to upload the backup of the FORUM, not the database. You should find your backup in your /forum root/Packages/backups directory, upload the latest one that you have (before installing 2.3.6) and it should be back up in minutes.
Let me know what you come up with.

In the future, please be careful whether you edit your live site or test one, I use 2 different servers for that, a free host for the test site is very good since you don't pay for your tests and you can hack your files in the worst possible way, but you can always re-install the whole forum on the test site if something goes wrong.
Regards
Have you tried SimplePortal Documentation before asking? ;)
F.A.Q.  English Support  |  Blocks Support
Fancy Feature idea ?!  |  Blocks Requests
Themes & Graphics

▼ My job! ▼

No PMs for support unless it's a paid request. Thank you! :)
#OpIsis

Offline Anastasie

  • Semi Newbie
  • *
  • Posts: 7
  • SMF Version: 2.0.10
  • SP Version: 2.3.5
Re: Need Help - Upgrading from 2.3.5 to 2.3.6
« Reply #2 on: May 01, 2015, 08:08:52 PM »
I got both test and live forums restored.  When I tried to uninstall 2.3.5 from my test forum I got the following error messages so I didn't do it.  Not sure what I can do to fix this.

See attached screen captures.

I'm kind of nervous to screw this up again...
« Last Edit: May 01, 2015, 08:11:29 PM by Anastasie »

Offline ♦ Ninja ZX-10RR ♦

  • Spammer Hammer
  • Support
  • *
  • Posts: 1179
  • Gender: Male
  • Sniper Legends
    • Virtual Interactive Games Entertainment™
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
  • Elkarte Version: 1.0.6
Re: Need Help - Upgrading from 2.3.5 to 2.3.6
« Reply #3 on: May 01, 2015, 08:26:13 PM »
Attach those files and we will see what we can do ;) Good choice not to go on, too.
P.S.: your mods list would be appreciated, to have an idea of how many you got there.
Have you tried SimplePortal Documentation before asking? ;)
F.A.Q.  English Support  |  Blocks Support
Fancy Feature idea ?!  |  Blocks Requests
Themes & Graphics

▼ My job! ▼

No PMs for support unless it's a paid request. Thank you! :)
#OpIsis

Offline Anastasie

  • Semi Newbie
  • *
  • Posts: 7
  • SMF Version: 2.0.10
  • SP Version: 2.3.5
Re: Need Help - Upgrading from 2.3.5 to 2.3.6
« Reply #4 on: May 01, 2015, 10:09:33 PM »
here are the files
« Last Edit: May 01, 2015, 10:11:34 PM by Anastasie »

Offline Chen Zhen

  • The Underdog
  • Operations Manager
  • *
  • Posts: 1342
  • Gender: Male
  • Kinesis
    • WebDev
  • SMF Version: 2.1
  • EhPortal Version: 1.22
Re: Need Help - Upgrading from 2.3.5 to 2.3.6
« Reply #5 on: May 02, 2015, 12:31:53 AM »
Anastasie,

Warning!:
All mods and manual edits will be nullified and your forum will be set to its default state.
Database entries will remain unaffected with this procedure.



Imo do the following:
  • Download & use the SMF 2.0.10 Large Upgrade Package
  • Download and use the repair_settings tool to remove all hooks (bottom right link)
  • Delete the repair_settings.php file
  • Log into forum and remove/delete all old SMF update packages using package manager
  • Remove/delete Simple Portal 2.3.5 and SMF Arcade 2.5 RC1.1D
  • Install/Enable custom theme
  • Download and install Simple Portal 2.3.6
  • Download and install SMF Arcade 2.5 RC3
  • Download & install updated versions of the other 3 mods (or install your current versions - up to you!)

Instructions for SMF upgrade: http://wiki.simplemachines.org/smf/Upgrading
Instructions for repair_settings: http://wiki.simplemachines.org/smf/Repair_settings.php

When your forum is botched and you do not know what to do, use the upgrade package as instructed above.

Regards.
« Last Edit: May 02, 2015, 01:40:08 AM by Chen Zhen »

Offline ♦ Ninja ZX-10RR ♦

  • Spammer Hammer
  • Support
  • *
  • Posts: 1179
  • Gender: Male
  • Sniper Legends
    • Virtual Interactive Games Entertainment™
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
  • Elkarte Version: 1.0.6
Re: Need Help - Upgrading from 2.3.5 to 2.3.6
« Reply #6 on: May 02, 2015, 12:58:27 AM »
I wouldn't want to disagree but it's a simple edit in all tree files... The one method you provided Chen Zhen would kill all the mods and custom themes and the OP would have to start over to customize his forum, please remember it when you link such things (I know that there is the link to the upgrade page but if it was me and I saw my mods wiped after doing that procedure I'd have been very very angry, because I could have followed it step by step, without clicking on the last links).

That said, Anastasie, your SMF arcade version is being the issue because it breaks the uninstall procedure in all 3 points :| I edited the files for you, however keep in mind that the aforementioned arcade mod might give you more headaches, I'd suggest to uninstall SP, try to update that arcade mod as Chen Zhen said, and THEN update SimplePortal again and see what you come up with.

If you want to try this way (more tricky but you won't lose any customizations) I have edited all the files for you. If you choose this path you have (once again, please remember the order of these is CRUCIAL):
1) Put your forum into maintenance mode (optional but suggested).
2) Replace the files you have now with the ones I provided.
3) Uninstall 2.3.5 and IGNORE the 3 errors, they will be still there because I have already removed the code in those places, so the package manager can't find it and throws the error as before, but this time you can ignore it ;)
4) Uninstall that arcade mod
5) Update it, or try to update it
6) Install SimplePortal 2.3.6 :)
7) Let us know what you come up with ;)

EDIT: ups, had forgot the files! ;D
« Last Edit: May 02, 2015, 03:19:28 AM by ♦ Ninja ZX-10RR ♦ »
Have you tried SimplePortal Documentation before asking? ;)
F.A.Q.  English Support  |  Blocks Support
Fancy Feature idea ?!  |  Blocks Requests
Themes & Graphics

▼ My job! ▼

No PMs for support unless it's a paid request. Thank you! :)
#OpIsis

Offline Chen Zhen

  • The Underdog
  • Operations Manager
  • *
  • Posts: 1342
  • Gender: Male
  • Kinesis
    • WebDev
  • SMF Version: 2.1
  • EhPortal Version: 1.22
Re: Need Help - Upgrading from 2.3.5 to 2.3.6
« Reply #7 on: May 02, 2015, 01:36:10 AM »
♦ Ninja ZX-10RR ♦,

  For those that seem to not be PHP savvy I tend to give instruction on using the upgrade package in an attempt to have them learn a simple method of repairing their forum without outside help. I figure it will help them in the future if something similar happens for any modification or possible forum failure/crash.

  You are correct whereas I should have first stated that all mods and manual edits will be nullified and that the forum will be set to its default state except for their database being fully intact. Imo due to the details provided in this specific case it looks as though there are only 5 mods installed with no manual edits. Installing the mods as instructed (the last process) would have their forum fixed and updated.

\\ last post has been updated with a warning regarding upgrade package usage

Regards.
« Last Edit: May 02, 2015, 01:41:12 AM by Chen Zhen »

Offline ♦ Ninja ZX-10RR ♦

  • Spammer Hammer
  • Support
  • *
  • Posts: 1179
  • Gender: Male
  • Sniper Legends
    • Virtual Interactive Games Entertainment™
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
  • Elkarte Version: 1.0.6
Re: Need Help - Upgrading from 2.3.5 to 2.3.6
« Reply #8 on: May 02, 2015, 03:20:50 AM »
Thanks :) Me instead I updated the last post because erh... I had forgot to attach the files ;D *blushes*
Have you tried SimplePortal Documentation before asking? ;)
F.A.Q.  English Support  |  Blocks Support
Fancy Feature idea ?!  |  Blocks Requests
Themes & Graphics

▼ My job! ▼

No PMs for support unless it's a paid request. Thank you! :)
#OpIsis

Offline Anastasie

  • Semi Newbie
  • *
  • Posts: 7
  • SMF Version: 2.0.10
  • SP Version: 2.3.5
Re: Need Help - Upgrading from 2.3.5 to 2.3.6
« Reply #9 on: May 02, 2015, 09:24:57 AM »
Thank you both for the help - I will see if I can make it work on my testing forum.
I honestly don't know if the arcade has an upgrade - I don't think it's been updated in quite a few years.

Offline Chen Zhen

  • The Underdog
  • Operations Manager
  • *
  • Posts: 1342
  • Gender: Male
  • Kinesis
    • WebDev
  • SMF Version: 2.1
  • EhPortal Version: 1.22
Re: Need Help - Upgrading from 2.3.5 to 2.3.6
« Reply #10 on: May 02, 2015, 12:05:12 PM »
Anastasie,

The link that I left in the last post is an updated version although you can still use that older version if you wish.
ref. http://web-develop.ca/index.php?action=downloads;sa=downfile&id=5

Regards.