collapse collapse

* User Info

 
 
Welcome, Guest. Please login or register.
Did you miss your activation email?

* Who's Online

  • Dot Guests: 197
  • Dot Hidden: 0
  • Dot Users: 0

There aren't any users online.

* Shoutbox

Refresh History
  • Shoutbox is not for support!
  • {OCS}MasterSeal: Yup, Still adore SP
    April 21, 2019, 07:08:06 PM
  • {OCS}MasterSeal: STILL love SP :)
    November 24, 2018, 05:05:50 AM
  • ♦ Ninja ZX-10RR ♦: <3 aegersz
    September 13, 2018, 03:36:09 PM
  • aegersz: I STILL <3 LOVE SimplePortal
    September 13, 2018, 07:11:39 AM
  • aegersz: o LOVE you guys - Simple Portal rocks !
    May 09, 2018, 05:18:59 AM
  • Chen Zhen: our apologies for the site being down.. please read server issues topic
    March 22, 2018, 05:32:38 AM
  • {OCS}MasterSeal: LOL PLEASE forget I just posted that. I found the answer in my own dang post back in 2015. lol sorry!
    July 04, 2017, 10:47:55 PM
  • {OCS}MasterSeal: I know this SB isnt' for support, but I just have a general question. Who would I contact to find out where SP stores its block info? Is it DB driven or files? I searched the site but came up with nothing. probably my fault any insight is appreciated.
    July 04, 2017, 10:43:36 PM
  • ♦ Ninja ZX-10RR ♦: Excuse me but what does Simpleportal have to deal with that?
    February 05, 2017, 08:21:14 PM
  • WhiteEagle: of course IMHO that site appears to be dead :(
    February 04, 2017, 01:08:05 PM
  • WhiteEagle: If I can get that, then I'll use it for that site...
    February 04, 2017, 01:07:35 PM
  • WhiteEagle: decided to not use SMF for any projects, unless I can get a copy of the premium version of the fanfiction archive plugin
    February 04, 2017, 01:06:54 PM
  • expertdecisions: cloudflare
    January 28, 2017, 08:01:47 AM
  • aegersz: SM release 2.0.13 !
    January 12, 2017, 06:00:13 AM
  • raffo: Tks Emanuele, even if I didn't understand the fix :D
    November 07, 2016, 02:01:20 AM
  • emanuele: [link]
    November 01, 2016, 12:43:50 PM
  • emanuele: raffo: the English support board is a good place. ;)
    November 01, 2016, 12:43:38 PM
  • raffo: Where can I find the fix for the shoutbox?
    November 01, 2016, 05:06:09 AM
  • {OCS}MasterSeal: To the SP team, I make a point to come here and thank you as much as possible for your work.  so again, THANK YOU!
    October 28, 2016, 10:38:05 AM
  • emanuele: That's indeed funny, the limit is present only in the patch and not the full install.
    October 22, 2016, 06:14:58 PM

* Recent Posts

Re: How to Add signature in Simple Portal? by tocnaza
[July 06, 2019, 12:04:00 PM]


Re: Yeni Sürüm Çıkacak mı? by mkuru
[July 01, 2019, 03:05:44 AM]


Re: Yeni Sürüm Çıkacak mı? by akorkut
[June 28, 2019, 05:38:26 AM]


Re: Yeni Sürüm Çıkacak mı? by mkuru
[June 26, 2019, 12:09:02 PM]


Yeni Sürüm Çıkacak mı? by akorkut
[June 25, 2019, 04:53:54 AM]

If you're interested in helping other members with support requests, consider joining the Community Support Helpers group.

Author Topic: Getting an error. Upgraded SMF, not SP.. Admin won't work 100%  (Read 4756 times)

0 Members and 1 Guest are viewing this topic.

Offline OFRD_GRL

  • Semi Newbie
  • *
  • Posts: 5
  • SMF Version: 2.0.10
I am getting the following error when trying to access many areas of the Admin in my SMF forum.
Fatal error: Call to undefined function sp_languageselect() in /home1/ofrdgrl/public_html/forum/Sources/ManageServer.php on line 1827

I just upgraded SMF from 2.0.4 to 2.0.10. I was pointed in the direction of SP possibly being the root cause. Can you help?
I cannot see any of my features or packages to see what version of SP I have installed (or to try and remove packages etc either).

Any help is much appreciated!

Offline Chen Zhen

  • The Underdog
  • Operations Manager
  • *
  • Posts: 1350
  • Gender: Male
  • Kinesis
    • WebDev
  • SMF Version: 2.1
  • EhPortal Version: 1.22
Re: Getting an error. Upgraded SMF, not SP.. Admin won't work 100%
« Reply #1 on: May 02, 2015, 12:54:11 AM »
OFRD_GRL,

  I see by your SMF post that you applied the upgrade package and had some issues.
When you apply the upgrade package you need to use FTP to overwrite all the relevant existing like files.
I will give you some instruction similar to what I just posted for someone else.

  • Download & use the SMF 2.0.10 Large Upgrade Package
  • Download and use the repair_settings tool to remove all hooks (bottom right link)
  • Delete the repair_settings.php file
  • Log into forum and remove/delete all old SMF update packages using package manager
  • Remove/delete older version of Simple Portal
  • Install/Enable custom theme
  • Download and install Simple Portal 2.3.6
  • Download & install updated versions of all other mods (or install your current versions - up to you!)

Instructions for SMF upgrade: http://wiki.simplemachines.org/smf/Upgrading
Instructions for repair_settings: http://wiki.simplemachines.org/smf/Repair_settings.php

Regards.

Offline OFRD_GRL

  • Semi Newbie
  • *
  • Posts: 5
  • SMF Version: 2.0.10
Re: Getting an error. Upgraded SMF, not SP.. Admin won't work 100%
« Reply #2 on: May 02, 2015, 01:00:21 AM »
Thanks!! I am at teh repair tool currently and have a quick question.
SSI Username (optional)
SSI Password (optional)
(For 2.0 and above)

How do I find out the info to input here since my version is 2.0.10?

Offline ♦ Ninja ZX-10RR ♦

  • Spammer Hammer
  • Support
  • *
  • Posts: 1188
  • Gender: Male
  • Sniper Legends
    • Virtual Interactive Games Entertainment™
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
  • Elkarte Version: 1.0.6
Re: Getting an error. Upgraded SMF, not SP.. Admin won't work 100%
« Reply #3 on: May 02, 2015, 01:02:43 AM »
Hi! SimplePortal nor SMF have nothing to deal with those fields (server-side-related), those are usually non-necessary (they have "optional" text below them) fields. Try to see if it works without them, because it should :)
Have you tried SimplePortal Documentation before asking? ;)
F.A.Q.  English Support  |  Blocks Support
Fancy Feature idea ?!  |  Blocks Requests
Themes & Graphics

▼ My job! ▼

No PMs for support unless it's a paid request. Thank you! :)
#OpIsis

Offline OFRD_GRL

  • Semi Newbie
  • *
  • Posts: 5
  • SMF Version: 2.0.10
Re: Getting an error. Upgraded SMF, not SP.. Admin won't work 100%
« Reply #4 on: May 02, 2015, 01:05:35 AM »
Hi! SimplePortal nor SMF have nothing to deal with those fields (server-side-related), those are usually non-necessary (they have "optional" text below them) fields. Try to see if it works without them, because it should :)

Not sure how I would go about this :-) I am somewhat tech savvy but definitely not a genius :-)

Offline Chen Zhen

  • The Underdog
  • Operations Manager
  • *
  • Posts: 1350
  • Gender: Male
  • Kinesis
    • WebDev
  • SMF Version: 2.1
  • EhPortal Version: 1.22
Re: Getting an error. Upgraded SMF, not SP.. Admin won't work 100%
« Reply #5 on: May 02, 2015, 01:10:25 AM »
OFRD_GRL,


  You can leave those blank. My instruction was more aimed at the link to the bottom right on the repair_settings tool that says remove all hooks. However it would be a good idea to double check all forum and theme links while you have the tool in operation.  There is a link under each path/directory setting to auto-set those entries if necessary. Just remember to click on SAVE when you have completed the adjustments.

Regards.

Offline OFRD_GRL

  • Semi Newbie
  • *
  • Posts: 5
  • SMF Version: 2.0.10
Re: Getting an error. Upgraded SMF, not SP.. Admin won't work 100%
« Reply #6 on: May 02, 2015, 01:14:23 AM »
OFRD_GRL,


  You can leave those blank. My instruction was more aimed at the link to the bottom right on the repair_settings tool that says remove all hooks. However it would be a good idea to double check all forum and theme links while you have the tool in operation.  There is a link under each path/directory setting to auto-set those entries if necessary. Just remember to click on SAVE when you have completed the adjustments.

Regards.

It did have some of the directories incorrect! :-)

Offline OFRD_GRL

  • Semi Newbie
  • *
  • Posts: 5
  • SMF Version: 2.0.10
Re: Getting an error. Upgraded SMF, not SP.. Admin won't work 100%
« Reply #7 on: May 02, 2015, 01:16:34 AM »
SO EXCITING!!! Your instructions were spot on. I truly appreciate it :-)

Now to start installing mods again :-) I decided to uninstall & delete what I had installed and start from scratch with those. Might find newer versions or better tools.