collapse collapse

* User Info

 
 
Welcome, Guest. Please login or register.
Did you miss your activation email?

* Who's Online

  • Dot Guests: 191
  • Dot Hidden: 0
  • Dot Users: 0

There aren't any users online.

* Shoutbox

Refresh History
  • Shoutbox is not for support!
  • {OCS}MasterSeal: Yup, Still adore SP
    April 21, 2019, 07:08:06 PM
  • {OCS}MasterSeal: STILL love SP :)
    November 24, 2018, 05:05:50 AM
  • ♦ Ninja ZX-10RR ♦: <3 aegersz
    September 13, 2018, 03:36:09 PM
  • aegersz: I STILL <3 LOVE SimplePortal
    September 13, 2018, 07:11:39 AM
  • aegersz: o LOVE you guys - Simple Portal rocks !
    May 09, 2018, 05:18:59 AM
  • Chen Zhen: our apologies for the site being down.. please read server issues topic
    March 22, 2018, 05:32:38 AM
  • {OCS}MasterSeal: LOL PLEASE forget I just posted that. I found the answer in my own dang post back in 2015. lol sorry!
    July 04, 2017, 10:47:55 PM
  • {OCS}MasterSeal: I know this SB isnt' for support, but I just have a general question. Who would I contact to find out where SP stores its block info? Is it DB driven or files? I searched the site but came up with nothing. probably my fault any insight is appreciated.
    July 04, 2017, 10:43:36 PM
  • ♦ Ninja ZX-10RR ♦: Excuse me but what does Simpleportal have to deal with that?
    February 05, 2017, 08:21:14 PM
  • WhiteEagle: of course IMHO that site appears to be dead :(
    February 04, 2017, 01:08:05 PM
  • WhiteEagle: If I can get that, then I'll use it for that site...
    February 04, 2017, 01:07:35 PM
  • WhiteEagle: decided to not use SMF for any projects, unless I can get a copy of the premium version of the fanfiction archive plugin
    February 04, 2017, 01:06:54 PM
  • expertdecisions: cloudflare
    January 28, 2017, 08:01:47 AM
  • aegersz: SM release 2.0.13 !
    January 12, 2017, 06:00:13 AM
  • raffo: Tks Emanuele, even if I didn't understand the fix :D
    November 07, 2016, 02:01:20 AM
  • emanuele: [link]
    November 01, 2016, 12:43:50 PM
  • emanuele: raffo: the English support board is a good place. ;)
    November 01, 2016, 12:43:38 PM
  • raffo: Where can I find the fix for the shoutbox?
    November 01, 2016, 05:06:09 AM
  • {OCS}MasterSeal: To the SP team, I make a point to come here and thank you as much as possible for your work.  so again, THANK YOU!
    October 28, 2016, 10:38:05 AM
  • emanuele: That's indeed funny, the limit is present only in the patch and not the full install.
    October 22, 2016, 06:14:58 PM

* Recent Posts

Re: How to Add signature in Simple Portal? by tocnaza
[July 06, 2019, 12:04:00 PM]


Re: Yeni Sürüm Çıkacak mı? by mkuru
[July 01, 2019, 03:05:44 AM]


Re: Yeni Sürüm Çıkacak mı? by akorkut
[June 28, 2019, 05:38:26 AM]


Re: Yeni Sürüm Çıkacak mı? by mkuru
[June 26, 2019, 12:09:02 PM]


Yeni Sürüm Çıkacak mı? by akorkut
[June 25, 2019, 04:53:54 AM]

NEED HELP? If you're looking for support with Simple Portal, look no further than the Support Board!

Author Topic: Broke SMF horribly and seems to be SP theme  (Read 4106 times)

0 Members and 1 Guest are viewing this topic.

Offline redcairo

  • Semi Newbie
  • *
  • Posts: 24
  • SMF Version: 2 RC1
  • SP Version: 2.2.1
Broke SMF horribly and seems to be SP theme
« on: May 19, 2015, 08:22:09 AM »
My server corp (unresponsive to this drama) 'upgraded' my domain. Apparently my SMF forum using SP now requires 'relative paths' such as for themes, as it made it hideously ugly and gives an error about theme not found at the top. So in troubleshooting this, the hard paths are fine, I replace http://www with //www which I found a note about somewhere, but this did not solve it. So at the bottom of an admin page in SMF it said something like try to find/resolve paths with a button. I thought perhaps it would look at the server and then give me whatever it 'ought' to use. When I pressed the button, I broke the forum utterly, which now has a huge blaring message and BARS access to my admin panel and everything else so I cannot try to FIX it:

Sorry, the copyright must be in the template.
Please notify this forum's administrator that this site is missing the copyright message for SMF so they can rectify the situation. Display of copyright is a legal requirement. For more information on this please visit the Simple Machines website.
Not sure why this message is appearing? Take a look at some common causes.

Now I realize this looks like an SMF issue of course, and I thought it was "theme incompatibility" and I was about to see if I could remove everything but default theme from FTP just in case, but just above that error above it says:

Unable to load the 'Portal' template.

I didn't even know what this was talking about for some time. I finally realized it must relate to simple portal... somehow. But since I cannot get to my admin panel in SMF anymore, I can't even look around to see if I could temporarily disable SP in order to work on figuring out WTH is going on.

Is there a way to disable SP in SMF without using the SMF admin panel?

Thanks for any help. The forum is totally broken which is so frustrating.

I can't tell you my version of SMF as I can't see the admin panel. I think it is slightly behind as our forum webmaster has some serious health issues and I've been trying not to lean on him, so I'm trying to figure it out myself. We have a pretty big forum for many years now and I'm afraid of doing something that will hose it in some way that can't be fixed.

http://www.dojopsi.info/forum/index.php?www

PJ (RedCairo)

Offline ♦ Ninja ZX-10RR ♦

  • Spammer Hammer
  • Support
  • *
  • Posts: 1188
  • Gender: Male
  • Sniper Legends
    • Virtual Interactive Games Entertainment™
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
  • Elkarte Version: 1.0.6
Re: Broke SMF horribly and seems to be SP theme
« Reply #1 on: May 19, 2015, 12:18:53 PM »
Hi!

My server corp (unresponsive to this drama) 'upgraded' my domain.
What do you mean by "upgrading" the domain? There is no such thing as domain "upgrades".

Apparently my SMF forum using SP now requires 'relative paths' such as for themes, as it made it hideously ugly and gives an error about theme not found at the top. [snip]
SimplePortal has nothing to deal with this, really, but I will support you anyway because you are not on the official site (that I hate). However, you are still in the wrong forum and in the wrong section.

Now I realize this looks like an SMF issue of course, and I thought it was "theme incompatibility" and I was about to see if I could remove everything but default theme from FTP just in case, but just above that error above it says:

Unable to load the 'Portal' template.

I didn't even know what this was talking about for some time. I finally realized it must relate to simple portal... somehow. But since I cannot get to my admin panel in SMF anymore, I can't even look around to see if I could temporarily disable SP in order to work on figuring out WTH is going on.
As above, it's an SMF issue, rather easy, I'll tell you afterwards.

Is there a way to disable SP in SMF without using the SMF admin panel?
There are always multiple ways to do things, in this case manually editing some values in the database, but it's not required, keep on reading.

I can't tell you my version of SMF as I can't see the admin panel. I think it is slightly behind as our forum webmaster has some serious health issues and I've been trying not to lean on him, so I'm trying to figure it out myself. We have a pretty big forum for many years now and I'm afraid of doing something that will hose it in some way that can't be fixed.
This is *BAD*. First off you should at least know the version you are on, secondly it looks YEARS behind and completely insecure, even a newbie coder could hack that, if you are still on RC versions (and from what I can see, you are).

http://www.dojopsi.info/forum/index.php?www
Even the link is wrong, index.php should be the end of it, there is no such thing like "www" AFTER the index.php



Anyways, the solution for this should be rather easy, just follow the instructions provided here and use the repair_settings.php tool: http://wiki.simplemachines.org/smf/Repair_settings.php/en



Regards
Have you tried SimplePortal Documentation before asking? ;)
F.A.Q.  English Support  |  Blocks Support
Fancy Feature idea ?!  |  Blocks Requests
Themes & Graphics

▼ My job! ▼

No PMs for support unless it's a paid request. Thank you! :)
#OpIsis

Offline redcairo

  • Semi Newbie
  • *
  • Posts: 24
  • SMF Version: 2 RC1
  • SP Version: 2.2.1
Re: Broke SMF horribly and seems to be SP theme
« Reply #2 on: May 20, 2015, 12:12:54 AM »
Thank you. My term was wrong; they 'upgraded' the server (probably moved the files to the cloud, they call it what they want). I realize a domain is a separate thing rather like I am not my name but tend to blur them. I've been working on the SMF fixes all day (still to no avail, it just got worse in a way). I agree now this is unrelated to simple portal and I apologize for posting; when it said 'portal theme' I thought maybe there was something missing related to SP that I could re-upload or whatever. I thought install and upgrade was the place for this since I am upgrading my SMF and figured maybe I needed to re-install or upgrade SP. Again, sorry about the confusion. Thanks for your response.  PJ (RC)


Offline ♦ Ninja ZX-10RR ♦

  • Spammer Hammer
  • Support
  • *
  • Posts: 1188
  • Gender: Male
  • Sniper Legends
    • Virtual Interactive Games Entertainment™
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
  • Elkarte Version: 1.0.6
Re: Broke SMF horribly and seems to be SP theme
« Reply #3 on: May 20, 2015, 02:13:01 AM »
Well, I told you what to do anyway, let me know :)
Have you tried SimplePortal Documentation before asking? ;)
F.A.Q.  English Support  |  Blocks Support
Fancy Feature idea ?!  |  Blocks Requests
Themes & Graphics

▼ My job! ▼

No PMs for support unless it's a paid request. Thank you! :)
#OpIsis