collapse collapse

* User Info

 
 
Welcome, Guest. Please login or register.
Did you miss your activation email?

* Who's Online

  • Dot Guests: 172
  • Dot Hidden: 0
  • Dot Users: 0

There aren't any users online.

* Shoutbox

Refresh History
  • Shoutbox is not for support!
  • {OCS}MasterSeal: STILL love SP :)
    November 24, 2018, 05:05:50 AM
  • ♦ Ninja ZX-10RR ♦: <3 aegersz
    September 13, 2018, 03:36:09 PM
  • aegersz: I STILL <3 LOVE SimplePortal
    September 13, 2018, 07:11:39 AM
  • aegersz: o LOVE you guys - Simple Portal rocks !
    May 09, 2018, 05:18:59 AM
  • Chen Zhen: our apologies for the site being down.. please read server issues topic
    March 22, 2018, 05:32:38 AM
  • {OCS}MasterSeal: LOL PLEASE forget I just posted that. I found the answer in my own dang post back in 2015. lol sorry!
    July 04, 2017, 10:47:55 PM
  • {OCS}MasterSeal: I know this SB isnt' for support, but I just have a general question. Who would I contact to find out where SP stores its block info? Is it DB driven or files? I searched the site but came up with nothing. probably my fault any insight is appreciated.
    July 04, 2017, 10:43:36 PM
  • ♦ Ninja ZX-10RR ♦: Excuse me but what does Simpleportal have to deal with that?
    February 05, 2017, 08:21:14 PM
  • WhiteEagle: of course IMHO that site appears to be dead :(
    February 04, 2017, 01:08:05 PM
  • WhiteEagle: If I can get that, then I'll use it for that site...
    February 04, 2017, 01:07:35 PM
  • WhiteEagle: decided to not use SMF for any projects, unless I can get a copy of the premium version of the fanfiction archive plugin
    February 04, 2017, 01:06:54 PM
  • expertdecisions: cloudflare
    January 28, 2017, 08:01:47 AM
  • aegersz: SM release 2.0.13 !
    January 12, 2017, 06:00:13 AM
  • raffo: Tks Emanuele, even if I didn't understand the fix :D
    November 07, 2016, 02:01:20 AM
  • emanuele: [link]
    November 01, 2016, 12:43:50 PM
  • emanuele: raffo: the English support board is a good place. ;)
    November 01, 2016, 12:43:38 PM
  • raffo: Where can I find the fix for the shoutbox?
    November 01, 2016, 05:06:09 AM
  • {OCS}MasterSeal: To the SP team, I make a point to come here and thank you as much as possible for your work.  so again, THANK YOU!
    October 28, 2016, 10:38:05 AM
  • emanuele: That's indeed funny, the limit is present only in the patch and not the full install.
    October 22, 2016, 06:14:58 PM
  • phantomm: and from what I see only patch is broken, full install package is fine
    October 21, 2016, 03:44:44 PM

* Recent Posts

Re: v 2.3.3 to v2.3.7 by ♦ Ninja ZX-10RR ♦
[December 11, 2018, 04:14:48 PM]


v 2.3.3 to v2.3.7 by rollingrock
[December 11, 2018, 09:36:20 AM]


[Block] Help with editing few lines on Simpleportal by Wallen
[December 09, 2018, 05:10:34 AM]


Re: LinkTree by Chen Zhen
[November 15, 2018, 02:24:51 PM]


Re: blocks showing user avatars by hulapyk
[November 15, 2018, 01:47:11 PM]

Thanks for having an interest with our portal. If you have any requests for features, have a look at the Feature Requests board.

Author Topic: Not logged in on Front page?  (Read 10935 times)

0 Members and 2 Guests are viewing this topic.

Offline khigh

  • Semi Newbie
  • *
  • Posts: 17
  • SMF Version: 2.0.10
  • SP Version: 2.3.6
Not logged in on Front page?
« on: July 26, 2015, 01:55:20 PM »
Hi all,

I got some help on here before about setting up as a standalone where SP was on the base URL and SMF was on /forum. I got that working great on a "minor" forum I was doing mostly for practice.

Now I'm putting together my "main" forum - relocating a years-old community in the four figures of members and I set it up the same way and it's mostly working.

EXCEPT

When I'm on "forum", I'm logged in, but when I'm on the SP "home" page, I'm "guest".

Any idea what I'm missing?

Thanks for looking.

Offline ♦ Ninja ZX-10RR ♦

  • Spammer Hammer
  • Support
  • *
  • Posts: 1177
  • Gender: Male
  • Sniper Legends
    • Virtual Interactive Games Entertainment™
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
  • Elkarte Version: 1.0.6
Re: Not logged in on Front page?
« Reply #1 on: July 26, 2015, 02:12:03 PM »
Hi khigh,

Could you please provide a link to your site and a screenshot of the issue? I can't really understand "where" you show as offline, in menus or in general. It matters because the answer changes accordingly.

Regards
Have you tried SimplePortal Documentation before asking? ;)
F.A.Q.  English Support  |  Blocks Support
Fancy Feature idea ?!  |  Blocks Requests
Themes & Graphics

▼ My job! ▼

No PMs for support unless it's a paid request. Thank you! :)
#OpIsis

Offline khigh

  • Semi Newbie
  • *
  • Posts: 17
  • SMF Version: 2.0.10
  • SP Version: 2.3.6
Re: Not logged in on Front page?
« Reply #2 on: July 26, 2015, 02:28:41 PM »
Thank you for the quick response.

If you need me to PM you the URL, I can, but it's not really "live" nor "public", so not the kind of thing I'd post.

Here's the view when I'm on straight SMF. the "Forum" button. I'm logged in - you can see I have Admin and Moderate



When I click "Home" on the same page and go to the Simple Portal Home page, it displays my user info as guest. the little asterisk and number are Lastpass offering to log me in as one of three different identities, if you're not familar. That's not a factor, though, because the same behavior is present on non-lastpass browsers, and my "working" forum works with it.



If I click "Forum" again, I return to SMF and I'm logged in. If I log in on the SP page, go to Forum, and return to SP, I'm Guest again.


« Last Edit: July 26, 2015, 02:54:14 PM by khigh »

Offline ♦ Ninja ZX-10RR ♦

  • Spammer Hammer
  • Support
  • *
  • Posts: 1177
  • Gender: Male
  • Sniper Legends
    • Virtual Interactive Games Entertainment™
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
  • Elkarte Version: 1.0.6
Re: Not logged in on Front page?
« Reply #3 on: July 26, 2015, 03:26:33 PM »
Thanks.

Just to exclude any cookie-related issue... Could you please rename the cookies from here? action=admin;area=serversettings;sa=cookie; See if it changes anything other than probably having to relog.

Regards
Have you tried SimplePortal Documentation before asking? ;)
F.A.Q.  English Support  |  Blocks Support
Fancy Feature idea ?!  |  Blocks Requests
Themes & Graphics

▼ My job! ▼

No PMs for support unless it's a paid request. Thank you! :)
#OpIsis

Offline khigh

  • Semi Newbie
  • *
  • Posts: 17
  • SMF Version: 2.0.10
  • SP Version: 2.3.6
Re: Not logged in on Front page?
« Reply #4 on: July 26, 2015, 03:56:32 PM »
Hi and thanks.

I type that somewhere? Edit it into a file?

Offline khigh

  • Semi Newbie
  • *
  • Posts: 17
  • SMF Version: 2.0.10
  • SP Version: 2.3.6
Re: Not logged in on Front page?
« Reply #5 on: July 26, 2015, 04:12:55 PM »
While I'm waiting

Broken on FF and Chrome, but works on IE

That's odd

Offline ♦ Ninja ZX-10RR ♦

  • Spammer Hammer
  • Support
  • *
  • Posts: 1177
  • Gender: Male
  • Sniper Legends
    • Virtual Interactive Games Entertainment™
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
  • Elkarte Version: 1.0.6
Re: Not logged in on Front page?
« Reply #6 on: July 26, 2015, 04:23:02 PM »
action=admin;area=serversettings;sa=cookie;
and there is an input field in that page.

The fact that it works on IE makes me think of a corrupted cookie issue even more.
Have you tried SimplePortal Documentation before asking? ;)
F.A.Q.  English Support  |  Blocks Support
Fancy Feature idea ?!  |  Blocks Requests
Themes & Graphics

▼ My job! ▼

No PMs for support unless it's a paid request. Thank you! :)
#OpIsis

Offline khigh

  • Semi Newbie
  • *
  • Posts: 17
  • SMF Version: 2.0.10
  • SP Version: 2.3.6
Re: Not logged in on Front page?
« Reply #7 on: July 26, 2015, 04:24:34 PM »
I put that in the address bar and it just came up a google search.

Does it go in a file?

Offline ♦ Ninja ZX-10RR ♦

  • Spammer Hammer
  • Support
  • *
  • Posts: 1177
  • Gender: Male
  • Sniper Legends
    • Virtual Interactive Games Entertainment™
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
  • Elkarte Version: 1.0.6
Re: Not logged in on Front page?
« Reply #8 on: July 26, 2015, 04:39:05 PM »
Ehm... It's part of the URL you should be using :/

{yourforumURL}/index.php?action=admin;area=serversettings;sa=cookie;
Have you tried SimplePortal Documentation before asking? ;)
F.A.Q.  English Support  |  Blocks Support
Fancy Feature idea ?!  |  Blocks Requests
Themes & Graphics

▼ My job! ▼

No PMs for support unless it's a paid request. Thank you! :)
#OpIsis

Offline [SiNaN]

  • Mr. SimplePortal
  • Developer
  • *
  • Posts: 6782
  • SMF Version: 2.0.15
  • SP Version: 2.3.7
Re: Not logged in on Front page?
« Reply #9 on: July 26, 2015, 05:01:27 PM »
Go to Admin > Server Settings > Cookies and Sessions area.

Make sure your settings are set like this:

Enable local storage of cookies > off
Use subdomain independent cookies > on
And slowly, you come to realize... It's all as it should be...

Offline khigh

  • Semi Newbie
  • *
  • Posts: 17
  • SMF Version: 2.0.10
  • SP Version: 2.3.6
Re: Not logged in on Front page?
« Reply #10 on: July 26, 2015, 05:26:58 PM »
OK - I did both of those things.

also did several combinations of logging out, clearing cookies, etc.

Also tried my phone browsers. Dolphin (the one I've been using on it) worked - Chrome and FF did not.

Offline khigh

  • Semi Newbie
  • *
  • Posts: 17
  • SMF Version: 2.0.10
  • SP Version: 2.3.6
Re: Not logged in on Front page?
« Reply #11 on: July 26, 2015, 05:28:28 PM »
Also just checked the working SP install and confirmed both it and the broken one are SimplePortal 2.3.6

Offline khigh

  • Semi Newbie
  • *
  • Posts: 17
  • SMF Version: 2.0.10
  • SP Version: 2.3.6
Re: Not logged in on Front page?
« Reply #12 on: July 26, 2015, 05:42:17 PM »
OK Thanks guys - those tow boxes didn't do it, but got to dinking around on that admin page and it's working now.

Thanks!


Offline ♦ Ninja ZX-10RR ♦

  • Spammer Hammer
  • Support
  • *
  • Posts: 1177
  • Gender: Male
  • Sniper Legends
    • Virtual Interactive Games Entertainment™
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
  • Elkarte Version: 1.0.6
Re: Not logged in on Front page?
« Reply #13 on: July 26, 2015, 05:50:54 PM »
Glad that it's solved, but it would be kind to post how you did it, just in case another user experiences the same issue! ;)
Have you tried SimplePortal Documentation before asking? ;)
F.A.Q.  English Support  |  Blocks Support
Fancy Feature idea ?!  |  Blocks Requests
Themes & Graphics

▼ My job! ▼

No PMs for support unless it's a paid request. Thank you! :)
#OpIsis

Offline khigh

  • Semi Newbie
  • *
  • Posts: 17
  • SMF Version: 2.0.10
  • SP Version: 2.3.6
Re: Not logged in on Front page?
« Reply #14 on: July 26, 2015, 06:11:06 PM »
Oh sure.

It looks like this now, and it's working. Thanks again



Offline ♦ Ninja ZX-10RR ♦

  • Spammer Hammer
  • Support
  • *
  • Posts: 1177
  • Gender: Male
  • Sniper Legends
    • Virtual Interactive Games Entertainment™
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
  • Elkarte Version: 1.0.6
Re: Not logged in on Front page?
« Reply #15 on: July 26, 2015, 07:00:47 PM »
Thanks for posting the screenshot! Post again if you have further issues/doubts. Have a nice day & hope you enjoy using SimplePortal!
Have you tried SimplePortal Documentation before asking? ;)
F.A.Q.  English Support  |  Blocks Support
Fancy Feature idea ?!  |  Blocks Requests
Themes & Graphics

▼ My job! ▼

No PMs for support unless it's a paid request. Thank you! :)
#OpIsis

Offline sundar_83

  • Newbie
  • Posts: 2
  • SMF Version: 2.0.12
  • SP Version: 2.3.7
Re: Not logged in on Front page?
« Reply #16 on: September 30, 2018, 12:21:10 AM »
Oh sure.

It looks like this now, and it's working. Thanks again



Thanks for this solution as u like said just changing the cookie name its getting resolve