collapse collapse

* Simple Portal Archived Forum

This is an Archive Forum.

The content in this forum may be out-of-date or have been superseded by newer information, and links in forum pages to other sites may not work.
This forum contains archives for future reference.

Visit our thread at Simple Machines Forum for current support.

* User Info

 
 
Welcome, Guest. Please login or register.

* Who's Online

  • Dot Guests: 116
  • Dot Hidden: 0
  • Dot Users: 0

There aren't any users online.

* Shoutbox

Refresh History
  • Shoutbox is not for support!
  • {OCS}MasterSeal: Yup, Still adore SP
    April 21, 2019, 07:08:06 PM
  • {OCS}MasterSeal: STILL love SP :)
    November 24, 2018, 05:05:50 AM
  • ♦ Ninja ZX-10RR ♦: <3 aegersz
    September 13, 2018, 03:36:09 PM
  • aegersz: I STILL <3 LOVE SimplePortal
    September 13, 2018, 07:11:39 AM
  • aegersz: o LOVE you guys - Simple Portal rocks !
    May 09, 2018, 05:18:59 AM
  • Chen Zhen: our apologies for the site being down.. please read server issues topic
    March 22, 2018, 05:32:38 AM
  • {OCS}MasterSeal: LOL PLEASE forget I just posted that. I found the answer in my own dang post back in 2015. lol sorry!
    July 04, 2017, 10:47:55 PM
  • {OCS}MasterSeal: I know this SB isnt' for support, but I just have a general question. Who would I contact to find out where SP stores its block info? Is it DB driven or files? I searched the site but came up with nothing. probably my fault any insight is appreciated.
    July 04, 2017, 10:43:36 PM
  • ♦ Ninja ZX-10RR ♦: Excuse me but what does Simpleportal have to deal with that?
    February 05, 2017, 08:21:14 PM
  • WhiteEagle: of course IMHO that site appears to be dead :(
    February 04, 2017, 01:08:05 PM
  • WhiteEagle: If I can get that, then I'll use it for that site...
    February 04, 2017, 01:07:35 PM
  • WhiteEagle: decided to not use SMF for any projects, unless I can get a copy of the premium version of the fanfiction archive plugin
    February 04, 2017, 01:06:54 PM
  • expertdecisions: cloudflare
    January 28, 2017, 08:01:47 AM
  • aegersz: SM release 2.0.13 !
    January 12, 2017, 06:00:13 AM
  • raffo: Tks Emanuele, even if I didn't understand the fix :D
    November 07, 2016, 02:01:20 AM
  • emanuele: [link]
    November 01, 2016, 12:43:50 PM
  • emanuele: raffo: the English support board is a good place. ;)
    November 01, 2016, 12:43:38 PM
  • raffo: Where can I find the fix for the shoutbox?
    November 01, 2016, 05:06:09 AM
  • {OCS}MasterSeal: To the SP team, I make a point to come here and thank you as much as possible for your work.  so again, THANK YOU!
    October 28, 2016, 10:38:05 AM
  • emanuele: That's indeed funny, the limit is present only in the patch and not the full install.
    October 22, 2016, 06:14:58 PM

* Recent Posts

Adding Forums Button to Nav bar by jirapon
[August 01, 2019, 09:07:12 AM]


Re: Board Icons by ♦ Ninja ZX-10RR ♦
[July 30, 2019, 04:03:41 PM]


MOVED: Czech translation???? by ♦ Ninja ZX-10RR ♦
[July 30, 2019, 03:04:51 PM]


Board Icons by jirapon
[July 30, 2019, 07:28:44 AM]


Re: Thankyou Simpleportal, by ♦ Ninja ZX-10RR ♦
[July 29, 2019, 09:41:29 AM]

Thanks for having an interest with our portal. If you have any requests for features, have a look at the Feature Requests board.

Author Topic: Simple Portal Blocks  (Read 8405 times)

0 Members and 1 Guest are viewing this topic.

Offline brettuk

  • Semi Newbie
  • *
  • Posts: 10
  • SMF Version: 2.0.11
Simple Portal Blocks
« on: April 18, 2016, 08:20:15 AM »
Hi,

I am currently using the Blocks feature to add content to each of my categories, as you can see here:
theseoforums.com/scrapebox-footprints/

All looks good - I was happy to find out that I could do this, however, when you visit a post within that category - the content remains, which is a pain.

I have assigned the block to only appear for the 'Scrapebox Footprints' board, but ofcourse, all posts will have the same header.

Anyway to exclude the posts?

Thanks! I appreciate every reply!
Site: Semtuts

Offline ♦ Ninja ZX-10RR ♦

  • Spammer Hammer
  • Support
  • *
  • Posts: 1193
  • Gender: Male
  • Sniper Legends
    • Virtual Interactive Games Entertainment™
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
  • Elkarte Version: 1.0.6
Re: Simple Portal Blocks
« Reply #1 on: April 18, 2016, 09:29:16 AM »
Hi and welcome to SimplePortal.

I cannot see any block in that board.

Regards
Have you tried SimplePortal Documentation before asking? ;)
F.A.Q.  English Support  |  Blocks Support
Fancy Feature idea ?!  |  Blocks Requests
Themes & Graphics

? My job! ?No PMs for support unless it's a paid request. Thank you! :)#OpIsis

Offline brettuk

  • Semi Newbie
  • *
  • Posts: 10
  • SMF Version: 2.0.11
Re: Simple Portal Blocks
« Reply #2 on: April 18, 2016, 12:08:13 PM »
Hi and welcome to SimplePortal.

I cannot see any block in that board.

Regards

Woops! My bad.
I had hidden it, I have re-enabled it now.
Site: Semtuts

Offline ♦ Ninja ZX-10RR ♦

  • Spammer Hammer
  • Support
  • *
  • Posts: 1193
  • Gender: Male
  • Sniper Legends
    • Virtual Interactive Games Entertainment™
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
  • Elkarte Version: 1.0.6
Re: Simple Portal Blocks
« Reply #3 on: April 18, 2016, 12:57:24 PM »
Block display doesn't work properly with prettyURLs installed (which is useless anyway - ref), so, to display the block properly, I think you will have to hard-code the block into the template.
Have you tried SimplePortal Documentation before asking? ;)
F.A.Q.  English Support  |  Blocks Support
Fancy Feature idea ?!  |  Blocks Requests
Themes & Graphics

? My job! ?No PMs for support unless it's a paid request. Thank you! :)#OpIsis

Offline emanuele

  • Developer
  • *
  • Posts: 293
Re: Simple Portal Blocks
« Reply #4 on: April 18, 2016, 03:44:42 PM »
Why block should not work with prettyURL? O_o

As a general rule, to hide a block from the posting page you can use:
Code: [Select]
-~action|post,-~action|post2 in the custom display options field (at least it works for me, but I'm not using the standard SP, so it may be due to some unrelated change.

Offline ♦ Ninja ZX-10RR ♦

  • Spammer Hammer
  • Support
  • *
  • Posts: 1193
  • Gender: Male
  • Sniper Legends
    • Virtual Interactive Games Entertainment™
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
  • Elkarte Version: 1.0.6
Re: Simple Portal Blocks
« Reply #5 on: April 18, 2016, 03:56:57 PM »
Last time I tried, it didn't work with a mod editing the URL in a much easier way, let alone prettyURLs that rewrites it entirely. If it works, cool then.
Have you tried SimplePortal Documentation before asking? ;)
F.A.Q.  English Support  |  Blocks Support
Fancy Feature idea ?!  |  Blocks Requests
Themes & Graphics

? My job! ?No PMs for support unless it's a paid request. Thank you! :)#OpIsis

Offline brettuk

  • Semi Newbie
  • *
  • Posts: 10
  • SMF Version: 2.0.11
Re: Simple Portal Blocks
« Reply #6 on: April 19, 2016, 04:27:56 AM »
Block display doesn't work properly with prettyURLs installed (which is useless anyway - ref), so, to display the block properly, I think you will have to hard-code the block into the template.

Permalink structure is a ranking algorithm, that guy is chatting out of his ass and has no evidence or theory to back it up.
If I display pretty URL's, the block will only display on the category index - surely it will still display sitewide for all posts in that category?
Site: Semtuts

Offline ♦ Ninja ZX-10RR ♦

  • Spammer Hammer
  • Support
  • *
  • Posts: 1193
  • Gender: Male
  • Sniper Legends
    • Virtual Interactive Games Entertainment™
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
  • Elkarte Version: 1.0.6
Re: Simple Portal Blocks
« Reply #7 on: April 19, 2016, 05:04:30 AM »
Well, Arantor is one of the most experience coders on the planet (although weird), but whatever, regardless of that, please refrain from using such tones on this board.

emanuele already replied with a suggestion, can you try that?

Regards
Have you tried SimplePortal Documentation before asking? ;)
F.A.Q.  English Support  |  Blocks Support
Fancy Feature idea ?!  |  Blocks Requests
Themes & Graphics

? My job! ?No PMs for support unless it's a paid request. Thank you! :)#OpIsis

Offline brettuk

  • Semi Newbie
  • *
  • Posts: 10
  • SMF Version: 2.0.11
Re: Simple Portal Blocks
« Reply #8 on: April 19, 2016, 05:57:05 AM »
Well, Arantor is one of the most experience coders on the planet (although weird), but whatever, regardless of that, please refrain from using such tones on this board.

emanuele already replied with a suggestion, can you try that?

Regards

Sorry - doesn't seem to work unfortunately :(
I uninstalled the pretty URL's mod and it still doesn't - I can't install it now I get the following error:

'Your session timed out while posting. Please go back and try again.'

Eugh :(
Site: Semtuts

Offline ♦ Ninja ZX-10RR ♦

  • Spammer Hammer
  • Support
  • *
  • Posts: 1193
  • Gender: Male
  • Sniper Legends
    • Virtual Interactive Games Entertainment™
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
  • Elkarte Version: 1.0.6
Re: Simple Portal Blocks
« Reply #9 on: April 19, 2016, 06:06:25 AM »
Code: [Select]
-~action|post,-~action|post2 in the custom display options field (at least it works for me, but I'm not using the standard SP, so it may be due to some unrelated change.
emanuele already replied with a suggestion, can you try that?
I uninstalled the pretty URL's mod
._. 2 people asking you to put some code into block display settings and you uninstalled prettyURLs instead...

We are not prettyURLs support either, so I don't know what is wrong now with that thing, but you could try to rename the forum cookies, to see if they got messed up, and install it again.
Have you tried SimplePortal Documentation before asking? ;)
F.A.Q.  English Support  |  Blocks Support
Fancy Feature idea ?!  |  Blocks Requests
Themes & Graphics

? My job! ?No PMs for support unless it's a paid request. Thank you! :)#OpIsis

Offline brettuk

  • Semi Newbie
  • *
  • Posts: 10
  • SMF Version: 2.0.11
Re: Simple Portal Blocks
« Reply #10 on: April 19, 2016, 06:16:57 AM »
Code: [Select]
-~action|post,-~action|post2 in the custom display options field (at least it works for me, but I'm not using the standard SP, so it may be due to some unrelated change.
emanuele already replied with a suggestion, can you try that?
I uninstalled the pretty URL's mod
._. 2 people asking you to put some code into block display settings and you uninstalled prettyURLs instead...

We are not prettyURLs support either, so I don't know what is wrong now with that thing, but you could try to rename the forum cookies, to see if they got messed up, and install it again.

I tried it before and after the mod was uninstalled.

I will try get this fixed.
Site: Semtuts

Offline brettuk

  • Semi Newbie
  • *
  • Posts: 10
  • SMF Version: 2.0.11
Re: Simple Portal Blocks
« Reply #11 on: April 19, 2016, 06:52:15 AM »
Why block should not work with prettyURL? O_o

As a general rule, to hide a block from the posting page you can use:
Code: [Select]
-~action|post,-~action|post2 in the custom display options field (at least it works for me, but I'm not using the standard SP, so it may be due to some unrelated change.

This doesn't seem to work unfortunately :(
Any other ideas? - I would like to keep PrettyURL's installed for the time being.

It would be fantastic if I was to get this working.
Site: Semtuts

Offline emanuele

  • Developer
  • *
  • Posts: 293
Re: Simple Portal Blocks
« Reply #12 on: April 19, 2016, 07:36:22 AM »
Well, Arantor is one of the most experience coders on the planet (although weird), but whatever, regardless of that, please refrain from using such tones on this board.
With all the respect I have for Arantor, he may have good knowledge of programming, but he is no God and doesn't necessarily know any thing of everything.
He had his debacles and the article you linked is 5 years old... you know how long five years are on the internet? For Google ranking algorithm is about 76 updates from 31st December 2011 to now. Are you really that sure the algorithm is still the same he was talking about 5 years ago?

On the other hand, as far as I remember/can find, Google never stated URL is a ranking factor.
In the always useful Search Engine Optimization Starter Guide, the part discussing friendly-URLs is rather short and the most important reason in favour of friendly-URLs is that the words in the URL may help the user identify the content of the page (not the search engine, but the user!):
Quote
URLs with words that are relevant to your site's content and structure are friendlier for visitors navigating your site. Visitors remember them better and might be more willing to link to them.
The only marginal help to ranking from friendly-URLs could come from "autolinking" of url posted "as is", without text describing them.

Anyway, this is way off topic, and I feel if you want to discuss more about that to open a new discussion. ;)

Back on the subject:
As a general rule, to hide a block from the posting page you can use:
Code: [Select]
-~action|post,-~action|post2 in the custom display options field (at least it works for me, but I'm not using the standard SP, so it may be due to some unrelated change.

This doesn't seem to work unfortunately :(
Any other ideas?

It would be fantastic if I was to get this working.
It is not working in the sense that it is still showing on the post pages?
Because I just tested again on a vanilla SP install and selecting the board and adding the above string to "Custom Display Options", the block is shown in the board page (i.e. ?board=123.x), in the topic pages (i.e. ?topic=123.x), but is not displayed when replying to a post or opening a new topic.

Offline brettuk

  • Semi Newbie
  • *
  • Posts: 10
  • SMF Version: 2.0.11
Re: Simple Portal Blocks
« Reply #13 on: April 19, 2016, 08:07:34 AM »
Well, Arantor is one of the most experience coders on the planet (although weird), but whatever, regardless of that, please refrain from using such tones on this board.
With all the respect I have for Arantor, he may have good knowledge of programming, but he is no God and doesn't necessarily know any thing of everything.
He had his debacles and the article you linked is 5 years old... you know how long five years are on the internet? For Google ranking algorithm is about 76 updates from 31st December 2011 to now. Are you really that sure the algorithm is still the same he was talking about 5 years ago?

On the other hand, as far as I remember/can find, Google never stated URL is a ranking factor.
In the always useful Search Engine Optimization Starter Guide, the part discussing friendly-URLs is rather short and the most important reason in favour of friendly-URLs is that the words in the URL may help the user identify the content of the page (not the search engine, but the user!):
Quote
URLs with words that are relevant to your site's content and structure are friendlier for visitors navigating your site. Visitors remember them better and might be more willing to link to them.
The only marginal help to ranking from friendly-URLs could come from "autolinking" of url posted "as is", without text describing them.

Anyway, this is way off topic, and I feel if you want to discuss more about that to open a new discussion. ;)

Back on the subject:
As a general rule, to hide a block from the posting page you can use:
Code: [Select]
-~action|post,-~action|post2 in the custom display options field (at least it works for me, but I'm not using the standard SP, so it may be due to some unrelated change.

This doesn't seem to work unfortunately :(
Any other ideas?

It would be fantastic if I was to get this working.
It is not working in the sense that it is still showing on the post pages?
Because I just tested again on a vanilla SP install and selecting the board and adding the above string to "Custom Display Options", the block is shown in the board page (i.e. ?board=123.x), in the topic pages (i.e. ?topic=123.x), but is not displayed when replying to a post or opening a new topic.

Yes, the block remains to be visible on a topic page.

I am thinking about implementing php into the block, and then grab the title of the post/subject to display in a H1 - if we can't figure out a way to get this working.
Site: Semtuts

Offline emanuele

  • Developer
  • *
  • Posts: 293
Re: Simple Portal Blocks
« Reply #14 on: April 19, 2016, 08:35:30 AM »
Okay, I'm now officially confused.
Could you please tell exactly where you want to see the topic and where you don't want to see it?

Offline brettuk

  • Semi Newbie
  • *
  • Posts: 10
  • SMF Version: 2.0.11
Re: Simple Portal Blocks
« Reply #15 on: April 19, 2016, 09:28:38 AM »
Okay, I'm now officially confused.
Could you please tell exactly where you want to see the topic and where you don't want to see it?

Sorry for the confusion.

I have added a block to the board/category 'Scrapebox Footprints' - which you can view here:
http://www.theseoforums.com/scrapebox-footprints/

However, when you click a post within that category/board - it still shows the header block:
http://www.theseoforums.com/scrapebox-footprints/footprints-for-finding-blog-pages-with-comments-allowed/

Is there anyway I can ONLY display the header block in the '/scrapebox-footprints/' board/category and not the posts within?

Thank you so much for your help. :)
Site: Semtuts

Offline emanuele

  • Developer
  • *
  • Posts: 293
Re: Simple Portal Blocks
« Reply #16 on: April 19, 2016, 09:43:26 AM »
Code: [Select]
-~action|post,-~action|post2,-~topic

Offline brettuk

  • Semi Newbie
  • *
  • Posts: 10
  • SMF Version: 2.0.11
Re: Simple Portal Blocks
« Reply #17 on: April 19, 2016, 10:02:10 AM »
Code: [Select]
-~action|post,-~action|post2,-~topic

Thank you very much! :)  :-*
Site: Semtuts

 

SimplePortal 2.3.7 © 2008-2020, SimplePortal