collapse collapse

* User Info

 
 
Welcome, Guest. Please login or register.
Did you miss your activation email?

* Who's Online

  • Dot Guests: 112
  • Dot Hidden: 0
  • Dot Users: 0

There aren't any users online.

* Shoutbox

Refresh History
  • Shoutbox is not for support!
  • ♦ Ninja ZX-10RR ♦: <3 aegersz
    September 13, 2018, 03:36:09 PM
  • aegersz: I STILL <3 LOVE SimplePortal
    September 13, 2018, 07:11:39 AM
  • aegersz: o LOVE you guys - Simple Portal rocks !
    May 09, 2018, 05:18:59 AM
  • Chen Zhen: our apologies for the site being down.. please read server issues topic
    March 22, 2018, 05:32:38 AM
  • {OCS}MasterSeal: LOL PLEASE forget I just posted that. I found the answer in my own dang post back in 2015. lol sorry!
    July 04, 2017, 10:47:55 PM
  • {OCS}MasterSeal: I know this SB isnt' for support, but I just have a general question. Who would I contact to find out where SP stores its block info? Is it DB driven or files? I searched the site but came up with nothing. probably my fault any insight is appreciated.
    July 04, 2017, 10:43:36 PM
  • ♦ Ninja ZX-10RR ♦: Excuse me but what does Simpleportal have to deal with that?
    February 05, 2017, 08:21:14 PM
  • WhiteEagle: of course IMHO that site appears to be dead :(
    February 04, 2017, 01:08:05 PM
  • WhiteEagle: If I can get that, then I'll use it for that site...
    February 04, 2017, 01:07:35 PM
  • WhiteEagle: decided to not use SMF for any projects, unless I can get a copy of the premium version of the fanfiction archive plugin
    February 04, 2017, 01:06:54 PM
  • expertdecisions: cloudflare
    January 28, 2017, 08:01:47 AM
  • aegersz: SM release 2.0.13 !
    January 12, 2017, 06:00:13 AM
  • raffo: Tks Emanuele, even if I didn't understand the fix :D
    November 07, 2016, 02:01:20 AM
  • emanuele: [link]
    November 01, 2016, 12:43:50 PM
  • emanuele: raffo: the English support board is a good place. ;)
    November 01, 2016, 12:43:38 PM
  • raffo: Where can I find the fix for the shoutbox?
    November 01, 2016, 05:06:09 AM
  • {OCS}MasterSeal: To the SP team, I make a point to come here and thank you as much as possible for your work.  so again, THANK YOU!
    October 28, 2016, 10:38:05 AM
  • emanuele: That's indeed funny, the limit is present only in the patch and not the full install.
    October 22, 2016, 06:14:58 PM
  • phantomm: and from what I see only patch is broken, full install package is fine
    October 21, 2016, 03:44:44 PM
  • phantomm: they say it for over 3 weeks now..
    October 21, 2016, 03:43:52 PM
Thanks for having an interest with our portal. If you have any requests for features, have a look at the Feature Requests board.

Author Topic: Enabling SimplePortal breaks my profile Look And Layout view.  (Read 2610 times)

0 Members and 1 Guest are viewing this topic.

Offline Grammy

  • Semi Newbie
  • *
  • Posts: 15
  • SMF Version: 2.0.11
  • SP Version: 2.3.6
Hi, guys; if you could help, I'd be so grateful.  I have 2.0.11 default.

The issue is how SimplePortal affects an old mod made by JohnyB (Bulakbol) called "Colorize Post".  Another mod author recently supplied me with the necessary edits to port it to 2.0.x and it installed and functions beautifully.  But I couldn't figure out why, when I view Profile-->Look and Layout, the field for its settings were broken.  Part of it appeared at the top of the page and part of it appeared at the bottom.  (Please see the two screenshots attached).  It should all be at the bottom of the page. 

I installed a fresh test forum today and the issue was gone.  One by one, I began reinstalling each mod, testing each time to see what was causing the problem.  Unfortunately, it is SimplePortal.  When I disable it, everything appears as it should (3rd screenshot).  The minute I enable it, the page "breaks". 

The files that SimplePortal and Colorize Post have in common are:  Load.php, Recent.php, ManagePermissions.php and Display.template.php.  I don't know which of these is affecting my profile's Look and Layout view.  I would guess the template?  I'm attaching Colorize Post's XML file and asking if you guys see any conflict in edits that would cause this to happen.

The Colorize Post is the only one of its kind that allows users to preset their favorite font and color.  Otherwise, I would simply try another kind.  I would appreciate any insight you could offer into this.

Thanks so much.
« Last Edit: June 14, 2016, 05:11:34 PM by Grammy »

Offline emanuele

  • Developer
  • *
  • Posts: 293
Re: Enabling SimplePortal breaks my profile Look And Layout view.
« Reply #1 on: June 14, 2016, 04:47:13 PM »
If I got the colorize file right (as a suggestion, next time post a link to the mods you are talking about, and if multiple files are present which one you downloaded so that anyone trying to help will be able to quickly pick up the situation) the issue is that the template of the mod is wrote for a very old version of SMF (namely 2.0 RC1) that had a completely different HTML markup (involving tables).

So, to fix this behaviour there is to rewrite the template in the function template_profile_modify_font present in Profile.template.php.
Probably, changing the various:
Code: [Select]
<tr><td>with:
Code: [Select]
<li>and the:
Code: [Select]
</td></tr>with:
Code: [Select]
</li>should do most of the trick.

Offline Grammy

  • Semi Newbie
  • *
  • Posts: 15
  • SMF Version: 2.0.11
  • SP Version: 2.3.6
Re: Enabling SimplePortal breaks my profile Look And Layout view.
« Reply #2 on: June 14, 2016, 05:11:12 PM »
Oh, thank you so much; that sorted it!  I'm really happy to be able to turn on my SimplePortal again; it's looking so nice and the users are loving it.  :)

Thank you for fixing an issue that, it turns out, really wasn't SimplePortal's issue to fix.  I'm confused, I have to say, as to why just that one mod's simple
Code: [Select]
<tr><td></td></tr> reacted when the portal was enabled, when that whole file seems filled with those same tags.  It's hard to say, without digging in, which were put there by SMF and which were added by mods, but nothing else seems to be affected by SimplePortal.  So that's a big sigh of relief! 

The link to that mod (in case anyone reading this at a later time wonders) is:

http://custom.simplemachines.org/mods/index.php?mod=1061

However, it isn't the zip I uploaded, since mine has the more current edits. 

Thank you again, for your kind help; very appreciated!

Offline emanuele

  • Developer
  • *
  • Posts: 293
Re: Enabling SimplePortal breaks my profile Look And Layout view.
« Reply #3 on: June 15, 2016, 08:32:12 AM »
The normal layout doesn't use tables. SP, on the other hand, uses a big table to wrap the whole page and create the areas. So, when you enable SP, the browser will associate the <tr>s from the mod with those from SP messing things up.