collapse collapse

* User Info

 
 
Welcome, Guest. Please login or register.
Did you miss your activation email?

* Who's Online

  • Dot Guests: 189
  • Dot Hidden: 0
  • Dot Users: 0

There aren't any users online.

* Shoutbox

Refresh History
  • Shoutbox is not for support!
  • {OCS}MasterSeal: STILL love SP :)
    November 24, 2018, 05:05:50 AM
  • ♦ Ninja ZX-10RR ♦: <3 aegersz
    September 13, 2018, 03:36:09 PM
  • aegersz: I STILL <3 LOVE SimplePortal
    September 13, 2018, 07:11:39 AM
  • aegersz: o LOVE you guys - Simple Portal rocks !
    May 09, 2018, 05:18:59 AM
  • Chen Zhen: our apologies for the site being down.. please read server issues topic
    March 22, 2018, 05:32:38 AM
  • {OCS}MasterSeal: LOL PLEASE forget I just posted that. I found the answer in my own dang post back in 2015. lol sorry!
    July 04, 2017, 10:47:55 PM
  • {OCS}MasterSeal: I know this SB isnt' for support, but I just have a general question. Who would I contact to find out where SP stores its block info? Is it DB driven or files? I searched the site but came up with nothing. probably my fault any insight is appreciated.
    July 04, 2017, 10:43:36 PM
  • ♦ Ninja ZX-10RR ♦: Excuse me but what does Simpleportal have to deal with that?
    February 05, 2017, 08:21:14 PM
  • WhiteEagle: of course IMHO that site appears to be dead :(
    February 04, 2017, 01:08:05 PM
  • WhiteEagle: If I can get that, then I'll use it for that site...
    February 04, 2017, 01:07:35 PM
  • WhiteEagle: decided to not use SMF for any projects, unless I can get a copy of the premium version of the fanfiction archive plugin
    February 04, 2017, 01:06:54 PM
  • expertdecisions: cloudflare
    January 28, 2017, 08:01:47 AM
  • aegersz: SM release 2.0.13 !
    January 12, 2017, 06:00:13 AM
  • raffo: Tks Emanuele, even if I didn't understand the fix :D
    November 07, 2016, 02:01:20 AM
  • emanuele: [link]
    November 01, 2016, 12:43:50 PM
  • emanuele: raffo: the English support board is a good place. ;)
    November 01, 2016, 12:43:38 PM
  • raffo: Where can I find the fix for the shoutbox?
    November 01, 2016, 05:06:09 AM
  • {OCS}MasterSeal: To the SP team, I make a point to come here and thank you as much as possible for your work.  so again, THANK YOU!
    October 28, 2016, 10:38:05 AM
  • emanuele: That's indeed funny, the limit is present only in the patch and not the full install.
    October 22, 2016, 06:14:58 PM
  • phantomm: and from what I see only patch is broken, full install package is fine
    October 21, 2016, 03:44:44 PM

* Recent Posts

Re: Occasional Chat/Shout box Issue by OpoWolfie
[January 06, 2019, 04:54:46 AM]


Re: Where is the code for these elements, where are they stored? by Chen Zhen
[January 04, 2019, 10:50:07 AM]


Re: Have a block only show on threads? by danmsmith018f
[January 03, 2019, 05:46:35 AM]


Re: Occasional Chat/Shout box Issue by OpoWolfie
[January 03, 2019, 05:33:09 AM]


Re: Occasional Chat/Shout box Issue by Chen Zhen
[January 03, 2019, 12:54:27 AM]

Blocks speak! Do you have an interest in getting more blocks - or even making your own? The Blocks Board is for you!

Author Topic: SimplePortal installation error  (Read 12030 times)

0 Members and 1 Guest are viewing this topic.

Offline SweeX

  • Semi Newbie
  • *
  • Posts: 5
  • Gender: Male
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
SimplePortal installation error
« on: January 20, 2017, 01:41:32 PM »
Hi all !
I need help installing simpleportal on my forum. Im using zone99 theme.
Here are pics about my problem.

http://i.imgur.com/hRCgUBl.png

http://i.imgur.com/tmxzrCA.png

Any solutions?  :(

Offline Chen Zhen

  • The Underdog
  • Operations Manager
  • *
  • Posts: 1342
  • Gender: Male
  • Kinesis
    • WebDev
  • SMF Version: 2.1
  • EhPortal Version: 1.22
Re: SimplePortal installation error
« Reply #1 on: January 20, 2017, 06:59:07 PM »

It is informing you that it can not perform the second edit to the ../index.php file.
Most likely it can not find its placement marker due to another modification's edit and/or manual edit.

You can do a manual edit but heed my advice regarding 3 things:
1) If you ever uninstall SP it will most likely require removing this manual edit
2) Be sure to use a proper PHP editor such as: notepad++ (DO NOT USE Microsoft notepad)
3) Make sure to do the edit properly and in the correct file after Simple Portal installation

Install Simple Portal, then edit index.php (using notepad++) located in your main forum directory

find:
Code: [Select]
// Is the forum in maintenance mode? (doesn't apply to administrators.)

replace with:
Code: [Select]
// Load SimplePortal.
sportal_init();

// Is the forum in maintenance mode? (doesn't apply to administrators.)

.. save the edit to the file.

Offline SweeX

  • Semi Newbie
  • *
  • Posts: 5
  • Gender: Male
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
Re: SimplePortal installation error
« Reply #2 on: January 22, 2017, 06:36:28 AM »
Thanks. I will try to fix this as soon as possible.  :)

Offline Kaede Akamatsu

  • Hero Member
  • *****
  • Posts: 2179
  • Gender: Male
  • $("div.content:dd").hide();
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
  • Elkarte Version: None
Re: SimplePortal installation error
« Reply #3 on: January 22, 2017, 09:27:33 PM »
If you would like, you can attach the index.php file here and we can perform the edit for you.

Offline ♦ Ninja ZX-10RR ♦

  • Spammer Hammer
  • Support
  • *
  • Posts: 1179
  • Gender: Male
  • Sniper Legends
    • Virtual Interactive Games Entertainment™
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
  • Elkarte Version: 1.0.6
Re: SimplePortal installation error
« Reply #4 on: January 23, 2017, 01:53:42 AM »
But please keep that as last resort, so at least you can learn how to do it and you will learn something useful, thanks! ;)
Have you tried SimplePortal Documentation before asking? ;)
F.A.Q.  English Support  |  Blocks Support
Fancy Feature idea ?!  |  Blocks Requests
Themes & Graphics

▼ My job! ▼

No PMs for support unless it's a paid request. Thank you! :)
#OpIsis

Offline SweeX

  • Semi Newbie
  • *
  • Posts: 5
  • Gender: Male
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
Re: SimplePortal installation error
« Reply #5 on: January 27, 2017, 03:16:47 PM »
Here is index.php.  :) (public_html)
If you guys can do it for me I would be most thankful.
I have really a lot of work so I currently can't find time to finish this.  :nervous-happy:

Offline Kaede Akamatsu

  • Hero Member
  • *****
  • Posts: 2179
  • Gender: Male
  • $("div.content:dd").hide();
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
  • Elkarte Version: None
Re: SimplePortal installation error
« Reply #6 on: January 27, 2017, 06:46:11 PM »
Here you go. The reason it was failing was because of a comment left over from a different portal mod.


Offline SweeX

  • Semi Newbie
  • *
  • Posts: 5
  • Gender: Male
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
Re: SimplePortal installation error
« Reply #7 on: January 27, 2017, 07:44:01 PM »
Here you go. The reason it was failing was because of a comment left over from a different portal mod.
Thank you soooo much  :)

Offline SweeX

  • Semi Newbie
  • *
  • Posts: 5
  • Gender: Male
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
Re: SimplePortal installation error
« Reply #8 on: January 28, 2017, 06:10:39 AM »
Now I have this when I try to replace index.php. I have backup so its not problem at all. Just want sp to work.  :)

"Fatal error: Call to undefined function sportal_init() in /home/a1000071/public_html/index.php on line 213"

Offline Kaede Akamatsu

  • Hero Member
  • *****
  • Posts: 2179
  • Gender: Male
  • $("div.content:dd").hide();
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
  • Elkarte Version: None
Re: SimplePortal installation error
« Reply #9 on: January 31, 2017, 12:33:10 AM »
Ah, right. Make sure to install SimplePortal and ignore the error. And THEN upload the file.

Offline ♦ Ninja ZX-10RR ♦

  • Spammer Hammer
  • Support
  • *
  • Posts: 1179
  • Gender: Male
  • Sniper Legends
    • Virtual Interactive Games Entertainment™
  • SMF Version: 2.0.13
  • SP Version: 2.3.6
  • Elkarte Version: 1.0.6
Re: SimplePortal installation error
« Reply #10 on: January 31, 2017, 03:13:08 AM »
Ah, right. Make sure to install SimplePortal and ignore the error. And THEN upload the file.
Errr NO. Unless you applied ALL the edits to index.php (and upon checking, you didn't), it's the other way around. The way you said will not apply all the other necessary edits to index.php, resulting in a broken installation.

The thing is, it causes a white page if you upload it before installing it, so you have to do it manually anyway.
Have you tried SimplePortal Documentation before asking? ;)
F.A.Q.  English Support  |  Blocks Support
Fancy Feature idea ?!  |  Blocks Requests
Themes & Graphics

▼ My job! ▼

No PMs for support unless it's a paid request. Thank you! :)
#OpIsis