collapse collapse

* Archive Notice

This is an Archive Forum.

The content in this forum may be out-of-date or have been superseded by newer information, and links in forum pages to other sites may not work. This forum contains archives for future reference.

Visit our thread at Simple Machines Forum for current support.

* User Info

 
 
Welcome, Guest. Please login or register.

* Who's Online

  • Dot Guests: 191
  • Dot Hidden: 0
  • Dot Users: 0

There aren't any users online.

* Shoutbox

Refresh History
  • Shoutbox is not for support!
  • {OCS}MasterSeal: Yup, Still adore SP
    April 21, 2019, 07:08:06 PM
  • {OCS}MasterSeal: STILL love SP :)
    November 24, 2018, 05:05:50 AM
  • ♦ Ninja ZX-10RR ♦: <3 aegersz
    September 13, 2018, 03:36:09 PM
  • aegersz: I STILL <3 LOVE SimplePortal
    September 13, 2018, 07:11:39 AM
  • aegersz: o LOVE you guys - Simple Portal rocks !
    May 09, 2018, 05:18:59 AM
  • Chen Zhen: our apologies for the site being down.. please read server issues topic
    March 22, 2018, 05:32:38 AM
  • {OCS}MasterSeal: LOL PLEASE forget I just posted that. I found the answer in my own dang post back in 2015. lol sorry!
    July 04, 2017, 10:47:55 PM
  • {OCS}MasterSeal: I know this SB isnt' for support, but I just have a general question. Who would I contact to find out where SP stores its block info? Is it DB driven or files? I searched the site but came up with nothing. probably my fault any insight is appreciated.
    July 04, 2017, 10:43:36 PM
  • ♦ Ninja ZX-10RR ♦: Excuse me but what does Simpleportal have to deal with that?
    February 05, 2017, 08:21:14 PM
  • WhiteEagle: of course IMHO that site appears to be dead :(
    February 04, 2017, 01:08:05 PM
  • WhiteEagle: If I can get that, then I'll use it for that site...
    February 04, 2017, 01:07:35 PM
  • WhiteEagle: decided to not use SMF for any projects, unless I can get a copy of the premium version of the fanfiction archive plugin
    February 04, 2017, 01:06:54 PM
  • expertdecisions: cloudflare
    January 28, 2017, 08:01:47 AM
  • aegersz: SM release 2.0.13 !
    January 12, 2017, 06:00:13 AM
  • raffo: Tks Emanuele, even if I didn't understand the fix :D
    November 07, 2016, 02:01:20 AM
  • emanuele: [link]
    November 01, 2016, 12:43:50 PM
  • emanuele: raffo: the English support board is a good place. ;)
    November 01, 2016, 12:43:38 PM
  • raffo: Where can I find the fix for the shoutbox?
    November 01, 2016, 05:06:09 AM
  • {OCS}MasterSeal: To the SP team, I make a point to come here and thank you as much as possible for your work.  so again, THANK YOU!
    October 28, 2016, 10:38:05 AM
  • emanuele: That's indeed funny, the limit is present only in the patch and not the full install.
    October 22, 2016, 06:14:58 PM

* Recent Posts

Adding Forums Button to Nav bar by jirapon
[August 01, 2019, 09:07:12 AM]


Re: Board Icons by ♦ Ninja ZX-10RR ♦
[July 30, 2019, 04:03:41 PM]


MOVED: Czech translation???? by ♦ Ninja ZX-10RR ♦
[July 30, 2019, 03:04:51 PM]


Board Icons by jirapon
[July 30, 2019, 07:28:44 AM]


Re: Thankyou Simpleportal, by ♦ Ninja ZX-10RR ♦
[July 29, 2019, 09:41:29 AM]

NEED HELP? If you're looking for support with Simple Portal, look no further than the Support Board!

Author Topic: blocks showing user avatars  (Read 3328 times)

0 Members and 1 Guest are viewing this topic.

Offline Chen Zhen

  • The Underdog
  • Operations Manager
  • *
  • Posts: 1351
  • Gender: Male
  • Kinesis
    • WebDev
  • SMF Version: 2.1
  • EhPortal Version: 1.22
blocks showing user avatars
« on: May 15, 2018, 01:09:12 PM »

re. any blocks showing user avatars

Most forums as of late use TLS/SSL ( https ) therefore some changes need to be made to how avatars are possibly rendered in blocks.
The current coding contains this for checking avatar url's:
Code: [Select]
stristr($row['avatar'], 'http://') ? ...

Imo the way it is being used (true or false) should be stripos instead of stristr & it should be checking both http & https.

ie.
create a new function to be used in the block php file (perhaps put in subs file)
Code: [Select]
function sp_stripos_array($string, $array)
{
$array = !is_array($array) ? array($array) : $array;
foreach ($array as $find)
if (stripos($string, $find) !== false)
return true;

return false;
}

.. and now replace existing code to be used like this:
Code: [Select]
sp_stripos_array($row['avatar'], array('http://', 'https://')) ? ...

Offline hulapyk

  • Newbie
  • Posts: 3
  • SMF Version: 2.0.15
  • SP Version: 2.3.7
Re: blocks showing user avatars
« Reply #1 on: November 15, 2018, 06:46:41 AM »
Is this what's causing url avatars to show as an error in the various blocks?
If so, should I replace all stristr($row['avatar'], 'http://') ? with your code?

Or is it another issue?

Thanks in advance.

Offline Chen Zhen

  • The Underdog
  • Operations Manager
  • *
  • Posts: 1351
  • Gender: Male
  • Kinesis
    • WebDev
  • SMF Version: 2.1
  • EhPortal Version: 1.22
Re: blocks showing user avatars
« Reply #2 on: November 15, 2018, 09:05:24 AM »
First you will need to add the new function to ie. /Sources/Subs-Portal.php & then you can replace the instances that were referenced.
I should make a tool to do this.

Offline hulapyk

  • Newbie
  • Posts: 3
  • SMF Version: 2.0.15
  • SP Version: 2.3.7
Re: blocks showing user avatars
« Reply #3 on: November 15, 2018, 09:22:30 AM »
You planning on doing that then? Then I'd rather wait  :P

Offline Chen Zhen

  • The Underdog
  • Operations Manager
  • *
  • Posts: 1351
  • Gender: Male
  • Kinesis
    • WebDev
  • SMF Version: 2.1
  • EhPortal Version: 1.22
Re: blocks showing user avatars
« Reply #4 on: November 15, 2018, 01:19:27 PM »
No, there is something wack about the SMF modification installer.
Their regexp option is not working and a search & replace of multiple instances of the same search is not working properly either.
You will have to do your own edits.

Use an editor such as notepad++ (notepad plus plus ... not MS notepad)
located here: https://notepad-plus-plus.org/



Open ../Sources/Subs-Portal.php with notepad++
hit CTRL-F

find what:
Code: [Select]
function sp_loadCalendarData($type, $low_date, $high_date = false)

add BEFORE above code:
Code: [Select]
function sp_stripos_array($string, $array)
{
$array = !is_array($array) ? array($array) : $array;
foreach ($array as $find)
if (stripos($string, $find) !== false)
return true;

return false;
}

save changes and close file



Open ../Sources/PortalBlocks.php with notepad++
hit CTRL-F
Click on "replace"

find what:
Code: [Select]
stristr($row['avatar'], 'http://')

replace with:
Code: [Select]
sp_stripos_array($row['avatar'], array('http://', 'https://'))

Use "replace all"
save changes and close file



Open ../Sources/PortalArticles.php with notepad++
hit CTRL-F
Click on "replace"

find what:
Code: [Select]
stristr($row['avatar'], 'http://')

replace with:
Code: [Select]
sp_stripos_array($row['avatar'], array('http://', 'https://'))

Use "replace all"
save changes and close file



The first edit is not a replacement, just add above the code I said to search for.
Make sure to use "replace all" for the 2nd & third edits because there are multiple replacements for those.
« Last Edit: November 15, 2018, 01:26:28 PM by Chen Zhen »

Offline hulapyk

  • Newbie
  • Posts: 3
  • SMF Version: 2.0.15
  • SP Version: 2.3.7
Re: blocks showing user avatars
« Reply #5 on: November 15, 2018, 01:47:11 PM »
Thanks a ton Chen Zhen :)
I'll give it a go later :)