collapse collapse

* User Info

 
 
Welcome, Guest. Please login or register.
Did you miss your activation email?

* Who's Online

  • Dot Guests: 187
  • Dot Hidden: 0
  • Dot Users: 0

There aren't any users online.

* Shoutbox

Refresh History
  • Shoutbox is not for support!
  • {OCS}MasterSeal: Yup, Still adore SP
    April 21, 2019, 07:08:06 PM
  • {OCS}MasterSeal: STILL love SP :)
    November 24, 2018, 05:05:50 AM
  • ♦ Ninja ZX-10RR ♦: <3 aegersz
    September 13, 2018, 03:36:09 PM
  • aegersz: I STILL <3 LOVE SimplePortal
    September 13, 2018, 07:11:39 AM
  • aegersz: o LOVE you guys - Simple Portal rocks !
    May 09, 2018, 05:18:59 AM
  • Chen Zhen: our apologies for the site being down.. please read server issues topic
    March 22, 2018, 05:32:38 AM
  • {OCS}MasterSeal: LOL PLEASE forget I just posted that. I found the answer in my own dang post back in 2015. lol sorry!
    July 04, 2017, 10:47:55 PM
  • {OCS}MasterSeal: I know this SB isnt' for support, but I just have a general question. Who would I contact to find out where SP stores its block info? Is it DB driven or files? I searched the site but came up with nothing. probably my fault any insight is appreciated.
    July 04, 2017, 10:43:36 PM
  • ♦ Ninja ZX-10RR ♦: Excuse me but what does Simpleportal have to deal with that?
    February 05, 2017, 08:21:14 PM
  • WhiteEagle: of course IMHO that site appears to be dead :(
    February 04, 2017, 01:08:05 PM
  • WhiteEagle: If I can get that, then I'll use it for that site...
    February 04, 2017, 01:07:35 PM
  • WhiteEagle: decided to not use SMF for any projects, unless I can get a copy of the premium version of the fanfiction archive plugin
    February 04, 2017, 01:06:54 PM
  • expertdecisions: cloudflare
    January 28, 2017, 08:01:47 AM
  • aegersz: SM release 2.0.13 !
    January 12, 2017, 06:00:13 AM
  • raffo: Tks Emanuele, even if I didn't understand the fix :D
    November 07, 2016, 02:01:20 AM
  • emanuele: [link]
    November 01, 2016, 12:43:50 PM
  • emanuele: raffo: the English support board is a good place. ;)
    November 01, 2016, 12:43:38 PM
  • raffo: Where can I find the fix for the shoutbox?
    November 01, 2016, 05:06:09 AM
  • {OCS}MasterSeal: To the SP team, I make a point to come here and thank you as much as possible for your work.  so again, THANK YOU!
    October 28, 2016, 10:38:05 AM
  • emanuele: That's indeed funny, the limit is present only in the patch and not the full install.
    October 22, 2016, 06:14:58 PM

* Recent Posts

Re: Avatar Bug by ♦ Ninja ZX-10RR ♦
[June 09, 2019, 07:14:27 PM]


Re: Avatar Bug by DollarSRV
[May 27, 2019, 07:47:32 AM]


MOVED: Avatar Bug by ♦ Ninja ZX-10RR ♦
[May 24, 2019, 04:03:59 PM]


Re: How to Add signature in Simple Portal? by elissaamsmart
[May 14, 2019, 07:19:57 AM]


Avatar Bug by Warning
[May 12, 2019, 03:15:54 PM]

Thanks for having an interest with our portal. If you have any requests for features, have a look at the Feature Requests board.

Author Topic: Custom profile bug?  (Read 2198 times)

0 Members and 1 Guest are viewing this topic.

Offline Nothingness

  • Jr. Member
  • **
  • Posts: 69
  • Gender: Male
  • I am...the architect of my own destruction...
  • SMF Version: 2 RC4
  • SP Version: 2.3.3
Custom profile bug?
« on: April 29, 2010, 10:56:00 PM »
As posted at SMF.org and sounds somewhat related to SP. Can I ask what mods are installed here? There might be a simliar mod we have that may have cause this somehow. It's not really a SP mod as I have tested it on my localhost.

http://www.simplemachines.org/community/index.php?topic=378770.0
"Do you wallow in self-pity, or do you learn to use the gifts God gave you and command fear and respect, and defend against those who would do us harm"

Offline [SiNaN]

  • Mr. SimplePortal
  • Developer
  • *
  • Posts: 6782
  • SMF Version: 2.0.15
  • SP Version: 2.3.7
Re: Custom profile bug?
« Reply #1 on: April 30, 2010, 02:39:19 AM »
Not an SMF but, but you could say it's SP bug, a very minor one though. You can only reproduce it if you have User Info block displayed in topics. That block will call loadMemberContext() without custom profile fields. So when it comes to loading the member context in posts, it won't load it again since it's already loaded by User Info block. This will fix it:

Source/PortalBlocks.php

Code: (Find) [Select]
loadMemberContext($user_info['id']);
Code: (Replace) [Select]
loadMemberContext($user_info['id'], true);
And slowly, you come to realize... It's all as it should be...

Offline Nothingness

  • Jr. Member
  • **
  • Posts: 69
  • Gender: Male
  • I am...the architect of my own destruction...
  • SMF Version: 2 RC4
  • SP Version: 2.3.3
Re: Custom profile bug?
« Reply #2 on: April 30, 2010, 02:55:48 AM »
Yay! Fixed! Another SP bug. ;D
« Last Edit: April 30, 2010, 09:09:36 PM by Dismal Shadow »
"Do you wallow in self-pity, or do you learn to use the gifts God gave you and command fear and respect, and defend against those who would do us harm"

Offline Nothingness

  • Jr. Member
  • **
  • Posts: 69
  • Gender: Male
  • I am...the architect of my own destruction...
  • SMF Version: 2 RC4
  • SP Version: 2.3.3
Re: Custom profile bug?
« Reply #3 on: April 30, 2010, 02:58:19 AM »
BTW...shouldn't this add to the tracker?
"Do you wallow in self-pity, or do you learn to use the gifts God gave you and command fear and respect, and defend against those who would do us harm"

Offline Eliana Tamerin

  • Comrade
  • *
  • Posts: 2889
  • Gender: Female
  • SMF Version: 2 RC2
  • SP Version: 2.3.2
Re: Custom profile bug?
« Reply #4 on: April 30, 2010, 08:59:14 PM »
Ms. Eliana Tamerin

It should be painfully obvious by now that I don't respond to support PMs. Don't send me PMs for support. They will be ignored and deleted, post on the Support Boards to get support.