collapse collapse

* Simple Portal Archived Forum

This is an Archive Forum.

The content in this forum may be out-of-date or have been superseded by newer information, and links in forum pages to other sites may not work.
This forum contains archives for future reference.

Visit our thread at Simple Machines Forum for current support.

* User Info

 
 
Welcome, Guest. Please login or register.

* Who's Online

  • Dot Guests: 90
  • Dot Hidden: 0
  • Dot Users: 0

There aren't any users online.

* Shoutbox

Refresh History
  • Shoutbox is not for support!
  • {OCS}MasterSeal: Yup, Still adore SP
    April 21, 2019, 07:08:06 PM
  • {OCS}MasterSeal: STILL love SP :)
    November 24, 2018, 05:05:50 AM
  • ♦ Ninja ZX-10RR ♦: <3 aegersz
    September 13, 2018, 03:36:09 PM
  • aegersz: I STILL <3 LOVE SimplePortal
    September 13, 2018, 07:11:39 AM
  • aegersz: o LOVE you guys - Simple Portal rocks !
    May 09, 2018, 05:18:59 AM
  • Chen Zhen: our apologies for the site being down.. please read server issues topic
    March 22, 2018, 05:32:38 AM
  • {OCS}MasterSeal: LOL PLEASE forget I just posted that. I found the answer in my own dang post back in 2015. lol sorry!
    July 04, 2017, 10:47:55 PM
  • {OCS}MasterSeal: I know this SB isnt' for support, but I just have a general question. Who would I contact to find out where SP stores its block info? Is it DB driven or files? I searched the site but came up with nothing. probably my fault any insight is appreciated.
    July 04, 2017, 10:43:36 PM
  • ♦ Ninja ZX-10RR ♦: Excuse me but what does Simpleportal have to deal with that?
    February 05, 2017, 08:21:14 PM
  • WhiteEagle: of course IMHO that site appears to be dead :(
    February 04, 2017, 01:08:05 PM
  • WhiteEagle: If I can get that, then I'll use it for that site...
    February 04, 2017, 01:07:35 PM
  • WhiteEagle: decided to not use SMF for any projects, unless I can get a copy of the premium version of the fanfiction archive plugin
    February 04, 2017, 01:06:54 PM
  • expertdecisions: cloudflare
    January 28, 2017, 08:01:47 AM
  • aegersz: SM release 2.0.13 !
    January 12, 2017, 06:00:13 AM
  • raffo: Tks Emanuele, even if I didn't understand the fix :D
    November 07, 2016, 02:01:20 AM
  • emanuele: [link]
    November 01, 2016, 12:43:50 PM
  • emanuele: raffo: the English support board is a good place. ;)
    November 01, 2016, 12:43:38 PM
  • raffo: Where can I find the fix for the shoutbox?
    November 01, 2016, 05:06:09 AM
  • {OCS}MasterSeal: To the SP team, I make a point to come here and thank you as much as possible for your work.  so again, THANK YOU!
    October 28, 2016, 10:38:05 AM
  • emanuele: That's indeed funny, the limit is present only in the patch and not the full install.
    October 22, 2016, 06:14:58 PM

* Recent Posts

Adding Forums Button to Nav bar by jirapon
[August 01, 2019, 09:07:12 AM]


Re: Board Icons by ♦ Ninja ZX-10RR ♦
[July 30, 2019, 04:03:41 PM]


MOVED: Czech translation???? by ♦ Ninja ZX-10RR ♦
[July 30, 2019, 03:04:51 PM]


Board Icons by jirapon
[July 30, 2019, 07:28:44 AM]


Re: Thankyou Simpleportal, by ♦ Ninja ZX-10RR ♦
[July 29, 2019, 09:41:29 AM]

Blocks speak! Do you have an interest in getting more blocks - or even making your own? The Blocks Board is for you!

Author Topic: instal de mod simple portal et bug menu  (Read 6632 times)

0 Members and 1 Guest are viewing this topic.

Offline ruliane

  • Semi Newbie
  • *
  • Posts: 9
  • SMF Version: 1.1.11
  • SP Version: 2.3.2
instal de mod simple portal et bug menu
« on: May 20, 2010, 09:54:35 AM »
Bonjour,

Je viens ici pour trouver réponse à un problème rencontré, je monte actuellement un petit site de guilde
avec SMF 1.1.11 sur lequel j'ai ajouté le mod simple portal 2.3.2 par installation automatique de paquet.

Au final tout s'est bien passé mais je n'arrivais plus à obtenir le bouton 'forum' celui de 'l'accueil' redirigeant
sur la page home de simple portal. J'ai déjà suivi certaine de vos conversation et est tenté de modifier le
fichier index.template.php mais dans le meilleur des cas je me retrouve avec deux boutons 'accueil' qui redirigent
sur le home de simple portal. Pour info j'utilise le thème défaut de SMF.

Si quelqu'un à une idée...Merci d'avance

Offline belgium-gravure

  • Full Member
  • ***
  • Posts: 127
  • Gender: Male
  • On a tous commencer part le bas de l'échelle
    • Forum de discution + divers
  • SMF Version: 2.0.10
  • SP Version: 2.3.6
Re: instal de mod simple portal et bug menu
« Reply #1 on: May 20, 2010, 03:11:49 PM »
Bonjour

tu utilise le theme part défault ou un theme perso?


Offline ruliane

  • Semi Newbie
  • *
  • Posts: 9
  • SMF Version: 1.1.11
  • SP Version: 2.3.2
Re: instal de mod simple portal et bug menu
« Reply #2 on: May 20, 2010, 03:31:57 PM »
Bonjour,

j'utilise le thème Asalet V7 fournit sur le sit SMF : http://custom.simplemachines.org/themes/index.php?lemma=1283

Offline belgium-gravure

  • Full Member
  • ***
  • Posts: 127
  • Gender: Male
  • On a tous commencer part le bas de l'échelle
    • Forum de discution + divers
  • SMF Version: 2.0.10
  • SP Version: 2.3.6
Re: instal de mod simple portal et bug menu
« Reply #3 on: May 20, 2010, 04:40:55 PM »
// Show the [forum] button.
   echo ($current_action=='forum' || $context['browser']['is_ie4']) ? '<td class="maintab_active_' . $first . '">&nbsp;</td>' : '' , '
            <td align="center" valign="top" class="maintab_' , $current_action == 'forum' ? 'active_back' : 'back' , '">
               <a href="', $scripturl, '">' , $txt['sp-forum'] , '</a>
            </td>' , $current_action == 'forum' ? '<td class="maintab_active_' . $last . '">&nbsp;</td>' : '';

Offline ruliane

  • Semi Newbie
  • *
  • Posts: 9
  • SMF Version: 1.1.11
  • SP Version: 2.3.2
Re: instal de mod simple portal et bug menu
« Reply #4 on: May 20, 2010, 05:09:11 PM »
Alors désormais j'ai le bouton home et le bouton forum mais tous les deux me mènent sur le home...
voici le code des deux boutons dans le index.template.php

// Show the [home] button.
   echo ($current_action=='home' || $context['browser']['is_ie4']) ? '<td class="maintab_active_' . $first . '">&nbsp;</td>' : '' , '
            <td align="center" valign="top" class="maintab_' , $current_action == 'home' ? 'active_back' : 'back' , '">
               <a href="', $scripturl, '">' , $txt[103] , '</a>
            </td>' , $current_action == 'home' ? '<td class="maintab_active_' . $last . '">&nbsp;</td>' : '';
         
     // Show the [forum] button.
   echo ($current_action=='forum' || $context['browser']['is_ie4']) ? '<td class="maintab_active_' . $first . '">&nbsp;</td>' : '' , '
            <td align="center" valign="top" class="maintab_' , $current_action == 'forum' ? 'active_back' : 'back' , '">
               <a href="', $scripturl, '">' , $txt['sp-forum'] , '</a>
            </td>' , $current_action == 'forum' ? '<td class="maintab_active_' . $last . '">&nbsp;</td>' : '';
« Last Edit: May 20, 2010, 05:11:16 PM by ruliane »

Offline AngelinaBelle

  • Comrade
  • *
  • Posts: 4870
  • Gender: Female
  • SMF Version: 2 RC3
  • SP Version: 2.3.2
Re: instal de mod simple portal et bug menu
« Reply #5 on: May 20, 2010, 07:26:00 PM »
Code: [Select]
<a href="', $scripturl . ($modSettings['sp_portal_mode'] == 1 ? '?action=forum' : ''), '">'
Code: [Select]
   // Show the [forum] button.
   if (empty($context['disable_sp']) && in_array($modSettings['sp_portal_mode'], array(1, 3)))
      echo ($current_action=='forum' || $context['browser']['is_ie4']) ? '<td class="maintab_active_' . $first . '">&nbsp;</td>' : '' , '
            <td valign="top" class="maintab_' , $current_action == 'forum' ? 'active_back' : 'back' , '">
               <a href="', $scripturl . ($modSettings['sp_portal_mode'] == 1 ? '?action=forum' : ''), '">', empty($txt['sp-forum']) ? 'Forum' : $txt['sp-forum'], '</a>
            </td>' , $current_action=='forum' ? '<td class="maintab_active_' . $last . '">&nbsp;</td>' : '';

 
En Anglais -- http://simpleportal.net/index.php?topic=148.msg707#msg707
Traduction?
 
Please to keep this website running, if you like SimplePortal, make a
one-time subscription. Thank you for your support.

Have you tried the SimplePortal documentation?

Offline ruliane

  • Semi Newbie
  • *
  • Posts: 9
  • SMF Version: 1.1.11
  • SP Version: 2.3.2
Re: instal de mod simple portal et bug menu
« Reply #6 on: May 20, 2010, 07:52:00 PM »
Ca marche impeccable, merci beaucoup à vous

Offline AngelinaBelle

  • Comrade
  • *
  • Posts: 4870
  • Gender: Female
  • SMF Version: 2 RC3
  • SP Version: 2.3.2
Re: instal de mod simple portal et bug menu
« Reply #7 on: May 20, 2010, 08:18:52 PM »
Bien.
 
Si on peut faire un traduction des tutorials -- ça serait bien, non?
Please to keep this website running, if you like SimplePortal, make a
one-time subscription. Thank you for your support.

Have you tried the SimplePortal documentation?

Offline ruliane

  • Semi Newbie
  • *
  • Posts: 9
  • SMF Version: 1.1.11
  • SP Version: 2.3.2
Re: instal de mod simple portal et bug menu
« Reply #8 on: May 20, 2010, 09:57:51 PM »
Bonjour, je re ouvre ce sujet car en installant un mod de galerie : http://custom.simplemachines.org/mods/index.php?mod=473
je me suis re retrouver face a un pb de bouton...

je ne sais pas si vous gérez cela, ca ne fait pas partie de Simple Portal mais l'erreur doit être du même type que ma précédente...
Voici mon code index.template.php, le bouton devrait apparaitre entre "Membre" et "connexion/déconnexion"

// the [SMF Gallery] button
   if ($context['allow_smfgallery_view'])
      echo ($current_action == 'gallery' || $context['browser']['is_ie4']) ? '<td class="maintab_active_' . $first . '">&nbsp;</td>' : '' , '
            <td align="center" valign="top" class="maintab_' , $current_action == 'gallery' ? 'active_back' : 'back' , '">
               <a href="', $scripturl, '?action=gallery">' , $txt['smfgallery_menu']  , '</a>
            </td>' , $current_action == 'gallery' ? '<td class="maintab_active_' . $last . '">&nbsp;</td>' : '';

Si vous avez une petite idée merci d'avance.
« Last Edit: May 20, 2010, 10:08:25 PM by ruliane »

Offline AngelinaBelle

  • Comrade
  • *
  • Posts: 4870
  • Gender: Female
  • SMF Version: 2 RC3
  • SP Version: 2.3.2
Re: instal de mod simple portal et bug menu
« Reply #9 on: May 21, 2010, 08:42:50 AM »
Ce code -- vous l'avez copier à partir de le thème default? Celui-là ne marche pas?

Qu'est-ce qui se passe quand vous l'utiliser?
 
(S'il vous plaît parler lentement et à voix haute. Je suis Anglophone :)
 
Please to keep this website running, if you like SimplePortal, make a
one-time subscription. Thank you for your support.

Have you tried the SimplePortal documentation?

Offline belgium-gravure

  • Full Member
  • ***
  • Posts: 127
  • Gender: Male
  • On a tous commencer part le bas de l'échelle
    • Forum de discution + divers
  • SMF Version: 2.0.10
  • SP Version: 2.3.6
Re: instal de mod simple portal et bug menu
« Reply #10 on: May 21, 2010, 04:15:06 PM »
// the [SMF Gallery] button
   if ($context['allow_smfgallery_view'])
      echo ($current_action == 'gallery' || $context['browser']['is_ie4']) ? '<td class="maintab_active_' . $first . '">&nbsp;</td>' : '' , '
            <td align="center" valign="top" class="maintab_' , $current_action == 'gallery' ? 'active_back' : 'back' , '">
               <a href="', $scripturl, '?action=gallery">' , $txt['smfgallery_menu']  , '</a>
            </td>' , $current_action == 'gallery' ? '<td class="maintab_active_' . $last . '">&nbsp;</td>' : '';



Si vous avez une petite idée merci d'avance.
bonsoir peut me mettre en annex ton fichier index-template de theme perso svp

Offline ruliane

  • Semi Newbie
  • *
  • Posts: 9
  • SMF Version: 1.1.11
  • SP Version: 2.3.2
Re: instal de mod simple portal et bug menu
« Reply #11 on: May 21, 2010, 05:11:53 PM »
re bonjour, je te joint le fichier index.template.php mais c'est celui du thème default qui est utilisé.

j'ai copié le code dans index.template.php et quand je l'utilise ca ne me rajoute pas de boutons dans le menu et ca m'ajoute un ligne noire non cliquable dans le menu de la partie admin.

Offline belgium-gravure

  • Full Member
  • ***
  • Posts: 127
  • Gender: Male
  • On a tous commencer part le bas de l'échelle
    • Forum de discution + divers
  • SMF Version: 2.0.10
  • SP Version: 2.3.6
Re: instal de mod simple portal et bug menu
« Reply #12 on: May 22, 2010, 03:19:52 AM »
ok je vait voir ce que je peut faire  ;)

Offline ruliane

  • Semi Newbie
  • *
  • Posts: 9
  • SMF Version: 1.1.11
  • SP Version: 2.3.2
Re: instal de mod simple portal et bug menu
« Reply #13 on: May 22, 2010, 08:33:03 AM »
Merci c'est très gentil, je suis sur que c'est une bêtise toute bête en plus...comme souvent.

Offline belgium-gravure

  • Full Member
  • ***
  • Posts: 127
  • Gender: Male
  • On a tous commencer part le bas de l'échelle
    • Forum de discution + divers
  • SMF Version: 2.0.10
  • SP Version: 2.3.6
Re: instal de mod simple portal et bug menu
« Reply #14 on: May 22, 2010, 11:48:50 AM »
Merci c'est très gentil, je suis sur que c'est une bêtise toute bête en plus...comme souvent.

Faut prendre sont temp  ;) et bien suivre les tuto

tu avait oublier ça "' gallery', " a ce niveau là
Code: [Select]
if (in_array($context['current_action'], array([color=red]'gallery',[/color]'search', 'admin', 'calendar', 'profile', 'mlist', 'register', 'login', 'help', 'pm', 'forum', 'spadmin')))

Offline ruliane

  • Semi Newbie
  • *
  • Posts: 9
  • SMF Version: 1.1.11
  • SP Version: 2.3.2
Re: instal de mod simple portal et bug menu
« Reply #15 on: May 22, 2010, 12:44:19 PM »
bonjour, le code que tu a rajouté m'a permit d'avoir la section gallery dans la fenêtre admin mais toujours rien sur sur le menu...

Offline belgium-gravure

  • Full Member
  • ***
  • Posts: 127
  • Gender: Male
  • On a tous commencer part le bas de l'échelle
    • Forum de discution + divers
  • SMF Version: 2.0.10
  • SP Version: 2.3.6
Re: instal de mod simple portal et bug menu
« Reply #16 on: May 22, 2010, 07:17:18 PM »
bonsoir

ok c'est d éjà un debut  ;P

Ps: garde a chaque fois l'ancienne version en backup part sécurité
« Last Edit: May 23, 2010, 03:41:21 PM by belgium-gravure »

Offline ruliane

  • Semi Newbie
  • *
  • Posts: 9
  • SMF Version: 1.1.11
  • SP Version: 2.3.2
Re: instal de mod simple portal et bug menu
« Reply #17 on: May 27, 2010, 05:04:24 AM »
oui, j'ai toujours la version du fichier php avant les modif pour la mise en place de la galery.
toujours pas de bouton dans le menu après diverses manip...

Offline AngelinaBelle

  • Comrade
  • *
  • Posts: 4870
  • Gender: Female
  • SMF Version: 2 RC3
  • SP Version: 2.3.2
Re: instal de mod simple portal et bug menu
« Reply #18 on: May 27, 2010, 08:05:06 AM »
Peut-être, il y a un autre problème?
 
Qu'est-ce que se passe comme vous utilisez le URL .../index.php?action=gallery
Le gallery SMF -- c'est là?
Please to keep this website running, if you like SimplePortal, make a
one-time subscription. Thank you for your support.

Have you tried the SimplePortal documentation?

Offline belgium-gravure

  • Full Member
  • ***
  • Posts: 127
  • Gender: Male
  • On a tous commencer part le bas de l'échelle
    • Forum de discution + divers
  • SMF Version: 2.0.10
  • SP Version: 2.3.6
Re: instal de mod simple portal et bug menu
« Reply #19 on: May 27, 2010, 10:28:29 AM »
oui, j'ai toujours la version du fichier php avant les modif pour la mise en place de la galery.
toujours pas de bouton dans le menu après diverses manip...
ok

on va voir autrement

peut tu me passer des access admin et ftp via message privé , si tu veut bien) , j'aurai plus vite fait ainsi  ;)

Offline AngelinaBelle

  • Comrade
  • *
  • Posts: 4870
  • Gender: Female
  • SMF Version: 2 RC3
  • SP Version: 2.3.2
Re: instal de mod simple portal et bug menu
« Reply #20 on: June 03, 2010, 12:14:16 PM »
Bonsoir.
Ça va bien?
Please to keep this website running, if you like SimplePortal, make a
one-time subscription. Thank you for your support.

Have you tried the SimplePortal documentation?