collapse collapse

* Simple Portal Archived Forum

This is an Archive Forum.

The content in this forum may be out-of-date or have been superseded by newer information, and links in forum pages to other sites may not work.
This forum contains archives for future reference.

Visit our thread at Simple Machines Forum for current support.

SMF 2.1 users: EhPortal is a ported version of Simple Portal specifically designed for the SMF 2.1 branch.
Please visit web-develop.ca to download EhPortal and for its support.

* User Info

 
 
Welcome, Guest. Please login or register.

* Who's Online

  • Dot Guests: 156
  • Dot Hidden: 0
  • Dot Users: 0

There aren't any users online.

* Shoutbox

Refresh History
  • Shoutbox is not for support!
  • {OCS}MasterSeal: Yup, Still adore SP
    April 21, 2019, 07:08:06 PM
  • {OCS}MasterSeal: STILL love SP :)
    November 24, 2018, 05:05:50 AM
  • ♦ Ninja ZX-10RR ♦: <3 aegersz
    September 13, 2018, 03:36:09 PM
  • aegersz: I STILL <3 LOVE SimplePortal
    September 13, 2018, 07:11:39 AM
  • aegersz: o LOVE you guys - Simple Portal rocks !
    May 09, 2018, 05:18:59 AM
  • Chen Zhen: our apologies for the site being down.. please read server issues topic
    March 22, 2018, 05:32:38 AM
  • {OCS}MasterSeal: LOL PLEASE forget I just posted that. I found the answer in my own dang post back in 2015. lol sorry!
    July 04, 2017, 10:47:55 PM
  • {OCS}MasterSeal: I know this SB isnt' for support, but I just have a general question. Who would I contact to find out where SP stores its block info? Is it DB driven or files? I searched the site but came up with nothing. probably my fault any insight is appreciated.
    July 04, 2017, 10:43:36 PM
  • ♦ Ninja ZX-10RR ♦: Excuse me but what does Simpleportal have to deal with that?
    February 05, 2017, 08:21:14 PM
  • WhiteEagle: of course IMHO that site appears to be dead :(
    February 04, 2017, 01:08:05 PM
  • WhiteEagle: If I can get that, then I'll use it for that site...
    February 04, 2017, 01:07:35 PM
  • WhiteEagle: decided to not use SMF for any projects, unless I can get a copy of the premium version of the fanfiction archive plugin
    February 04, 2017, 01:06:54 PM
  • expertdecisions: cloudflare
    January 28, 2017, 08:01:47 AM
  • aegersz: SM release 2.0.13 !
    January 12, 2017, 06:00:13 AM
  • raffo: Tks Emanuele, even if I didn't understand the fix :D
    November 07, 2016, 02:01:20 AM
  • emanuele: [link]
    November 01, 2016, 12:43:50 PM
  • emanuele: raffo: the English support board is a good place. ;)
    November 01, 2016, 12:43:38 PM
  • raffo: Where can I find the fix for the shoutbox?
    November 01, 2016, 05:06:09 AM
  • {OCS}MasterSeal: To the SP team, I make a point to come here and thank you as much as possible for your work.  so again, THANK YOU!
    October 28, 2016, 10:38:05 AM
  • emanuele: That's indeed funny, the limit is present only in the patch and not the full install.
    October 22, 2016, 06:14:58 PM

* Recent Posts

Adding Forums Button to Nav bar by jirapon
[August 01, 2019, 09:07:12 AM]


Re: Board Icons by ♦ Ninja ZX-10RR ♦
[July 30, 2019, 04:03:41 PM]


MOVED: Czech translation???? by ♦ Ninja ZX-10RR ♦
[July 30, 2019, 03:04:51 PM]


Board Icons by jirapon
[July 30, 2019, 07:28:44 AM]


Re: Thankyou Simpleportal, by ♦ Ninja ZX-10RR ♦
[July 29, 2019, 09:41:29 AM]

If you're interested in helping other members with support requests, consider joining the Community Support Helpers group.

Author Topic: SimplePortal 2.3.3- SimplePortal Tab in Administration Center is not there  (Read 9787 times)

0 Members and 1 Guest are viewing this topic.

Offline 94AmTranVolunteer

  • Semi Newbie
  • *
  • Posts: 28
  • SMF Version: 2 RC4
  • SP Version: 2.3.3
Hello. I just installed SimplePortal Sucessfully, however the Tab for SimplePortal in the Administration Center is not there. Please Help.

I am using SimplePortal Version 2.3.3 and SMF 2.0 RC4
SMF Version: SMF 2.0 RC5 | SimplePortal Version: SimplePortal 2.3.3

Offline AngelinaBelle

  • Comrade
  • *
  • Posts: 4870
  • Gender: Female
  • SMF Version: 2 RC3
  • SP Version: 2.3.2
Re: SimplePortal 2.3.3- SimplePortal Tab in Administration Center is not there
« Reply #1 on: February 03, 2011, 07:27:59 AM »
Often, when mod installation fails because of permission issues, SMF's Package Manager simply does not detect the problem, and reports a successful installation.
 
Please try index.php?action=admin;area=portalconfig at your forum to find out for sure if SimplePortal is there.
 
Next, please try the suggestions in solving install problems: http://simpleportal.net/index.php?action=docs;area=solving_install_problems
 
Then please reply here to let us know how it went.
 
 
Please to keep this website running, if you like SimplePortal, make a
one-time subscription. Thank you for your support.

Have you tried the SimplePortal documentation?

Offline 94AmTranVolunteer

  • Semi Newbie
  • *
  • Posts: 28
  • SMF Version: 2 RC4
  • SP Version: 2.3.3
Re: SimplePortal 2.3.3- SimplePortal Tab in Administration Center is not there
« Reply #2 on: February 03, 2011, 01:44:31 PM »
When I put in index.php?action=admin;area=portalconfig and pressed load, it just redirected me to the Administration Center Page.
SMF Version: SMF 2.0 RC5 | SimplePortal Version: SimplePortal 2.3.3

Offline AngelinaBelle

  • Comrade
  • *
  • Posts: 4870
  • Gender: Female
  • SMF Version: 2 RC3
  • SP Version: 2.3.2
Re: SimplePortal 2.3.3- SimplePortal Tab in Administration Center is not there
« Reply #3 on: February 03, 2011, 02:31:19 PM »
That confirms that Package Manager failed, but doesn't realize it.
SimplePortal is not installed.
 
I hope that the solution to your problem is in the support document  http://simpleportal.net/index.php?action=docs;area=solving_install_problems

Please give it a try and let us know how it works out for you.
Please to keep this website running, if you like SimplePortal, make a
one-time subscription. Thank you for your support.

Have you tried the SimplePortal documentation?

Offline 94AmTranVolunteer

  • Semi Newbie
  • *
  • Posts: 28
  • SMF Version: 2 RC4
  • SP Version: 2.3.3
Re: SimplePortal 2.3.3- SimplePortal Tab in Administration Center is not there
« Reply #4 on: February 03, 2011, 02:47:34 PM »
I am sorry but I don't know what to do. Can you tell me how I can fix this problem?
SMF Version: SMF 2.0 RC5 | SimplePortal Version: SimplePortal 2.3.3

Offline Nathaniel

  • Comrade
  • *
  • Posts: 5203
  • Gender: Male
    • Verbtest.com
  • SMF Version: 2 RC4
  • SP Version: 2.3.3
Re: SimplePortal 2.3.3- SimplePortal Tab in Administration Center is not there
« Reply #5 on: February 03, 2011, 07:03:17 PM »
The support document that Angelina linked you to, explains how to fix the problem. Please go through that document and try the suggestions for fixing the problem that it lists.

Another link to the relevant page: http://simpleportal.net/index.php?action=docs;area=solving_install_problems

SMF Friend (Former Support Specialist) | SimplePortal DeveloperMy SMF Mods | SimplePortal"Quis custodiet ipsos custodes?" - Who will Guard the Guards?Please don't send me ANY support related PMs. I will just delete them.

Offline 94AmTranVolunteer

  • Semi Newbie
  • *
  • Posts: 28
  • SMF Version: 2 RC4
  • SP Version: 2.3.3
Re: SimplePortal 2.3.3- SimplePortal Tab in Administration Center is not there
« Reply #6 on: February 03, 2011, 07:27:45 PM »
I am sorry but the Doc's are confusing.
SMF Version: SMF 2.0 RC5 | SimplePortal Version: SimplePortal 2.3.3

Offline AngelinaBelle

  • Comrade
  • *
  • Posts: 4870
  • Gender: Female
  • SMF Version: 2 RC3
  • SP Version: 2.3.2
Re: SimplePortal 2.3.3- SimplePortal Tab in Administration Center is not there
« Reply #7 on: February 04, 2011, 08:29:19 AM »
That's OK.  Let's take it one step at a time.
The section you want is on setting permissions, and possibly creating a temp directory.
 
Please start at the beginning, and be very specific about the part where you get lost, and cannot follow the advice any longer.  I can explain more, and maybe even make the doc easier to understand for the next person.
Please to keep this website running, if you like SimplePortal, make a
one-time subscription. Thank you for your support.

Have you tried the SimplePortal documentation?

Offline 94AmTranVolunteer

  • Semi Newbie
  • *
  • Posts: 28
  • SMF Version: 2 RC4
  • SP Version: 2.3.3
Re: SimplePortal 2.3.3- SimplePortal Tab in Administration Center is not there
« Reply #8 on: February 04, 2011, 01:51:53 PM »
Okay. I have already created a "temp" directory, and changed the CHMOD to 777. I don't really know what could be wrong. I read the paragraph's on setting permission's, but I still got confused. The Whole Paragraph is confusing because I already created a temp directory and changed CHMOD to 777.
SMF Version: SMF 2.0 RC5 | SimplePortal Version: SimplePortal 2.3.3

Offline AngelinaBelle

  • Comrade
  • *
  • Posts: 4870
  • Gender: Female
  • SMF Version: 2 RC3
  • SP Version: 2.3.2
Re: SimplePortal 2.3.3- SimplePortal Tab in Administration Center is not there
« Reply #9 on: February 04, 2011, 04:18:00 PM »
Did you try the install again after that?
What happened?
 
* Did you do the "all files and directories" thing with the CHMOD?
 
Please to keep this website running, if you like SimplePortal, make a
one-time subscription. Thank you for your support.

Have you tried the SimplePortal documentation?

Offline 94AmTranVolunteer

  • Semi Newbie
  • *
  • Posts: 28
  • SMF Version: 2 RC4
  • SP Version: 2.3.3
Re: SimplePortal 2.3.3- SimplePortal Tab in Administration Center is not there
« Reply #10 on: February 04, 2011, 07:15:19 PM »
No, I did not.
SMF Version: SMF 2.0 RC5 | SimplePortal Version: SimplePortal 2.3.3

Offline AngelinaBelle

  • Comrade
  • *
  • Posts: 4870
  • Gender: Female
  • SMF Version: 2 RC3
  • SP Version: 2.3.2
Re: SimplePortal 2.3.3- SimplePortal Tab in Administration Center is not there
« Reply #11 on: February 06, 2011, 01:05:50 PM »
Please try resetting permissions in all your forum directories.  SMf provides a way to do that.  the Package Manager has to put files in the directories, and make changes to the files.  So it has to have permission to write to files and directories.
 
Then, try the install again.
Please to keep this website running, if you like SimplePortal, make a
one-time subscription. Thank you for your support.

Have you tried the SimplePortal documentation?

Offline 94AmTranVolunteer

  • Semi Newbie
  • *
  • Posts: 28
  • SMF Version: 2 RC4
  • SP Version: 2.3.3
Re: SimplePortal 2.3.3- SimplePortal Tab in Administration Center is not there
« Reply #12 on: February 06, 2011, 04:09:55 PM »
Could you please walk me through it?
SMF Version: SMF 2.0 RC5 | SimplePortal Version: SimplePortal 2.3.3

Offline AngelinaBelle

  • Comrade
  • *
  • Posts: 4870
  • Gender: Female
  • SMF Version: 2 RC3
  • SP Version: 2.3.2
Re: SimplePortal 2.3.3- SimplePortal Tab in Administration Center is not there
« Reply #13 on: February 07, 2011, 09:01:22 AM »
OK. I'll try to walk you through. You tell me what you have and haven't done already. And please let me know what is unclear in the documentation so I can fix it up for the next time someone needs to do this.
 
http://simpleportal.net/index.php?action=docs;area=solving_install_problems
File and Directory Permission Problems
One common reason for SMF to say it installed a mod when it hasn't is a permission problem.
* Please read What is chmod?
* Also, please read http://docs.simplemachines.org/index.php?topic=363.0
* SMF 2RC4 has "File Permissions" under Packages (at ?action=admin;area=packages;sa=perms) to help with this. Under "Use predefined permission profile", click the radio button next to "Use predefined permission profile" and select "Free -- all files writable" (after filling in FTP information). Then hit the "Make Changes" button.
Please to keep this website running, if you like SimplePortal, make a
one-time subscription. Thank you for your support.

Have you tried the SimplePortal documentation?

Offline 94AmTranVolunteer

  • Semi Newbie
  • *
  • Posts: 28
  • SMF Version: 2 RC4
  • SP Version: 2.3.3
Re: SimplePortal 2.3.3- SimplePortal Tab in Administration Center is not there
« Reply #14 on: February 07, 2011, 06:41:39 PM »
I did all that exactly how it said, however, when I reinstalled it, it didn't work.  The Problem is still there.
SMF Version: SMF 2.0 RC5 | SimplePortal Version: SimplePortal 2.3.3

Offline AngelinaBelle

  • Comrade
  • *
  • Posts: 4870
  • Gender: Female
  • SMF Version: 2 RC3
  • SP Version: 2.3.2
Re: SimplePortal 2.3.3- SimplePortal Tab in Administration Center is not there
« Reply #15 on: February 08, 2011, 11:03:09 AM »
Some time ago, another SMF user had a similar problem.
He eventually figured out that his host did something strange when he used chmod 777. He could chmod to 777, but install still would not work -- these permission settings were not obeyed when the action was initiated via the web (and the webserver). Some hosts do this to try to protect you from hackers.
 
Eventually, he found he needed to use another setting.
 
You could contact your host to explain that SMF's package manager is supposed to move, remove, replace, and edit files, all done in php and initiated via the web.  Your host could explain to you the chmod settings you can use to make this all possible.
 
Or you could experiment with different chmod settings: 644, 664, or even 645 might work.
Please to keep this website running, if you like SimplePortal, make a
one-time subscription. Thank you for your support.

Have you tried the SimplePortal documentation?

Offline 94AmTranVolunteer

  • Semi Newbie
  • *
  • Posts: 28
  • SMF Version: 2 RC4
  • SP Version: 2.3.3
Re: SimplePortal 2.3.3- SimplePortal Tab in Administration Center is not there
« Reply #16 on: February 08, 2011, 04:57:08 PM »
Sure. I'll contact them A.S.A.P.
SMF Version: SMF 2.0 RC5 | SimplePortal Version: SimplePortal 2.3.3

Offline 94AmTranVolunteer

  • Semi Newbie
  • *
  • Posts: 28
  • SMF Version: 2 RC4
  • SP Version: 2.3.3
Re: SimplePortal 2.3.3- SimplePortal Tab in Administration Center is not there
« Reply #17 on: February 08, 2011, 05:05:06 PM »
I have contacted the host via posting a support ticket.

This is what i put in the support ticket:

I recently put a SMF 2.0 RC4 Forum on my website last week. However, today, I tried installing a SMF Mod, SimplePortal, and it did not work. I contacted SimplePortal via their support forum and said to contact host. I did everything SimplePortal told me to do. I had changed the CHMOD number on the directory for simple portal to 777, however, it is not working. I was told to CHMOD it to 777 unless the server has a different setting. Could you help me any?
SMF Version: SMF 2.0 RC5 | SimplePortal Version: SimplePortal 2.3.3

Offline AngelinaBelle

  • Comrade
  • *
  • Posts: 4870
  • Gender: Female
  • SMF Version: 2 RC3
  • SP Version: 2.3.2
Re: SimplePortal 2.3.3- SimplePortal Tab in Administration Center is not there
« Reply #18 on: February 09, 2011, 09:49:24 AM »
I hope your host will be able to answer your questions.
In the meantime, you could certainly try the other chmod settings, to see what you learn.
Please to keep this website running, if you like SimplePortal, make a
one-time subscription. Thank you for your support.

Have you tried the SimplePortal documentation?

Offline 94AmTranVolunteer

  • Semi Newbie
  • *
  • Posts: 28
  • SMF Version: 2 RC4
  • SP Version: 2.3.3
Re: SimplePortal 2.3.3- SimplePortal Tab in Administration Center is not there
« Reply #19 on: February 19, 2011, 11:59:06 AM »
Its not resolved. I upgraded to SMF 2.0 RC5. I was going to use TinyPortal, but TinyPortal is in a Release Candiate and has a lot of bugs. So I decided to go with SimplePortal again. Could you give me a link to the topic someone else had posted who had the same problem?
SMF Version: SMF 2.0 RC5 | SimplePortal Version: SimplePortal 2.3.3

Offline AngelinaBelle

  • Comrade
  • *
  • Posts: 4870
  • Gender: Female
  • SMF Version: 2 RC3
  • SP Version: 2.3.2
Please to keep this website running, if you like SimplePortal, make a
one-time subscription. Thank you for your support.

Have you tried the SimplePortal documentation?

Offline 94AmTranVolunteer

  • Semi Newbie
  • *
  • Posts: 28
  • SMF Version: 2 RC4
  • SP Version: 2.3.3
Re: SimplePortal 2.3.3- SimplePortal Tab in Administration Center is not there
« Reply #21 on: February 21, 2011, 06:08:53 PM »
Well, looks like none of those topics help. Can Anyone tell me how to fully install this and get it fully up and running so I can work on my Portal.
SMF Version: SMF 2.0 RC5 | SimplePortal Version: SimplePortal 2.3.3

Offline AngelinaBelle

  • Comrade
  • *
  • Posts: 4870
  • Gender: Female
  • SMF Version: 2 RC3
  • SP Version: 2.3.2
Re: SimplePortal 2.3.3- SimplePortal Tab in Administration Center is not there
« Reply #22 on: February 22, 2011, 04:23:57 PM »
There are 3 parts to the install
1) edit existing SMF files
2) copy SimplePortal files into place
3) Put data on the database.
 
One of these steps is failing. Probably 1) or 2) is failing because of permission problems.
But the Package Manager has not noticed the problem.
 
Please look in index.php for "sp_action", just to see if that edit succeeded.
Then, please look in Sources for a file called PortalBlocks.php and tell me if it is there.
 
 
Please to keep this website running, if you like SimplePortal, make a
one-time subscription. Thank you for your support.

Have you tried the SimplePortal documentation?

Offline 94AmTranVolunteer

  • Semi Newbie
  • *
  • Posts: 28
  • SMF Version: 2 RC4
  • SP Version: 2.3.3
Re: SimplePortal 2.3.3- SimplePortal Tab in Administration Center is not there
« Reply #23 on: February 22, 2011, 08:46:52 PM »
okay, will do
SMF Version: SMF 2.0 RC5 | SimplePortal Version: SimplePortal 2.3.3

Offline 94AmTranVolunteer

  • Semi Newbie
  • *
  • Posts: 28
  • SMF Version: 2 RC4
  • SP Version: 2.3.3
Re: SimplePortal 2.3.3- SimplePortal Tab in Administration Center is not there
« Reply #24 on: February 22, 2011, 09:00:05 PM »
None of those files are there.

However, this problem isn't just with this mod. It has also happened with Global Headers and Footers and TinyPortal when I tried to install TinyPortal [TinyPortal has a problem and is still in Release Candidate mode, so I decided to go with SimplePortal].
SMF Version: SMF 2.0 RC5 | SimplePortal Version: SimplePortal 2.3.3

Offline AngelinaBelle

  • Comrade
  • *
  • Posts: 4870
  • Gender: Female
  • SMF Version: 2 RC3
  • SP Version: 2.3.2
Re: SimplePortal 2.3.3- SimplePortal Tab in Administration Center is not there
« Reply #25 on: February 23, 2011, 09:51:07 AM »
You are having a permission problem that is preventing the Package Manager from installing mods.
This is not a SimplePortal problem, per se.
The Package Manager checked to see that the directory is writable, so it assumes that when it issues the command to copy the files into the directory, it is going to work.
But then it does not work, and Package Manager doesn't know that it didn't work, so it thinks the install was successful.
 
Many other SMF users have reported problems like this.
Usually, they have needed to sort something out with their host.
 
Either the host used suPHP (so the php "user" is the website owner), but the files don't belong to the correct user, or something else is set up improperly.
 
You will most likely have to talk to your host. You may get valuable information on package installation failure by searching at the simplemachines.org site.
Please to keep this website running, if you like SimplePortal, make a
one-time subscription. Thank you for your support.

Have you tried the SimplePortal documentation?

Offline 94AmTranVolunteer

  • Semi Newbie
  • *
  • Posts: 28
  • SMF Version: 2 RC4
  • SP Version: 2.3.3
Re: SimplePortal 2.3.3- SimplePortal Tab in Administration Center is not there
« Reply #26 on: February 24, 2011, 04:13:40 PM »
Is there any more help. How can I fix it, and if I don't fix it, does that mean my website won't have a SimplePortal?
SMF Version: SMF 2.0 RC5 | SimplePortal Version: SimplePortal 2.3.3

Offline AngelinaBelle

  • Comrade
  • *
  • Posts: 4870
  • Gender: Female
  • SMF Version: 2 RC3
  • SP Version: 2.3.2
Re: SimplePortal 2.3.3- SimplePortal Tab in Administration Center is not there
« Reply #27 on: February 24, 2011, 04:46:37 PM »
I think you need to discuss this problem with your host.  Something is not set up right for you.
Please to keep this website running, if you like SimplePortal, make a
one-time subscription. Thank you for your support.

Have you tried the SimplePortal documentation?

Offline AngelinaBelle

  • Comrade
  • *
  • Posts: 4870
  • Gender: Female
  • SMF Version: 2 RC3
  • SP Version: 2.3.2
Re: SimplePortal 2.3.3- SimplePortal Tab in Administration Center is not there
« Reply #28 on: February 28, 2011, 07:19:21 AM »
Another user just solved a similar problem this way:
The problem was that I had old themes that no longer existed. Once I deleted them, it installed fine.
Please to keep this website running, if you like SimplePortal, make a
one-time subscription. Thank you for your support.

Have you tried the SimplePortal documentation?

Offline urgent

  • Newbie
  • Posts: 2
  • SMF Version: 2 RC5
  • SP Version: None
Re: SimplePortal 2.3.3- SimplePortal Tab in Administration Center is not there
« Reply #29 on: October 02, 2011, 12:21:17 AM »
Also an .htaccess file could cause problems. I had an .htaccess file in my webroot. Eventhough SMF was in a subdirectory of my webroot, the top level .htaccess was affecting the install.

Offline AngelinaBelle

  • Comrade
  • *
  • Posts: 4870
  • Gender: Female
  • SMF Version: 2 RC3
  • SP Version: 2.3.2
Re: SimplePortal 2.3.3- SimplePortal Tab in Administration Center is not there
« Reply #30 on: October 05, 2011, 10:14:23 AM »
Let's take this one step at a time, then.

What chmod settings are you using currently?
Please to keep this website running, if you like SimplePortal, make a
one-time subscription. Thank you for your support.

Have you tried the SimplePortal documentation?

 

SimplePortal 2.3.7 © 2008-2021, SimplePortal